Results 1 to 5 of 5

Thread: Logger stopped after upgrade to 5.0.7

  1. #1
    Join Date
    Mar 2007
    Location
    Plymouth, uk
    Posts
    93
    Rep Power
    8

    Default Logger stopped after upgrade to 5.0.7

    Hello
    I upgraded 5.0.6 NE to 5.0.7 NE on ubuntu 604 last night, there were some problems, I had to re-run the install.
    After the second run, things started working, but the logger will still not start:

    zmcontrol status
    antispam Running
    antivirus Running
    ldap Running
    logger Stopped
    logmysql.server is not running
    mailbox Running
    mta Running
    snmp Running
    spell Running
    stats Running

    But when I try to start it:
    logmysql.server start
    mysqld_safe already running with pid 4977

    after stopping logmysq.server and then starting with logmysql.server start
    it looks promising, giving:
    Starting mysqld daemon with databases from /opt/zimbra/logger/db/data

    logmysql.server status
    mysql is running with pid 14307

    zmloggerctl status
    logmysql.server is not running

    In desperation I have tried a full server reboot in case old processes were hanging on, this also did not improve things.

    Can anyone shed some light and point me in the right direction?

  2. #2
    Join Date
    Mar 2007
    Location
    Plymouth, uk
    Posts
    93
    Rep Power
    8

    Default more details

    I have removed all the logger dbs and done the zmloggerinit process. This did not return any errors, but:

    zmcontrol status:
    antispam Running
    antivirus Running
    ldap Running
    logger Stopped
    zmlogswatchctl is not running
    mailbox Running
    mta Running
    snmp Running
    spell Running
    stats Running

    zimbra@mail:~$ zmloggerctl start
    mysqld_safe already running with pid 17202

  3. #3
    Join Date
    Mar 2007
    Location
    Plymouth, uk
    Posts
    93
    Rep Power
    8

    Default

    A bit of progress:

    Issuing zmloggerctl reload seems to have been what it wanted. zmcontrol status now shows that all services are running, but...

    Logging in to the web gui, on the server status section gives:

    Code:
    Server error encountered Message: system failure: getting database logger connection Error code: service.FAILURE Method: GetServiceStatusRequest Details:soap:Receiver

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Check to see if there are any errors in the database, fix them if there are any.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Mar 2007
    Location
    Plymouth, uk
    Posts
    93
    Rep Power
    8

    Unhappy

    Thanks Phoenix

    zmloggerctl stop (if this is not done, "1 client is using or hasn't closed the table" errors are given on next step, this seems normal to me)

    /opt/zimbra/mysql/bin/myisamchk -s /opt/zimbra/logger/db/data/zimbra_logger/*.MYI
    (returns nothing - "no repair needed" messages suppressed)

    So it seems the logger tables are all ok. I can see that there is data in them as well (`select * from raw_logs limit 1` returns a very recent log entry)

    Tried on a different client machine to access the admin gui and same error is returned.

    find /opt/zimbra/logger/ -name *.err returns nothing, so there doesnt seem to be an error file as mentioned in a few posts.
    Last edited by captainmish; 07-08-2008 at 05:38 AM. Reason: added find detail

Similar Threads

  1. Replies: 28
    Last Post: 05-21-2008, 01:04 PM
  2. zmmailboxdctl is stopped frequently..
    By tamilnandhu in forum Installation
    Replies: 13
    Last Post: 04-12-2008, 09:59 AM
  3. Replies: 41
    Last Post: 10-29-2007, 03:36 PM
  4. logger stopped by itself
    By zzzzsg in forum Administrators
    Replies: 23
    Last Post: 08-15-2007, 04:55 PM
  5. The mailbox and mta dies in FC4 GA version
    By meikka in forum Installation
    Replies: 72
    Last Post: 03-16-2006, 05:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •