Results 1 to 5 of 5

Thread: different install problem

  1. #1
    Join Date
    Sep 2005
    Location
    Roswell, GA
    Posts
    58
    Rep Power
    10

    Default different install problem

    I've read through the and seem some stuff similar to this, but all the fixes so far have not worked. I'm on Fedora Core 3 with yum update as of last night. My /etc/hosts file has the localhost stuff only and I am getting this in the install log:



    Code:
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    Preparing packages for installation...
    zimbra-ldap-3.0.M1_21.FC3-20050920155949_
    Preparing packages for installation...
    zimbra-mta-3.0.M1_21.FC3-20050920155949_
    Preparing packages for installation...
    zimbra-snmp-3.0.M1_21.FC3-20050920155949_
    Preparing packages for installation...
    zimbra-store-3.0.M1_21.FC3-20050920155949_
    COMMAND: /opt/zimbra/libexec/zmmyinit
    * Creating required directories
    * Generating mysql config /opt/zimbra/conf/my.cnf
    * Creating database in /opt/zimbra/db/data
    there's more stuff that seems to be right and then I get this:
    Code:
    COMMAND: zmlocalconfig -e zimbra_server_hostname=stuff.testdomain.com
    COMMAND: zmlocalconfig -e ldap_host=stuff.testdomain.com
    COMMAND: zmlocalconfig -e ldap_port=389
    COMMAND: /opt/zimbra/libexec/zmldapinit
    Started slapd: pid 17883
    adding new entry "cn=zimbra"
    
    adding new entry "cn=admins,cn=zimbra"
    
    adding new entry "uid=zimbra,cn=admins,cn=zimbra"
    
    adding new entry "cn=config,cn=zimbra"
    a whole bunch of those adding new entry entries and then:

    Code:
    COMMAND: zmprov cs stuff.testdomain.com
    7bdb7016-3134-11da-a2ab-5b38d97859fb
    COMMAND: zmprov cd orlandini.us
    7df30644-3134-11da-bf2a-fddcba5e56d2
    COMMAND: zmprov mcf zimbraDefaultDomainName orlandini.us
    COMMAND: zmprov ca admin@orlandini.us password zimbraIsAdminAccount TRUE
    823bfa82-3134-11da-a190-0baa57f54086
    COMMAND: zmprov ms stuff.testdomain.com zimbraSmtpHostname 
    zmprov [cmd] [args ...]
    
      CreateAccount(ca) {name@domain} {password} [attr1 value1 [attr2 value2...]]
      DeleteAccount(da) {name@domain|id}
      GetAccount(ga) {name@domain|id}
      GetAllAccounts(gaa) [-v] [{domain}]
      GetAllAdminAccounts(gaaa) [-v]
      ModifyAccount(ma) {name@domain|id} [attr1 value1 [attr2 value2...]]
      SetPassword(sp) {name@domain|id} {password}
      AddAccountAlias(aaa) {name@domain|id} {alias@domain}
      RemoveAccountAlias(raa) {name@domain|id} {alias@domain}
      SetAccountCos(sac) {name@domain|id} {cos-name|cos-id}
      SearchAccounts(sa) [-v] {ldap-query} [limit {limit}] [offset {offset}] [sortBy {attr}] [attrs {a1,a2...}] [sortAscending 0|1*] [applyCos [0|1*] [domain {domain}]
    and more usage stuff... Then I get this:

    Code:
    COMMAND: id=`zmprov gs stuff.testdomain.com | grep zimbraId | awk '{print $2}'`; for i in `zmprov gc default | grep zimbraMailHostPool | sed 's/zimbraMailHostPool: //'`; do host="$host zimbraMailHostPool $i"; done; zmprov mc default $host zimbraMailHostPool $id
    COMMAND: /opt/zimbra/libexec/zmmtainit stuff.testdomain.com
    COMMAND: zmlocalconfig -e av_notify_user=notify@stuff.testdomain.com
    COMMAND: zmlocalconfig -e av_notify_domain=stuff.testdomain.com
    COMMAND: zmlocalconfig -e snmp_notify=0
    COMMAND: zmlocalconfig -e smtp_notify=0
    COMMAND: zmlocalconfig -e snmp_trap_host=
    COMMAND: zmlocalconfig -e smtp_source=none
    COMMAND: zmlocalconfig -e smtp_destination=none
    COMMAND: zmsnmpinit
    creating /opt/zimbra/conf/swatchrc
    COMMAND: zmprov ms stuff.testdomain.com zimbraServiceInstalled ldap zimbraServiceInstalled mailbox zimbraServiceInstalled mta zimbraServiceInstalled antivirus zimbraServiceInstalled antispam zimbraServiceInstalled snmp
    COMMAND: zmprov ms stuff.testdomain.com zimbraServiceEnabled ldap zimbraServiceEnabled mailbox zimbraServiceEnabled mta zimbraServiceEnabled antivirus zimbraServiceEnabled antispam zimbraServiceEnabled snmp
    COMMAND: zmlocalconfig -e zimbra_services="ldap mailbox mta antivirus antispam snmp"
    COMMAND: zmcreatecert
    Error - fully qualified host name not found - please correct
    COMMAND: zmcertinstall mailbox
    /opt/zimbra/bin/zmcertinstall: line 46: print: command not found
    COMMAND: zmtlsctl http
    /opt/zimbra/bin/zmtlsctl: line 48: print: command not found
    COMMAND: zmcertinstall mta /opt/zimbra/ssl/ssl/server/smtpd.crt /opt/zimbra/ssl/ssl/ca/ca.key
    /opt/zimbra/bin/zmcertinstall: line 46: print: command not found
    COMMAND: zmlocalconfig -e ssl_allow_untrusted_certs=true
    COMMAND: zmcontrol startup
    Calling startup (stuff.testdomain.com)
    
    perl /opt/zimbra/bin/zmmon &
    
    RESPONSE: (Zimbra::Mon::serviceInfo)
    	antispam
    		status              Running
    	antivirus
    		status              Running
    	ldap
    		status              Running
    	mailbox
    		status              Running
    	mta
    		status              Running
    	snmp
    		status              Stopped
    	host
    		ip                  10.10.1.67
    		name                stuff.testdomain.com
    COMMAND: zmlocalconfig -s > .localconfig.save.16307
    COMMAND: zmprov gs stuff.testdomain.com > .zmprov.stuff.testdomain.com.save.16307
    COMMAND: zmprov gacf stuff.testdomain.com > .zmprov.gacf.save.16307
    FYI - I have the FQN name in the hostfile. The 127.0.0.1 is only localhost, but the real IP 10.10.1.67 has the FQN and the shortname. Everything seems to fire up right and I can connect to the host and get the mail interface up and running. However, when I connect to the admin 7071 address I get a connection refused. Here's what was in my /opt/zimbra/tomcat/logs/catalina.out

    Code:
    Sep 29, 2005 6:06:11 PM org.apache.coyote.http11.Http11Protocol init
    INFO: Initializing Coyote HTTP/1.1 on http-7070
    Sep 29, 2005 6:06:11 PM org.apache.coyote.http11.Http11Protocol init
    SEVERE: Error initializing endpoint
    java.io.FileNotFoundException: /opt/zimbra/tomcat/conf/keystore (No such file or directory)
            at java.io.FileInputStream.open(Native Method)
            at java.io.FileInputStream.(FileInputStream.java:106)
            at org.apache.tomcat.util.net.jsse.JSSESocketFactory.getStore(JSSESocketFactory.java:278)
            at org.apache.tomcat.util.net.jsse.JSSESocketFactory.getKeystore(JSSESocketFactory.java:222)
            at org.apache.tomcat.util.net.jsse.JSSE14SocketFactory.getKeyManagers(JSSE14SocketFactory.java
    :141)
            at org.apache.tomcat.util.net.jsse.JSSE14SocketFactory.init(JSSE14SocketFactory.java:109)
            at org.apache.tomcat.util.net.jsse.JSSESocketFactory.createSocket(JSSESocketFactory.java:88)
            at org.apache.tomcat.util.net.PoolTcpEndpoint.initEndpoint(PoolTcpEndpoint.java:292)
            at org.apache.coyote.http11.Http11Protocol.init(Http11Protocol.java:142)
            at org.apache.catalina.connector.Connector.initialize(Connector.java:918)
            at org.apache.catalina.core.StandardService.initialize(StandardService.java:580)
            at org.apache.catalina.core.StandardServer.initialize(StandardServer.java:764)
            at org.apache.catalina.startup.Catalina.load(Catalina.java:490)
            at org.apache.catalina.startup.Catalina.load(Catalina.java:509)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:585)
            at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:243)
            at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:408)
    Sep 29, 2005 6:06:11 PM org.apache.catalina.startup.Catalina load
    SEVERE: Catalina.start
    The extra spaces are from the copy/paste.

    please help!

    TIA

  2. #2
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default smtphostname not set

    Somehow, the installer managed not to get the smtphostname set, which is why the command
    COMMAND: zmprov ms stuff.testdomain.com zimbraSmtpHostname
    fails (there's supposed to be an argument at the end).

    The cert install stuff is complaining about hostname, too.

    does your etc hosts file have:
    127.0.0.1 localhost localhost.localdomain
    or
    127.0.0.1 localhost.localdomain localhost

    I think we want the latter...

  3. #3
    Join Date
    Sep 2005
    Location
    Roswell, GA
    Posts
    58
    Rep Power
    10

    Default it's the later

    here's the first few lines:

    Code:
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1               localhost.localdomain localhost
    10.10.1.67              stuff stuff.testdomain.com

  4. #4
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default hostname

    What do
    hostname
    and hostname --fqdn
    return?

  5. #5
    Join Date
    Sep 2005
    Location
    Roswell, GA
    Posts
    58
    Rep Power
    10

    Default silly hostnames

    Your post gave me the idea to swap the order in the hosts file. I took it from:

    10.10.1.67 stuff stuff.testdomain.com

    to
    10.10.1.67 stuff.testdomain.com stuff

    and now things are working.

    Thanks for the help.

Similar Threads

  1. Cannot install zimbra (/etc/hosts problem ?)
    By kevork in forum Installation
    Replies: 12
    Last Post: 06-15-2010, 05:41 AM
  2. [SOLVED] fc6 install problem
    By underdog in forum Installation
    Replies: 5
    Last Post: 08-03-2009, 02:55 PM
  3. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 11:12 AM
  4. Multi-server install - logger problem
    By mrfileio in forum Administrators
    Replies: 1
    Last Post: 11-29-2006, 06:53 AM
  5. install problem with FC5
    By indica3D in forum Installation
    Replies: 4
    Last Post: 11-05-2006, 03:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •