Results 1 to 5 of 5

Thread: libnss-ldap prevents zimbra from working

  1. #1
    Join Date
    Jul 2008
    Posts
    27
    Rep Power
    7

    Default libnss-ldap prevents zimbra from working

    Hey

    I've done an install using the posixUserAccount admin extension to administrate the system user in zimbra's admin GUI. I've done this several times for remote machines, but now zimbra runs on the same machine where the linux users are needed by ldap/libnss.

    Now i get some strange errors - after installing libnss-ldap (debian 4.0) antivir and antispam won't start anymore (it worked before).
    Code:
    zmamavisdctl start
    /usr/bin/perl: symbol lookup error: /opt/zimbra/zimbramon/lib/i486-linux-gnu-thread-multi/auto/DB_File/DB_File.so: undefined symbol: db_version
    i had no idea what to do, so i removed /etc/libnss-ldap.conf and got a new error:
    Code:
    zmamavisdctl start
    perl: ldap-nss.c:1376: do_init: Assertion `cfg->ldc_uris[__session.ls_current_uri] != ((void *)0)' failed.
    /opt/zimbra/bin/zmamavisdctl: line 74:  2711 Aborted                 ${zimbra_home}/amavisd/sbin/amavisd -c ${zimbra_home}/conf/amavisd.conf
    from now it was clear that libnss-ldap was the reason ... i removed the package and everything was fine again.

    The problem is - I really need the users beeing able to authenticate against ldap on this machine - any ideas?

    regards
    juergenmw

  2. #2
    Join Date
    Jul 2008
    Posts
    27
    Rep Power
    7

    Default

    ok, i 've re-checked all settings today - especially for conflicting UIDs (local and ldap ID). I did a new installation of libnss-ldap, restartet zimbra and the problem still remains.

  3. #3
    Join Date
    Jul 2008
    Posts
    27
    Rep Power
    7

    Default

    any idea to debug this?
    Zimbra brings a huge chroot-like environment and I've no idea if/how it's possible to use strace or similar tools

  4. #4
    Join Date
    Jul 2008
    Posts
    1
    Rep Power
    7

    Default

    When I comment out one ldap search in /etc/nsswitch.conf so it looks like this:
    Code:
    passwd:         compat ldap
    group:          compat ldap
    shadow:         compat #ldap
    this error disappears.

    I have another zimbra installation where nss works just fine w/o any comments. The difference is that on the working installation there are ldap entries in pam config files so I think it might be this.

  5. #5
    Join Date
    May 2009
    Posts
    1
    Rep Power
    6

    Default Change the /opt/zimbra/.bashrc

    Add the following to the /opt/zimbra/.bashrc

    export LD_LIBRARY_PATH=/opt/zimbra/sleepycat/lib

    this should fix it (at least it did it for me)

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 09:06 AM
  2. [SOLVED] Zimbra logwatch.
    By nishith in forum Administrators
    Replies: 5
    Last Post: 06-10-2009, 04:42 PM
  3. Replies: 31
    Last Post: 12-15-2007, 08:05 PM
  4. svn version still won't start
    By kinaole in forum Developers
    Replies: 0
    Last Post: 10-04-2006, 06:47 AM
  5. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 11:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •