Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: [SOLVED] multiple accounts on smtp relay

  1. #11
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Vannes, France
    Rep Power


    You may find it easier to get a gmail account and use the gmail server as a relay, I'm almost certain that it doesn't have the restrictions you're encountering with your current ISP. Try that and see if you can relay all your accounts through that.


    Acompli: A new adventure for Co-Founder KevinH.

  2. #12
    Join Date
    Aug 2007
    Rep Power


    I've found a solution in Postfix's documentation.
    Zimbra uses Postfix so this worked for me!

    Log as user zimbra 'su - zimbra':

    Step 1

    Create /opt/zimbra/conf/relayhost_map file:

    Append entries for each unique sender => isp relay mapping you need. (note: our default relay,, is not included here):

    # Per-sender provider [] [] []

    Step 2

    Create/update the /opt/zimbra/conf/relay_password file with the user authentication information:

    # Per-sender authentication
    # Login for the default relayhost
    [] defaultUsername:defaultPassword

    Step 3

    Modify these setting in postfix configuration:

    postconf -e smtp_sender_dependent_authentication=yes
    postconf -e sender_dependent_relayhost_maps=hash:/opt/zimbra/conf/relayhost_map
    postconf -e smtp_sasl_auth_enable=yes
    postconf -e smtp_sasl_password_maps=hash:/opt/zimbra/conf/relay_password

    Step 4
    Hash the config files. Restart Postfix:

    postmap /opt/zimbra/conf/relayhost_map
    postmap /opt/zimbra/conf/relay_password
    postfix reload

    Mirko Guidolin

  3. #13
    Join Date
    Jan 2007
    Rep Power


    I have followed the instructions here, but it seems I am missing something. If I follow the instructions here for, and I send an email from to and run tcpdump -f "tcp port 25" -A in another terminal, I can see postfix connect to the mail server at I designate in step 1, and I can see the message being passed off successfully, but I do not see any attempt to actually authenticate to the server. What could be wrong?

    I would greatly appreciate any help.

Similar Threads

  1. Multiple Mail Accounts, Folders
    By skwdenyer in forum Users
    Replies: 12
    Last Post: 12-01-2013, 07:52 PM
  2. SMTP Relay
    By adarsh in forum Administrators
    Replies: 4
    Last Post: 11-11-2010, 03:36 AM
  3. Exchange Server 2003 SMTP
    By jschwartz73 in forum General Questions
    Replies: 8
    Last Post: 04-07-2008, 01:56 AM
  4. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  5. Open Relay Help & Telnet Security Issue
    By OfMacAndMen in forum Installation
    Replies: 17
    Last Post: 07-10-2007, 07:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts