Results 1 to 4 of 4

Thread: Solaris 10 x86 install-- Problems compiling ZimbraNative

  1. #1
    Join Date
    Mar 2006
    Rep Power

    Default Solaris 10 x86 install-- Problems compiling ZimbraNative

    I've been attempting to create a binary package for zimbra on Solaris 10 x86. I think I'm most of the way there, but am having problems starting tomcat with the zimbra-native.jar.

    Catalina.out reads:
    Fatal error: terminating: Failed to loadLibrary(zimbra-native)
    java.lang.UnsatisfiedLinkError: /opt/zimbra/lib/ java: fatal: open failed: No such file or directory
            at java.lang.ClassLoader$NativeLibrary.load(Native Method)
            at java.lang.ClassLoader.loadLibrary0(
            at java.lang.ClassLoader.loadLibrary(
    So is a linux only, so I try to build zimbra-native for Solaris with gmake (since the Makefile isn't compatible w/ ccs-make), and I get:
    gmake[1]: Leaving directory `/opt/zimbra/src/zcs-src/ZimbraNative'
    gmake build/
    gmake[1]: Entering directory `/opt/zimbra/src/zcs-src/ZimbraNative'
    gcc  -shared -o build/ build/IO.o build/Process.o build/zjniutil.o
    Text relocation remains                         referenced
        against symbol                  offset      in file
                               0x7f        build/IO.o
                               0x9d        build/IO.o
                               0xd7        build/IO.o
                               0x111       build/IO.o
                               0x204       build/IO.o
                               0x246       build/IO.o
                               0x290       build/IO.o
                               0x356       build/IO.o
                               0x74        build/Process.o
                               0xd8        build/Process.o
                               0x130       build/Process.o
                               0x16f       build/Process.o
                               0x1a9       build/Process.o
                               0x1d9       build/Process.o
                               0xf         build/zjniutil.o
                               0x51        build/zjniutil.o
                               0x93        build/zjniutil.o
                               0xd5        build/zjniutil.o
    _xstat                              0x12        build/IO.o
    _lxstat                             0x2d        build/IO.o
    _fxstat                             0x48        build/IO.o
    _xmknod                             0x63        build/IO.o
    ZimbraThrowNPE                      0x87        build/IO.o
    ZimbraThrowNPE                      0xa5        build/IO.o
    ZimbraThrowNPE                      0x24e       build/IO.o
    ZimbraThrowNPE                      0x177       build/Process.o
    ZimbraThrowIAE                      0xdf        build/IO.o
    ZimbraThrowIAE                      0x119       build/IO.o
    ZimbraThrowIAE                      0x298       build/IO.o
    ZimbraThrowIAE                      0x1b1       build/Process.o
    ZimbraThrowIAE                      0x1e1       build/Process.o
    memset                              0x153       build/IO.o
    memset                              0x1a9       build/IO.o
    memset                              0x2e8       build/IO.o
    link                                0x1db       build/IO.o
    errno                               0x1f0       build/IO.o
    errno                               0x342       build/IO.o
    errno                               0x63        build/Process.o
    errno                               0xc4        build/Process.o
    errno                               0x11f       build/Process.o
    strerror                            0x1f5       build/IO.o
    strerror                            0x347       build/IO.o
    strerror                            0x68        build/Process.o
    strerror                            0xc9        build/Process.o
    strerror                            0x124       build/Process.o
    snprintf                            0x215       build/IO.o
    snprintf                            0x367       build/IO.o
    snprintf                            0x85        build/Process.o
    snprintf                            0xe9        build/Process.o
    snprintf                            0x141       build/Process.o
    ZimbraThrowIOE                      0x22a       build/IO.o
    ZimbraThrowIOE                      0x37c       build/IO.o
    getuid                              0x7         build/Process.o
    geteuid                             0x14        build/Process.o
    geteuid                             0x3e        build/Process.o
    getgid                              0x21        build/Process.o
    getegid                             0x2e        build/Process.o
    setgid                              0x52        build/Process.o
    ZimbraThrowOFE                      0x9a        build/Process.o
    ZimbraThrowOFE                      0xfe        build/Process.o
    ZimbraThrowOFE                      0x156       build/Process.o
    initgroups                          0xb0        build/Process.o
    setuid                              0x10e       build/Process.o
    calloc                              0x1c5       build/Process.o
    free                                0x226       build/Process.o
    ld: fatal: relocations remain against allocatable but non-writable sections
    collect2: ld returned 1 exit status
    gmake[1]: *** [build/] Error 1
    gmake[1]: Leaving directory `/opt/zimbra/src/zcs-src/ZimbraNative'
    gmake: *** [all] Error 2
    Any help would be much appreciated. Once I get things finished on Solaris 10 x86, I'd be happy to try to package it on sparc also.


  2. #2
    Join Date
    Sep 2005
    Rep Power


    I never got saslauthd to build on solaris - never got to zimbra native.

    Which linker are you using?

  3. #3
    Join Date
    Mar 2006
    Rep Power


    I got it to link with both gnu ld, and /opt/csw/i386-pc-solaris2.8/bin/ld with the following (I tried them both):

    /opt/csw/i386-pc-solaris2.8/bin/ld -lstdc++ -o build/ build/IO.o build/Process.o build/zjniutil.o

    After that, (and commenting out the p4 stuff) "gmake all" and "gmake push" both complete. After that I tried another "ant reset-the-world". I got the following in the catalina.out
    log4j:WARN No appenders could be found for logger (org.apache.commons.digester.Digester.sax).
    log4j:WARN Please initialize the log4j system properly.
    Zimbra server reserving server socket port=7110 bindaddr=null ssl=false
    Zimbra server reserving server socket port=7995 bindaddr=null ssl=true
    Zimbra server reserving server socket port=7143 bindaddr=null ssl=false
    Zimbra server reserving server socket port=7993 bindaddr=null ssl=true
    Fatal error: terminating: Failed to loadLibrary(zimbra-native)
    java.lang.UnsatisfiedLinkError: no zimbra-native in java.library.path
            at java.lang.ClassLoader.loadLibrary(
            at java.lang.Runtime.loadLibrary0(
            at java.lang.System.loadLibrary(
            at com.zimbra.znative.Util.loadLibrary(
            at com.zimbra.znative.Util.(
            at com.zimbra.znative.Process.geteuid(
            at com.zimbra.cs.servlet.PrivilegedServlet.init(
            at javax.servlet.GenericServlet.init(
            at org.apache.catalina.core.StandardWrapper.loadServlet(
            at org.apache.catalina.core.StandardWrapper.load(
            at org.apache.catalina.core.StandardContext.loadOnStartup(
            at org.apache.catalina.core.StandardContext.start(
            at org.apache.catalina.core.ContainerBase.addChildInternal(
            at org.apache.catalina.core.ContainerBase.addChild(
            at org.apache.catalina.core.StandardHost.addChild(
            at org.apache.catalina.startup.HostConfig.deployWAR(
            at org.apache.catalina.startup.HostConfig.deployWARs(
            at org.apache.catalina.startup.HostConfig.deployApps(
            at org.apache.catalina.startup.HostConfig.start(
            at org.apache.catalina.startup.HostConfig.lifecycleEvent(
            at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(
            at org.apache.catalina.core.ContainerBase.start(
            at org.apache.catalina.core.StandardHost.start(
            at org.apache.catalina.core.ContainerBase.start(
            at org.apache.catalina.core.StandardEngine.start(
            at org.apache.catalina.core.StandardService.start(
            at org.apache.catalina.core.StandardServer.start(
            at org.apache.catalina.startup.Catalina.start(
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(
            at java.lang.reflect.Method.invoke(
            at org.apache.catalina.startup.Bootstrap.start(
            at org.apache.catalina.startup.Bootstrap.main(
    Thanks for any help,

  4. #4
    Join Date
    Aug 2005
    San Mateo, CA
    Rep Power


    You need to compile ZimbraNative.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

Similar Threads

  1. Ubuntu 6.06 Install Problems
    By swu in forum Installation
    Replies: 8
    Last Post: 06-29-2007, 09:18 AM
  2. Ubuntu 6.06 LTS server install problems
    By Kavey1978 in forum Installation
    Replies: 17
    Last Post: 05-30-2007, 01:49 AM
  3. CentOS 4.4 64 bit - 4.5.0_GA install problems
    By davespigot in forum Installation
    Replies: 1
    Last Post: 01-25-2007, 07:25 PM
  4. Install on Solaris 10 x86
    By chrschaffer in forum Installation
    Replies: 1
    Last Post: 01-23-2007, 04:48 PM
  5. more fedora install problems
    By jlynch3 in forum Installation
    Replies: 13
    Last Post: 09-14-2005, 09:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts