Results 1 to 2 of 2

Thread: OSX LDAP search string for Zimbra authentication

  1. #1
    Join Date
    Jul 2008
    Rep Power

    Default OSX LDAP search string for Zimbra authentication


    We've got ZCS 5 running on an OSX 10.5 server. It seems to work OK, and the users have been provisioned and Mail migrated fine.

    However, external LDAP authentication cannot be made to work at all.

    The LDAP master is another OSX 10.5 server, which works fine as well. It's a straight up installation - only file and directory services are installed on the machine, no other apps.

    Other applications can browse the LDAP list, so I think Zimbra's problem is that I cannot find a LDAP Filter string that works.

    More specifically :

    If in the "External LDAP Authentication Configuration Wizard" I put as an LDAP filter "uid=%u" or "mail=%u@domain.tld" when I run the test, I get :

    javax.naming.AuthenticationException: empty search
    at com.zimbra.cs.account.ldap.LdapUtil.ldapAuthentica te(
    at com.zimbra.cs.account.ldap.Check.checkAuthConfig(C
    at com.zimbra.cs.service.admin.CheckAuthConfig.handle (
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:267)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:159)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:266)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:727)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(
    at org.mortbay.servlet.UserAgentFilter.doFilter(UserA
    at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter .java:132)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se
    at org.mortbay.jetty.handler.ContextHandler.handle(Co
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(
    at org.mortbay.jetty.handler.HandlerCollection.handle (
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha
    at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle(
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha
    at org.mortbay.jetty.Server.handle(
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt
    at org.mortbay.jetty.HttpConnection$ ntent(
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:644)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec
    at org.mortbay.thread.BoundedThreadPool$ n(

    When it comes time to test against a user that is known to exist in the directory.

    I can muck about with other Filter strings, and maybe get a different error message, but they're all about as useful.

    If anyone has suggestions, I'd love to hear them.

    Last edited by djnephew; 07-31-2008 at 07:15 AM. Reason: Added clarification.

  2. #2
    Join Date
    Jul 2006
    Rep Power


    There's an OpenDirectory search string in this post. It was for OSX 10.4 so I'm not sure if it will work for 10.5.
    Bugzilla - Wiki - Downloads - Before posting... Search!

Similar Threads

  1. [SOLVED] Zimbra logwatch.
    By nishith in forum Administrators
    Replies: 5
    Last Post: 06-10-2009, 04:42 PM
  2. external authentication returns empty search
    By Nikos Lyberakis in forum Installation
    Replies: 1
    Last Post: 02-19-2008, 02:44 PM
  3. GAL not working with Active Directory
    By ardiederich in forum Installation
    Replies: 13
    Last Post: 02-12-2008, 07:01 PM
  4. Mac OSX install: Java errors & LDAP CA error
    By jefbear in forum Installation
    Replies: 9
    Last Post: 12-16-2006, 02:39 PM
  5. Authentication to external ldap stop working.
    By jahaj in forum Installation
    Replies: 3
    Last Post: 12-05-2006, 02:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts