Page 1 of 5 123 ... LastLast
Results 1 to 10 of 42

Thread: Cannot receive mail from other mail server

  1. #1
    Join Date
    Jul 2008
    Posts
    91
    Rep Power
    7

    Default Cannot receive mail from other mail server

    My Installation Zimbra almost finish,

    My Zimbra can send out email:
    1) Zimbra user to Zimbra user
    2) Zimbra user to yahoo user

    My Zimbra can receive Zimbra user email

    But My Zimbra user cannot receive email from yahoo user?

    What matter?

    I guess is the Split DNS problem...

    This is my file
    /etc/bind/named.conf.local
    zone "example.com" {
    type master;
    file "/etc/bind/db.example.com";
    };

    zone "1.168.192.in-addr.arpa" {
    type master;
    file "/etc/bind/db.192";
    };

    logging {
    channel query.log {
    file "/var/log/query.log";
    severity debug 3;
    };
    category queries { query.log; };
    };
    /etc/bind/db.example.com
    ;
    ; BIND data file for local loopback interface
    ;
    $TTL 604800
    @ IN SOA ns.example.com. root.example.com. (
    2 ; Serial
    604800 ; Refresh
    86400 ; Retry
    2419200 ; Expire
    604800 ) ; Negative Cache TTL
    ;

    @ IN NS ns.example.com.
    @ IN A 192.168.1.16
    mail.example.com. IN MX 10 mail.example.com.
    example.com. IN MX 10 mail.example.com.

    mail IN A 192.168.1.16
    www IN A 192.168.1.16
    ns IN A 192.168.1.16
    /etc/bind/db.192
    ;
    ; BIND reverse data file for local loopback interface
    ;
    $TTL 604800
    @ IN SOA ns.example.com. root.example.com. (
    2 ; Serial
    604800 ; Refresh
    86400 ; Retry
    2419200 ; Expire
    604800 ) ; Negative Cache TTL
    ;
    @ IN NS ns.
    16 IN PTR ns.example.com.
    Testing Bind
    server@mail:~$ host example.com 127.0.0.1
    Using domain server:
    Name: 127.0.0.1
    Address: 127.0.0.1#53
    Aliases:

    example.com has address 192.168.1.16
    example.com mail is handled by 10 mail.example.com.
    server@mail:~$ dig example.com

    ; <<>> DiG 9.4.2-P1 <<>> example.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 62432
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;example.com. IN A

    ;; ANSWER SECTION:
    example.com. 604800 IN A 192.168.1.16

    ;; AUTHORITY SECTION:
    example.com. 604800 IN NS ns.example.com.

    ;; ADDITIONAL SECTION:
    ns.example.com. 604800 IN A 192.168.1.16

    ;; Query time: 0 msec
    ;; SERVER: 192.168.1.16#53(192.168.1.16)
    ;; WHEN: Mon Aug 4 17:08:13 2008
    ;; MSG SIZE rcvd: 84
    All the stuff running ok... But My Zimbra user cannot receive email from yahoo user?

    Thank

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Where does the external MX record for your domain point to ? As you are behind a firewall on a private LAN are you NAT/PATing ? It would help if you let us know your domain name so we can test.

  3. #3
    Join Date
    Jul 2008
    Posts
    91
    Rep Power
    7

    Default

    My external MX record is point to a Public address using a mail.example.com name

    mail.example.com ----> 202.168.XXX.XXX

    I behind a NAT private network....

    It would help if you let us know your domain name so we can test.
    Thank you for the help.

    Don't give me the answer... Give me clue to solve the problem...

    Normally, we subscripte the service that provide the public ip a domain. They will assign a ip and a domain name to us...

    Then I need to configure using the domain name given...

    My hostname now is mail.example.com which is point to 192.168.1.16 which is my IP

    mail.example.com also point to the Public IP...

    Thank you

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Well from a machine external to your local network try and telnet to port 25 on your internet facing IP address and see if it connects. That much of a hint to you

  5. #5
    Join Date
    Jul 2008
    Posts
    91
    Rep Power
    7

    Default

    After telnet from my pc to the external pc then what should I do?

    * External PC is the PC that connected to outside world (internet) right?

    Thank

  6. #6
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    yes. you need to test that you can get to port 25 from the outside world.

  7. #7
    Join Date
    Jul 2008
    Posts
    91
    Rep Power
    7

    Default

    I understood already...

    You want me to check the external PC is it got block any traffic from port 110 (POP3)

    So far, they say the 110 port is enable....

    the Snmp port also enable...

    What should I do next step?

    Thank

  8. #8
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Are you collecting all your email via POP3 then ? or are you expecting to receive it via SMTP ?

  9. #9
    Join Date
    Jul 2008
    Posts
    91
    Rep Power
    7

    Default

    Mostly mail are send using SMTP port 25
    Then mail are receive using the pop3 port 110
    So far I know this is the standard... else gmail do not know where to send to yahoo mail

    Is it zimbra using another port?

    Thank

  10. #10
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Okay, so your external MX for your domain goes to a account at your ISP, and then you are downloading the email using POP3. Have you checked your Log Files - Zimbra :: Wiki for any error messages ? If you telnet to port 110 at your provider do you get a connection ?

Similar Threads

  1. Replies: 48
    Last Post: 09-18-2012, 09:49 AM
  2. [SOLVED] Mailserver down when send file attach of 50Mb
    By ZMilton in forum Administrators
    Replies: 20
    Last Post: 04-10-2008, 12:44 PM
  3. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 09:09 AM
  4. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 08:46 PM
  5. Tomcat broken after upgrade to 4
    By dotslashroot in forum Migration
    Replies: 13
    Last Post: 01-31-2007, 06:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •