Results 1 to 4 of 4

Thread: Upgrading Process

  1. #1
    Join Date
    May 2008
    Posts
    5
    Rep Power
    7

    Default Upgrading Process

    Hello,

    We are currently using ZCS 4.5 Open Source Edition for our e-mail server but are wanting to upgrade to the latest version of ZCS Open Source Edition so that we can take advantage of the new Zimbra Desktop (which requires at least 5.0).

    Unfortunately, I cannot find any information about how we can upgrade. Any thoughts?

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    First tell us your exact version: zmcontrol -v

    For instance if you're in the low 4.5.2 or something it's probably better to go to 4.5.11 first. That will also tell us your platform. http://www.zimbra.com/forums/announc...html#post62754

    Step 1: Make a backup Backup and Restore Articles - Zimbra :: Wiki
    Step 2: Double check step 1
    Step 3: Download & read the release notes http://www.zimbra.com/forums/announc...-0-8-live.html
    Step 4: Download the tar
    Step 5 : tar -xvf zcs-etcetc
    Step 6: ./install.sh

  3. #3
    Join Date
    May 2008
    Posts
    5
    Rep Power
    7

    Default

    Unfortunately, zmcontrol -v freezes and eventually locks up my server. However, given the date of the files in /opt/zimbra/bin (1/15/2007), I assume that we are running the GA release.

    So, is your suggestion to backup our /opt/zimbra/ directory, upgrade to 4.5.11, then backup our /opt/zimbra/ directory again, and finally upgrade to 5.0.8?

  4. #4
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Well there's several general availability releases of 4.5.x - but that sounds like 4.5.0?
    Check your /opt/zimbra/.install_history file.
    Do you have issues on other zmcontrol or zmprov commands or just that one?
    You can also type $set:get version in your AJAX web-client main search bar.

    Reasons to go to 4.5.11 first:
    -Large changes to Tomcat & LDAP around the 4.5.5/.6/.7/.8 area. For instance 4.5.2 > 5.0.8 is a big jump - while we test upgrading from everything in the 4.5.x line (that's different than 4.0.x line) by very definition there were more 4.5.8+ upgrades to 5.0.x 'ran' as that was current was when some of the 5.0.x beta's came out.
    -If you have any LDAP replicas you definitely should. LDAP Replicas 4.5.x to 5.0.x - Zimbra :: Wiki
    Make sure everything's fine, backup again, upgrade to 5.0.8 (no need to run through all the 5.0.0.1/.2/.3/.4/.5/.6/.7)

    4.5.11 (02/01/08)
    4.5.10 (11/21/07)
    4.5.9 (10/22/07)
    4.5.8 (10/04/07) FOSS
    4.5.7 (09/18/07)
    4.5.6 (06/28/07)
    4.5.5 (05/06/07)
    4.5.4 (03/28/07)
    4.5.3 (03/01/07)
    4.5.2 (02/16/07)
    4.5.1 (02/05/07)
    4.5.0 (01/16/07)
    4.5.0 RC2 (01/06/07)
    4.5.0 RC1 (12/15/06)
    4.5.0 Beta2 (07/24/06)
    4.5.0 Beta1 (06/26/06)
    Last edited by mmorse; 08-06-2008 at 03:05 PM.

Similar Threads

  1. Replies: 8
    Last Post: 01-12-2012, 02:20 AM
  2. [SOLVED] Outlook no longer updating
    By jeremy.pratt in forum Zimbra Connector for BlackBerry
    Replies: 10
    Last Post: 05-30-2008, 04:22 PM
  3. Can't seem to get global in BES
    By sdemeyer in forum Zimbra Connector for BlackBerry
    Replies: 12
    Last Post: 03-19-2008, 09:22 AM
  4. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM
  5. tomcat not running / postfix/postqueue errors
    By seravitae in forum Installation
    Replies: 7
    Last Post: 03-10-2007, 08:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •