Results 1 to 4 of 4

Thread: Zmtlsctl Method Problem, Downloads Small Binary File, Doesn't Redirect to SSL

  1. #1
    Join Date
    Feb 2008
    Rep Power

    Talking Zmtlsctl Redirect Method Problem/Downloads Small Binary File/Doesn't Redirect to SSL

    I'd like only to support SSL (and secure mail transports like secure imap and pop, etc.).

    For whatever reason, (mostly), no matter which method I select with zmtlsctl (redirect, https, etc.), something always is listening on port 80, though it prompts my browser to download a small bin file rather than redir to https.

    Zmtlsctl is supposed to edit the relevant conf files ... but it's not working so hot. I zmcontrol stop and start, and restart the jetty mailbox thingy between zmtlsctl's to make sure everything is fresh.

    Can I do zmtlsctl's job manually? What file should I check? I was not able to determine what is listening on port 80 with lsof or netstat. Must be something that listens on more than 1 port?

    I would even consider installing an Apache (or configuring the zimbra Apache) to redir http to https - hopefully with some direction from the experts here. But probably can't until I can tell whatever it that is currently listening on 80 to stop.

    Thank for any help!

    Last edited by spacegoose; 08-14-2008 at 09:22 AM.

  2. #2
    Join Date
    Jul 2007
    Rep Power


    well i don't know what the problem on your box is but it *should* work

    zimbra@zimbra:~> zmtlsctl https
    Setting tls mode to https
    Updating /opt/zimbra/mailboxd/etc/
    Updating /opt/zimbra/jetty/etc/
    Updating /opt/zimbra/jetty/etc/
    Updating PROTOCOL MODE in /opt/zimbra/mailboxd/etc/
    Rewriting config files for webxml and mailboxd...done.
    Updating /opt/zimbra/cyrus-sasl/etc/
    Rewriting config files for cyrus-sasl...done.
    Setting ldap config zimbraMailMode https for
    zimbra@zimbra:~> zmcontrol stop
            Stopping stats...Done
            Stopping mta...Done
            Stopping spell...Done
            Stopping snmp...Done
            Stopping archiving...Done
            Stopping antivirus...Done
            Stopping antispam...Done
            Stopping imapproxy...Done
            Stopping mailbox...Done
            Stopping logger...Done
            Stopping ldap...Done
    zimbra@zimbra:~> zmcontrol start
            Starting ldap...Done.
            Starting logger...Done.
            Starting mailbox...Done.
            Starting antispam...Done.
            Starting antivirus...Done.
            Starting snmp...Done.
            Starting spell...Done.
            Starting mta...Done.
            Starting stats...Done.
    zimbra@zimbra:~> telnet localhost 80
    telnet: connect to address Connection refused
    (localhost responds when in other modes)
    Last edited by bdial; 08-14-2008 at 09:29 AM.

  3. #3
    Join Date
    May 2007
    Rep Power

    Default Another poster having same issue.

    I don't think his issue was resolved yet. This may be a bug. Not sure.

  4. #4
    Join Date
    Feb 2008
    Rep Power

    Default redirect weirdness

    When I telnet on the server to localhost 80 or 80 both connections are refused. Though on a different host, there is a response when I telnet on 80 (via hostname or IP) can't tell what's responding though.

    typing in the connection gives:
    PConnection closed by foreign host
    Last edited by spacegoose; 08-14-2008 at 06:42 PM.

Similar Threads

  1. [SOLVED] SSL Connection Problem
    By GCamp in forum Zimbra Connector for Outlook
    Replies: 8
    Last Post: 07-28-2008, 11:23 AM
  2. Replies: 4
    Last Post: 03-18-2008, 10:03 AM
  3. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM
  4. SMTP SSL Problem
    By nexus in forum Installation
    Replies: 8
    Last Post: 03-15-2007, 08:26 AM
  5. SSL Problem - No common encryption algorithm
    By Daryl Jones in forum Installation
    Replies: 15
    Last Post: 02-13-2006, 02:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts