OK, I'm trying to install ZCS on a Red Hat Enterprise box that's also running as a web server right now. I figured it'd be okay if we just set the http for zcs to port 8080, right?
So I go through the install and it asks the infamous "do you want to change the domain?" quesiton, which is yes - the server is at teamfranken.com and shows up as sf5d187.a2hosting.com - which I know is a local DNS thing. so I change it to teamfranken.com.
the rest of the config goes fine, until i get this:
Operations logged to /tmp/zmsetup.01001900-000011009344.log
Setting local config values...done.
Setting up CA...done.
Deploying CA to /opt/zimbra/conf/ca ...done.
Creating SSL certificate...done.
Installing mailboxd SSL certificates...done.
Initializing ldap...failed. (2304)


ERROR



Configuration failed

Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to
complete the configuration.
Now, when I look into the log file, I see two spots that fail:
Fri Aug 15 10:56:40 2008 *** Running as root user: /opt/zimbra/bin/zmcertmgr createca
** Creating directory /opt/zimbra/ssl/zimbra
** Creating directory /opt/zimbra/ssl/zimbra/ca
** Creating directory /opt/zimbra/ssl/zimbra/server
** Creating directory /opt/zimbra/ssl/zimbra/commercial
** Creating directory /opt/zimbra/mailboxd/webapps/zimbraAdmin/tmp
** Creating /opt/zimbra/ssl/zimbra/ca/zmssl.cnf...done
** Retrieving CA private key from ldap...failed.
** Retrieving CA cert from ldap...failed.
** Creating CA private key /opt/zimbra/ssl/zimbra/ca/ca.key...done.
** Creating CA cert /opt/zimbra/ssl/zimbra/ca/ca.pem...done.
Fri Aug 15 10:56:44 2008 done.
BUT - in the /opt/zimbra/conf/ca directory, ca.key exists!

I'll be the first to admit, I'm a DNS newbie. so here's the hostfile:
127.0.0.1 localhost.localdomain localhost
69.39.86.187 sf5d187.a2hosting.com sf5d187
I *think* that's right, but I just kind of left it unchanged.
how do I fix the error and get ZCS up and running?

Thanks SO MUCH for the help!
-Louie