Results 1 to 2 of 2

Thread: Berkeley DB version mismatch

Hybrid View

  1. #1
    Join Date
    Mar 2006
    Posts
    3
    Rep Power
    9

    Default Berkeley DB version mismatch

    Hi

    I downloaded the patches suggested in build_cvs_howto.txt for sleepycat

    I build and install it.

    When I try to install openLDAP by running
    env CPPFLAGS="-I/usr/local/BerkeleyDB.4.2/include" \
    LDFLAGS="-L/usr/local/BerkeleyDB.4.2/lib" ./configure

    it tells me

    checking for Berkeley DB version match... Berkeley DB version mismatch
    header: Sleepycat Software: Berkeley DB 4.2.52: (December 3, 2003)
    library: Sleepycat Software: Berkeley DB 4.3.27: (September 9, 2005)

    Do I need to download any other patches?

    Kayse

  2. #2
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    You've got a later version (4.3) installed on your box, and it's finding the headers (or libraries) from that version.

Similar Threads

  1. Toaster and .53
    By jhoelz in forum General Questions
    Replies: 1
    Last Post: 08-04-2007, 12:03 PM
  2. Resetting the version number
    By steveweingart in forum Administrators
    Replies: 2
    Last Post: 03-20-2007, 10:31 AM
  3. Toaster Problem
    By jdell in forum Users
    Replies: 8
    Last Post: 03-08-2007, 04:03 AM
  4. Fix for SA Configure Files Version Mismatch
    By unilogic in forum Developers
    Replies: 1
    Last Post: 12-03-2005, 07:37 PM
  5. Bayes filter import bug
    By jwilso2 in forum Developers
    Replies: 4
    Last Post: 11-03-2005, 09:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •