Results 1 to 3 of 3

Thread: Logger not running

  1. #1
    Join Date
    Aug 2008
    Posts
    9
    Rep Power
    7

    Default Logger not running

    Hey,

    I need a bit of help, i've set up zimbra and everthing seems to be running now except the logger function, when i run the zmcontrol status i get the following:

    Code:
    zimbra@zimbrabackup:/root$ zmcontrol status
    Host zimbrabackup.teldust.com
            antispam                Running
            antivirus               Running
            imapproxy               Running
            ldap                    Running
            logger                  Stopped
                    zmlogswatchctl is not running
            mailbox                 Running
            mta                     Running
            snmp                    Running
            spell                   Running
            stats                   Running
    I did some searching and found a wikizimbra page and followed the instructions about checking zmlogswatchtl with following result:

    Code:
    zimbra@zimbrabackup:/root$ cat /opt/zimbra/logger/db/mysql.pid
    4407
    Which i'd think was as it should be so i continued to next step:

    zimbra@zimbrabackup:/root$ ps aux | grep logswatch
    zimbra 27790 0.0 0.0 1624 428 pts/0 D+ 12:14 0:00 grep logswatch
    So from what i can see the logswatch process is missing, correct? If so, any ideas as to how i can fix this?

  2. #2
    Join Date
    Aug 2008
    Posts
    9
    Rep Power
    7

    Default

    Just FYI i read the http://www.zimbra.com/forums/adminis...t-running.html post. And i don't think my problem is related to this or the rotation bug since it stops immediately, i start the logger and run the status right after. The above posts where from commands entered within a minute or two. Hope this helps in helping me :P

  3. #3
    Join Date
    Aug 2008
    Posts
    9
    Rep Power
    7

    Default

    In my desperation i've resorted to trying abit of everything. I read through oopstu's logswatch problem. Down along the thread marmac talk about changing passwords, i've gone through the steps he talked about using help from the wiki page concerning pass change

    All this resulted in:
    antispam Running
    antivirus Running
    imapproxy Running
    ldap Running
    logger Stopped
    logmysql.server is not running
    mailbox Running
    mta Running
    snmp Running
    spell Running
    stats Running
    And if i check to make sure there is a mysql.pid and processes running i get:

    zimbra@zimbrabackup:/root$ cat /opt/zimbra/logger/db/mysql.pid
    4276
    zimbra@zimbrabackup:/root$ ps aux | grep logger/mysql
    zimbra 4168 0.0 0.3 3068 1564 ? S 15:19 0:00 /bin/sh /opt/zimbra/logger/mysql/bin/mysqld_safe --defaults-file=/opt/zimbra/conf/my.logger.cnf --external-locking --log-error=/opt/zimbra/log/logger_mysql_error.log --ledir=/opt/zimbra/logger/mysql/libexec
    zimbra 4276 0.0 2.5 105528 13304 ? Sl 15:19 0:00 /opt/zimbra/logger/mysql/libexec/mysqld --defaults-file=/opt/zimbra/conf/my.logger.cnf --basedir=/opt/zimbra/logger/mysql --datadir=/opt/zimbra/logger/db/data --pid-file=/opt/zimbra/logger/db/mysql.pid --skip-external-locking --port=7307 --socket=/opt/zimbra/logger/db/mysql.sock --external-locking
    zimbra 9552 0.0 0.1 1644 564 pts/0 R+ 15:29 0:00 grep logger/mysql
    Is this the required processes or am i missing something, my guess is that the proccesses are running.

Similar Threads

  1. [SOLVED] Outlook no longer updating
    By jeremy.pratt in forum Zimbra Connector for BlackBerry
    Replies: 10
    Last Post: 05-30-2008, 04:22 PM
  2. zmmailboxdctl is stopped frequently..
    By tamilnandhu in forum Installation
    Replies: 13
    Last Post: 04-12-2008, 09:59 AM
  3. Can't seem to get global in BES
    By sdemeyer in forum Zimbra Connector for BlackBerry
    Replies: 12
    Last Post: 03-19-2008, 09:22 AM
  4. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  5. Trouble sending mail from Outlook
    By czaveri in forum Users
    Replies: 15
    Last Post: 07-24-2006, 12:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •