Results 1 to 7 of 7

Thread: [SOLVED] Don't receive e-mail

  1. #1
    Join Date
    Feb 2008
    Posts
    15
    Rep Power
    7

    Unhappy [SOLVED] Don't receive e-mail

    Hi all,
    i have install zimbra now, but i don't receive an e-mail...
    I send e-mail from account@zimbra.net to account2@zimbra.net, but i don't receive nothing...
    In the log i found this
    Code:
    Apr  8 09:43:23 zimbrawebmail postfix/smtpd[23341]: connect from zimbrawebmail.zimbra.net[192.168.5.150]
    Apr  8 09:43:23 zimbrawebmail postfix/smtpd[23341]: 8ACF52F58227: client=zimbrawebmail.zimbra.net[192.168.5.150]
    Apr  8 09:43:23 zimbrawebmail postfix/cleanup[23344]: 8ACF52F58227: message-id=<31940233.91207640603319.JavaMail.root@zimbrawebmail>
    Apr  8 09:43:23 zimbrawebmail postfix/qmgr[5892]: 8ACF52F58227: from=, size=662, nrcpt=1 (queue active)
    Apr  8 09:43:23 zimbrawebmail postfix/smtpd[23341]: disconnect from zimbrawebmail.zimbra.net[192.168.5.150]
    Apr  8 09:43:23 zimbrawebmail amavis[4805]: (04805-01) ESMTP::10024 /opt/zimbra/data/amavisd/tmp/amavis-20080408T094323-04805:  ->  SIZE=662 Received: from zimbrawebmail.zimbra.net ([127.0.0.1]) by localhost (zimbrawebmail.zimbra.net [127.0.0.1]) (amavisd-new, port 10024) with ESMTP for ; Tue,  8 Apr 2008 09:43:23 +0200 (CEST)
    Apr  8 09:43:23 zimbrawebmail amavis[4805]: (04805-01) Checking: pBgs8mkTrUqL [192.168.5.150] zimbra.net> -> zimbra.net>
    Apr  8 09:43:24 zimbrawebmail postfix/smtpd[23348]: connect from localhost.localdomain[127.0.0.1]
    Apr  8 09:43:24 zimbrawebmail postfix/smtpd[23348]: 3BF442F5822C: client=localhost.localdomain[127.0.0.1]
    Apr  8 09:43:24 zimbrawebmail postfix/cleanup[23344]: 3BF442F5822C: message-id=<31940233.91207640603319.JavaMail.root@zimbrawebmail>
    Apr  8 09:43:24 zimbrawebmail postfix/qmgr[5892]: 3BF442F5822C: from=, size=1362, nrcpt=1 (queue active)
    Apr  8 09:43:24 zimbrawebmail amavis[4805]: (04805-01) FWD via SMTP:  -> ,BODY=7BIT 250 2.6.0 Ok, id=04805-01, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 3BF442F5822C
    Apr  8 09:43:24 zimbrawebmail postfix/smtpd[23348]: disconnect from localhost.localdomain[127.0.0.1]
    Apr  8 09:43:24 zimbrawebmail amavis[4805]: (04805-01) Passed CLEAN, LOCAL [192.168.5.150] [192.168.5.150]  -> , Message-ID: <31940233.91207640603319.JavaMail.root@zimbrawebmail>, mail_id: pBgs8mkTrUqL, Hits: -1.488, size: 662, queued_as: 3BF442F5822C, 767 ms
    Apr  8 09:43:24 zimbrawebmail postfix/smtp[23345]: 8ACF52F58227: to=, relay=127.0.0.1[127.0.0.1]:10024, delay=0.91, delays=0.09/0.03/0.05/0.74, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 3BF442F5822C)
    Apr  8 09:43:24 zimbrawebmail postfix/qmgr[5892]: 8ACF52F58227: removed
    Apr  8 09:43:24 zimbrawebmail amavis[4805]: (04805-01) extra modules loaded: /opt/zimbra/zimbramon/lib/i386-linux-thread-multi/auto/Net/SSLeay/autosplit.ix, /opt/zimbra/zimbramon/lib/i386-linux-thread-multi/auto/Net/SSLeay/randomize.al, IO/Socket/SSL.pm, Net/LDAP/Extension.pm, Net/SSLeay.pm
    Apr  8 09:43:24 zimbrawebmail postfix/lmtp[23349]: 3BF442F5822C: to=, relay=none, delay=0.23, delays=0.16/0.06/0/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=zimbrawebmail.zimbra.net type=A: Host not found)
    Apr  8 09:43:24 zimbrawebmail postfix/cleanup[23344]: 80BA52F5822B: message-id=<20080408074324.80BA52F5822B@zimbrawebmail.zimbra.net>
    Apr  8 09:43:24 zimbrawebmail postfix/qmgr[5892]: 80BA52F5822B: from=<>, size=3560, nrcpt=1 (queue active)
    Apr  8 09:43:24 zimbrawebmail postfix/bounce[23350]: 3BF442F5822C: sender non-delivery notification: 80BA52F5822B
    Apr  8 09:43:24 zimbrawebmail postfix/qmgr[5892]: 3BF442F5822C: removed
    Apr  8 09:43:24 zimbrawebmail postfix/lmtp[23349]: 80BA52F5822B: to=, relay=none, delay=0.03, delays=0.02/0.01/0/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=zimbrawebmail.zimbra.net type=A: Host not found)
    Apr  8 09:43:24 zimbrawebmail postfix/qmgr[5892]: 80BA52F5822B: removed
    Do you know why don't receive an e-mail?

    Thank's all

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Looks like you have a DNS issue. Please provide the following
    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig _yourdomainname_ mx
    dig _yourdomainname_ any
    dig _yourserverfqdn_
    host `hostname` <- note backticks and not double quotes
    it would be useful aswell if you update your profile to include what version of ZCS you are running
    Code:
    su - zimbra
    zmcontrol -v

  3. #3
    Join Date
    Feb 2008
    Posts
    15
    Rep Power
    7

    Default

    I'm install bind on this server because i don't have a mx dns, and i want use zimbra to download e-mail wicth fetchmail (before i use squirrelmail)

    However my configuration is:
    Code:
    [root@zimbrawebmail~]# cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1       localhost.localdomain localhost
    192.168.5.150   zimbrawebmail.zimbra.net zimbrawebmail
    Code:
    [root@zimbrawebmail ~]# cat /etc/resolv.conf
    search zimbra.net
    domain zimbra.net
    nameserver 127.0.0.1
    nameserver 192.168.5.150
    nameserver 192.168.2.1
    nameserver 192.168.2.2
    Code:
    [root@zimbrawebmail ~]# dig _zimbra.net_ mx
    
    ; <<>> DiG 9.4.2 <<>> _zimbra.net_ mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 13298
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;_zimbra.net_.           IN      MX
    
    ;; AUTHORITY SECTION:
    .                       10800   IN      SOA     A.ROOT-SERVERS.NET. NSTLD.VERISIGN-GRS.COM. 2008090301 1800 900 604800 86400
    
    ;; Query time: 174 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Tue Apr  8 11:50:12 2008
    ;; MSG SIZE  rcvd: 112
    Code:
    [root@zimbrawebmail ~]# dig _zimbra.net_ any
    
    ; <<>> DiG 9.4.2 <<>> _zimbra.net_ any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 13497
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;_zimbra.net_.           IN      ANY
    
    ;; AUTHORITY SECTION:
    .                       10475   IN      SOA     A.ROOT-SERVERS.NET. NSTLD.VERISIGN-GRS.COM. 2008090301 1800 900 604800 86400
    
    ;; Query time: 3 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Tue Apr  8 11:5
    Code:
    [root@zimbrawebmail ~]# dig _zimbrawebmail_
    
    ; <<>> DiG 9.4.2 <<>> _zimbrawebmail_
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 54766
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;_zimbrawebmail_.               IN      A
    
    ;; AUTHORITY SECTION:
    .                       10800   IN      SOA     A.ROOT-SERVERS.NET. NSTLD.VERISIGN-GRS.COM. 2008090301 1800 900 604800 86400
    
    ;; Query time: 85 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Tue Apr  8 11:56:32 2008
    ;; MSG SIZE  rcvd: 108
    Code:
    [root@zimbrawebmail ~]# host `hostname`
    Host zimbrawebmail not found: 3(NXDOMAIN)
    Code:
    [zimbra@zimbrawebmail ~]$ zmcontrol -v
    
    
    Release 5.0.9_GA_2533.F7_20080815140725 F7 FOSS edition
    I hope to have you posted all that you need

    Thank's for all

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    as you are on a local LAN and probably behind a firewall you will need to install a Split DNS - Zimbra :: Wiki. A MX and A record will need to be available for ZCS so that it can deliver email, even for local delivery.

  5. #5
    Join Date
    Feb 2008
    Posts
    15
    Rep Power
    7

    Default

    I have modify my "/etc/named.conf" and now is:

    Code:
    options {
    directory "/var/named";
    allow-transfer {
    127.0.0.1;
    192.168.0.0/24;
    };
    allow-query {
    127.0.0.1;
    192.168.0.0/24;
    };
    forward first;
    #inserire i dns della propria connessione ad internet
    forwarders {
    192.168.2.1;
    192.168.2.2;
    };
    };
    #secret "inserite la vostra chiave che trovate nel file /etc/rndc.key"
    key "rndckey" {
    algorithm hmac-md5;
    secret "xxx";
    };
    logging {
    category lame-servers { null; };
    };
    zone "." {
    type hint;
    file "/var/named/db.root";
    };
    zone "localhost" {
    type master;
    file "/var/named/db.local";
    };
    zone "127.in-addr.arpa" {
    type master;
    file "/var/named/db.127";
    };
    zone "0.in-addr.arpa" {
    type master;
    file "/var/named/db.0";
    };
    zone "255.in-addr.arpa" {
    type master;
    file "/var/named/db.255";
    };
    zone "zimbra.net" {
    type master;
    file "/var/named/zimbra.net";
    allow-update { key rndckey; };
    };
    zone "zimbrawemail.zimbra.net" {
        type master;
        file "db.zimbrawemail.zimbra.net";
    };
    zone "0.168.192.in-addr.arpa" {
    type master;
    file "/var/named/zimbra.net.rev";
    allow-update { key rndckey; };
    };
    and i have create "/var/named/db.zimbrawemail.zimbra.net"

    Code:
    ;
    ;       Addresses and other host information.
    ;
    @       IN      SOA     zimbrawemail.zimbra.net. hostmaster.zimbrawemail.zimbra.net. (
                                   10118      ; Serial
                                   43200      ; Refresh
                                   3600       ; Retry
                                   3600000    ; Expire
                                   2592000 )  ; Minimum
    ;       Define the nameservers and the mail servers
                   IN      NS      192.168.5.150
                   IN      A       192.168.5.150
                   IN      MX      10 zimbrawemail.zimbra.net.
    but don't receive nothing

    For installing and configuration bind, i have read this Lordkarolus » Configurazione Server DNS + DHCP

  6. #6
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    You have defined the zone as the FQDN of your server which will not work. The zone should only be the domain element of your FQDN hostname. The Wiki article I posted explains this, and also look at the bottom for the PowerTip.

  7. #7
    Join Date
    Feb 2008
    Posts
    15
    Rep Power
    7

    Default

    I reconfigure all and now i receive e-mail...

    Code:
    [root@zimbrawebmail src]# cat /etc/named.conf
    options {
           directory "/var/named";
           dump-file "/var/named/data/cache_dump.db";
           statistics-file "/var/named/data/named_stats.txt";
    forwarders {
            192.168.2.1;
            192.168.2.2; };
    };
    include "/etc/rndc.key";
    // We are the master server for server.example.com
    zone "zimbra.net" {
        type master;
        file "db.zimbra.net";
    };
    Code:
    [root@zimbrawebmail src]# cat /var/named/db.zimbra.net
    ;
    ;       Addresses and other host information.
    ;
    $TTL    86400
    @       IN      SOA  @  zimbrawebmail.zimbra.net. (
                                            1         ; Serial
                                            604800    ; Refresh
                                            86400     ; Retry
                                            2419200   ; Expire
                                            86400 )   ; Negative Cache TTL
    ;       Define the nameservers and the mail servers
    @       IN NS           zimbrawebmail.zimbra.net.
            IN MX 10        zimbrawebmail.zimbra.net.
            IN A            192.168.5.150
    zimbrawebmail   IN A            192.168.5.150
    www     IN A            192.168.5.150

    Thank you very much
    Last edited by zap985; 09-04-2008 at 07:01 AM.

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 06:01 AM
  2. [SOLVED] Mailserver down when send file attach of 50Mb
    By ZMilton in forum Administrators
    Replies: 20
    Last Post: 04-10-2008, 11:44 AM
  3. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 06:07 PM
  4. Issues...
    By timothyalangorman in forum Administrators
    Replies: 3
    Last Post: 11-19-2007, 09:43 AM
  5. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 08:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •