Results 1 to 3 of 3

Thread: lmtp vs dns?

  1. #1
    Join Date
    Mar 2006
    Posts
    1
    Rep Power
    9

    Default lmtp vs dns?

    Hi,
    I m running Zimbra 3.0.1 GA on RHEL4

    How does lmtp resolve dns?
    It looks strange for me...

    My initial dns setup was
    @ IN SOA localhost. root.localhost. (

    IN NS localhost.
    MX 10 mail.wwzimbra.com.
    mail A 10.1.254.40

    and there's an error
    Mar 20 17:08:58 localhost postfix/lmtp[28338]: 3F33548D4: to=, relay=none, delay=1, status=bounced (Host o
    r domain name not found. Name service error for name=wwzimbra.com type=A: Host found but no data record of requested type)

    (1) Why lmtp looking for wwzimbra.com A record of the domain itself?

    When I add A record as
    @ IN SOA localhost. root.localhost. (

    IN NS localhost.
    A 10.1.254.10
    MX 10 mail.wwzimbra.com.
    mail A 10.1.254.40

    Error is
    Mar 20 17:52:58 localhost postfix/lmtp[26038]: 43F6E24B8C: to=, relay=none, delay=0, status=deferred (connect to wwzimbra.com[10.1.254.10]: Connection refused)

    (2) my email server is 10.1.254.40, not 10.1.254.10, Why lmtp send it to 10.1.254.10?

    After changed 10.1.254.10 into 10.1.254.40, all deferred email can go through

    Mar 20 18:21:53 localhost postfix/lmtp[6665]: 8860524B8E: to=, relay=wwzimbra.com[10.1.254.40], delay=0, status=sent (250 2.1.5 OK)

    It does not make sense to change dns like this, as host-10 is default webserver (another host), host-40 is zimbra mail server.

    Any idea about this?

    Thanks.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Does your DNS setup match this - that works for me on a CentOS 4.2 server. Is your hosts file also set-up correctly?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    lmtp sends it to wwzimbra.com because the zimbraMailHost attribute on the destination account is set to wwzimbra.com
    Bugzilla - Wiki - Downloads - Before posting... Search!

Similar Threads

  1. :( DNS Lookup issues
    By jhgutierrezg in forum Administrators
    Replies: 3
    Last Post: 05-30-2007, 08:00 AM
  2. LMTP problem (amoung other things)
    By kollross in forum Administrators
    Replies: 3
    Last Post: 02-18-2007, 09:36 PM
  3. ZCS ROCKS! Need some DNS help!
    By SiteDiscovery in forum Administrators
    Replies: 9
    Last Post: 12-30-2006, 09:50 PM
  4. DNS in a nutshell part two (For dummies)
    By daimer77 in forum Installation
    Replies: 4
    Last Post: 12-18-2006, 05:28 PM
  5. DNS Strategies and Best Practices, and a SLES10 Request
    By LMStone in forum Administrators
    Replies: 4
    Last Post: 10-14-2006, 07:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •