Results 1 to 8 of 8

Thread: Can't upgrade to 5.0.10 FOSS

  1. #1
    Join Date
    Sep 2008
    Posts
    3
    Rep Power
    7

    Default Can't upgrade to 5.0.10 FOSS

    Hey everyone,

    I've never had problems upgrading zimbra before... And I'm stuck now.
    I was running 5.0.9 open source on Ubuntu 8.04. I downloaded the install for Ubuntu 8 and ran the install file like usual. Here's how far I got:


    The Zimbra Collaboration Suite appears already to be installed.
    It can be upgraded with no effect on existing accounts,
    or the current installation can be completely removed prior
    to installation for a clean install.

    Do you wish to upgrade? [Y] Y

    Select the packages to install
    Upgrading zimbra-core
    Upgrading zimbra-ldap
    Upgrading zimbra-logger
    Upgrading zimbra-mta
    Upgrading zimbra-snmp
    Upgrading zimbra-store
    Upgrading zimbra-apache
    Upgrading zimbra-spell

    Install zimbra-proxy [N] N
    Checking required space for zimbra-core
    checking space for zimbra-store

    Installing:
    zimbra-core
    zimbra-ldap
    zimbra-logger
    zimbra-mta
    zimbra-snmp
    zimbra-store
    zimbra-apache
    zimbra-spell

    The system will be modified. Continue? [N] Y

    Shutting down zimbra mail

    Backing up the ldap database...done.

    Removing existing packages

    zimbra-ldap...done
    zimbra-logger...done
    zimbra-mta...done
    zimbra-snmp...done
    zimbra-store...done
    zimbra-spell...done
    zimbra-apache...done
    zimbra-core...done

    Removing deployed webapp directories
    Installing packages

    zimbra-core......zimbra-core_5.0.10_GA_2609.UBUNTU8_i386.deb...done
    zimbra-ldap......zimbra-ldap_5.0.10_GA_2609.UBUNTU8_i386.deb...done
    zimbra-logger......zimbra-logger_5.0.10_GA_2609.UBUNTU8_i386.deb...done
    zimbra-mta......zimbra-mta_5.0.10_GA_2609.UBUNTU8_i386.deb...done
    zimbra-snmp......zimbra-snmp_5.0.10_GA_2609.UBUNTU8_i386.deb...done
    zimbra-store......zimbra-store_5.0.10_GA_2609.UBUNTU8_i386.deb...done
    zimbra-apache......zimbra-apache_5.0.10_GA_2609.UBUNTU8_i386.deb...FAILED
    ###ERROR###

    zimbra-apache_5.0.10_GA_2609.UBUNTU8_i386.deb installation failed

    Installation cancelled

    root@:/usr/local/source/zcs#
    The installation just stopped... Any ideas anyone? I've never had problems before so I don't know where to start.

    Thanks for your help...

    EDIT:

    I found the install log in the /tmp directory and here's what it says:

    COMMAND: zmlocalconfig -s | sed -e "s/ = \(.*\)/=\'\1\'/" > /opt/zimbra/.saveconfig/config.save
    COMMAND: zmcontrol shutdown
    Host
    Stopping stats...Done
    Stopping mta...Done
    Stopping spell...Done
    Stopping snmp...Done
    Stopping archiving...Done
    Stopping antivirus...Done
    Stopping antispam...Done
    Stopping imapproxy...Done
    Stopping mailbox...Done
    Stopping logger...Done
    Stopping ldap...Done
    Selecting previously deselected package zimbra-core.
    (Reading database ... 55789 files and directories currently installed.)
    Unpacking zimbra-core (from .../zimbra-core_5.0.10_GA_2609.UBUNTU8_i386.deb) ...
    Setting up zimbra-core (5.0.10_GA_2609.UBUNTU8) ...
    rm: cannot remove `/opt/zimbra/java': Is a directory
    ln: creating symbolic link `/opt/zimbra/java/jdk1.5.0_15': File exists
    rm: cannot remove `/opt/zimbra/sleepycat': Is a directory
    ln: creating symbolic link `/opt/zimbra/sleepycat/sleepycat-4.2.52.6': File exists
    rm: cannot remove `/opt/zimbra/openssl': Is a directory
    ln: creating symbolic link `/opt/zimbra/openssl/openssl-0.9.8g': File exists
    rm: cannot remove `/opt/zimbra/heimdal': Is a directory
    ln: creating symbolic link `/opt/zimbra/heimdal/heimdal-1.2': File exists
    rm: cannot remove `/opt/zimbra/curl': Is a directory
    ln: creating symbolic link `/opt/zimbra/curl/curl-7.18.1': File exists
    rm: cannot remove `/opt/zimbra/cyrus-sasl': Is a directory
    ln: creating symbolic link `/opt/zimbra/cyrus-sasl/cyrus-sasl-2.1.22.3z': File exists
    rm: cannot remove `/opt/zimbra/openldap-clibs': Is a directory
    rm: cannot remove `/opt/zimbra/tcmalloc': Is a directory
    ln: creating symbolic link `/opt/zimbra/tcmalloc/tcmalloc-0.97': File exists
    Loading classes to share ... done.
    Rewriting and unlinking classes ... done.
    Calculating hash values for String objects .. done.
    Calculating fingerprints ... done.
    Removing unshareable information ... done.
    Moving most read-only objects to shared space at 0x90910000 ... done.
    Moving common symbols to shared space at 0x90c8d938 ... done.
    Moving remaining symbols to shared space at 0x90dbaa68 ... done.
    Moving string char arrays to shared space at 0x90dbb4f8 ... done.
    Moving additional symbols to shared space at 0x90e3e070 ... done.
    Read-only space ends at 0x90e92e10, 5778960 bytes.
    Moving read-write objects to shared space at 0x91110000 ... done.
    Moving String objects to shared space at 0x916a0e40 ... done.
    Read-write space ends at 0x916e1640, 6100544 bytes.
    Updating references to shared objects ... done.


    Processing triggers for libc6 ...
    ldconfig deferred processing now taking place
    Selecting previously deselected package zimbra-ldap.
    (Reading database ... 62398 files and directories currently installed.)
    Unpacking zimbra-ldap (from .../zimbra-ldap_5.0.10_GA_2609.UBUNTU8_i386.deb) ...
    Setting up zimbra-ldap (5.0.10_GA_2609.UBUNTU8) ...
    rm: cannot remove `/opt/zimbra/openldap': Is a directory

    Processing triggers for libc6 ...
    ldconfig deferred processing now taking place
    Selecting previously deselected package zimbra-logger.
    (Reading database ... 62789 files and directories currently installed.)
    Unpacking zimbra-logger (from .../zimbra-logger_5.0.10_GA_2609.UBUNTU8_i386.deb) ...
    Setting up zimbra-logger (5.0.10_GA_2609.UBUNTU8) ...
    rm: cannot remove `/opt/zimbra/logger/mysql': Is a directory
    ln: creating symbolic link `/opt/zimbra/logger/mysql/mysql-standard-5.0.51a-pc-linux-gnu-i686-glibc23': File exists

    Selecting previously deselected package zimbra-mta.
    (Reading database ... 64785 files and directories currently installed.)
    Unpacking zimbra-mta (from .../zimbra-mta_5.0.10_GA_2609.UBUNTU8_i386.deb) ...
    Setting up zimbra-mta (5.0.10_GA_2609.UBUNTU8) ...
    rm: cannot remove `/opt/zimbra/amavisd': Is a directory
    ln: creating symbolic link `/opt/zimbra/amavisd/amavisd-new-2.5.4': File exists
    rm: cannot remove `/opt/zimbra/dspam': Is a directory
    ln: creating symbolic link `/opt/zimbra/dspam/dspam-3.8.0': File exists
    rm: cannot remove `/opt/zimbra/postfix': Is a directory
    ln: creating symbolic link `/opt/zimbra/postfix/postfix-2.4.7.5z': File exists
    rm: cannot remove `/opt/zimbra/clamav': Is a directory
    ln: creating symbolic link `/opt/zimbra/clamav/clamav-0.93.3': File exists

    Processing triggers for libc6 ...
    ldconfig deferred processing now taking place
    Selecting previously deselected package zimbra-snmp.
    (Reading database ... 65042 files and directories currently installed.)
    Unpacking zimbra-snmp (from .../zimbra-snmp_5.0.10_GA_2609.UBUNTU8_i386.deb) ...
    Setting up zimbra-snmp (5.0.10_GA_2609.UBUNTU8) ...
    ln: creating symbolic link `/opt/zimbra/snmp/net-snmp-5.4.1': File exists

    Selecting previously deselected package zimbra-store.
    (Reading database ... 65590 files and directories currently installed.)
    Unpacking zimbra-store (from .../zimbra-store_5.0.10_GA_2609.UBUNTU8_i386.deb) ...
    Setting up zimbra-store (5.0.10_GA_2609.UBUNTU8) ...
    /opt/zimbra/libexec/zmfixperms: 20: shopt: not found
    rm: cannot remove `/opt/zimbra/mysql': Is a directory
    ln: creating symbolic link `/opt/zimbra/mysql/mysql-standard-5.0.51a-pc-linux-gnu-i686-glibc23': File exists
    ln -s /opt/zimbra/jetty-6.1.5 /opt/zimbra/jetty
    ln: creating symbolic link `/opt/zimbra/jetty/jetty-6.1.5': File exists
    Relinking mailboxd to /opt/zimbra/jetty-6.1.5
    ln -s /opt/zimbra/apache-tomcat-5.5.15 /opt/zimbra/tomcat
    ln: creating symbolic link `/opt/zimbra/tomcat/apache-tomcat-5.5.15': File exists
    rm: cannot remove `/opt/zimbra/jetty': Is a directory
    ln: creating symbolic link `/opt/zimbra/jetty/jetty-6.1.5': File exists

    Selecting previously deselected package zimbra-apache.
    (Reading database ... 82461 files and directories currently installed.)
    Unpacking zimbra-apache (from .../zimbra-apache_5.0.10_GA_2609.UBUNTU8_i386.deb) ...
    Setting up zimbra-apache (5.0.10_GA_2609.UBUNTU8) ...
    ln: creating symbolic link `/opt/zimbra/httpd/httpd-2.2.8': File exists
    dpkg: error processing zimbra-apache (--install):
    subprocess post-installation script returned error exit status 1
    Errors were encountered while processing:
    zimbra-apache
    Last edited by Mccreations2; 09-27-2008 at 09:42 AM.

  2. #2
    Join Date
    Sep 2008
    Posts
    3
    Rep Power
    7

    Default

    Sorry to bump, but is it possible to transfer data from my old zimbra installation to a new one I would make? I need my mail server online and don't want to loose my data...

  3. #3
    Join Date
    Jul 2009
    Posts
    4
    Rep Power
    6

    Default

    Quote Originally Posted by Mccreations2 View Post
    Hey everyone,

    I've never had problems upgrading zimbra before... And I'm stuck now.
    I was running 5.0.9 open source on Ubuntu 8.04. I downloaded the install for Ubuntu 8 and ran the install file like usual. Here's how far I got:




    The installation just stopped... Any ideas anyone? I've never had problems before so I don't know where to start.

    Thanks for your help...

    EDIT:

    I found the install log in the /tmp directory and here's what it says:
    The same problem. Do You have an idea?

  4. #4
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    Make sure /bin/sh is a symbolic link to /bin/bash instead of /bin/dash
    Bugzilla - Wiki - Downloads - Before posting... Search!

  5. #5
    Join Date
    Jul 2009
    Posts
    4
    Rep Power
    6

    Default

    Quote Originally Posted by brian View Post
    Make sure /bin/sh is a symbolic link to /bin/bash instead of /bin/dash
    Thx for reply. I tried
    Code:
    rm /bin/sh
    ln -s /bin/bash /bin/sh
    No result. The Error is
    Code:
    zimbra-apache......zimbra-apache_5.0.10_GA_2638.DEBIAN4.0_i386.deb...FAILED
    ###ERROR###
    zimbra-apache_5.0.10_GA_2638.DEBIAN4.0_i386.deb installation failed
    Installation cancelled

  6. #6
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Did you perform a uninstall before trying the install again ?

  7. #7
    Join Date
    Jul 2009
    Posts
    4
    Rep Power
    6

    Default

    Yes, I unintalled the Zimbra "./install -u" and tried install one more but I had the error "zimbra-apache FAILED###ERROR###".

  8. #8
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Okay, so when you execute the install trying doing it using
    Code:
    sh -x ./install.sh
    that way you may get more information about the error.

Similar Threads

  1. 5.0.10 FOSS is out!
    By mmorse in forum Announcements
    Replies: 0
    Last Post: 09-24-2008, 09:33 PM
  2. Replies: 2
    Last Post: 08-25-2008, 10:40 PM
  3. FOSS upgrade fails
    By buraglio in forum Administrators
    Replies: 13
    Last Post: 03-09-2008, 09:53 PM
  4. Upgrade from ZCS 5.0 GA FOSS to ZCA 5.0 NE
    By fcolpron in forum Installation
    Replies: 7
    Last Post: 01-22-2008, 12:44 PM
  5. Replies: 13
    Last Post: 01-15-2008, 08:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •