Results 1 to 3 of 3

Thread: [SOLVED] Error deleting index before re-indexing

  1. #1
    Join Date
    Oct 2008
    Fountain Hills, Arizona
    Rep Power

    Default [SOLVED] Error deleting index before re-indexing


    I'm new to Zimbra. I apologize if this has been discussed before, but, I'm not finding help searching the forums or using Google.

    I have a mailbox that never produces any search results. Every text search fails. I found information about reindexing the mailbox. When I try to reindex the mailbox, I get this error in zmmailboxd.out:

    com.zimbra.common.service.ServiceException: system failure: Error deleting index before re-indexing
            at com.zimbra.common.service.ServiceException.FAILURE(
            at com.zimbra.cs.mailbox.Mailbox.reIndex(
            at com.zimbra.cs.service.admin.ReIndex$
    Caused by: read past EOF
            at org.apache.lucene.index.SegmentInfo.(
            at org.apache.lucene.index.IndexFileDeleter.(
            at org.apache.lucene.index.IndexWriter.init(
            at org.apache.lucene.index.IndexWriter.(
            at com.zimbra.cs.index.Lucene23Index.deleteIndex(
            at com.zimbra.cs.index.MailboxIndex.deleteIndex(
            at com.zimbra.cs.mailbox.Mailbox.reIndex(
            ... 1 more
    This mailbox was originally populated using the outlook pst importer program. I am using FOSS 5.0.10 running on Ubuntu 8.04 LTS. Searches in other mailboxes (which were not loaded using the outlook pst import) do work correctly.

    What else can I try?

    Thanks in advance,
    Last edited by alahser; 10-07-2008 at 05:04 PM. Reason: Grammar

  2. #2
    Join Date
    May 2006
    Rep Power


    Welcome to the forums,

    When you have a window of time:
    1. zmprov gmi
    1. Set the problematic account into a restricted mode: zmprov ma zimbraAccountStatus maintenance (this step is not completely necessary but I would prevent access somehow)
    3. Shutdown Zimbra (zmcontrol stop)
    4. Delete the folder # dedicated to the user under /opt/zimbra/index/0/
    zmcontrol start - you will see that it rebuilds the index of the mailbox.
    6. Wait until the reindexing is finished.
    7. If you did step 1, make the account active again. zmprov ma zimbraAccountStatus active

    A good read: Account mailbox database structure - Zimbra :: Wiki
    Last edited by mmorse; 10-07-2008 at 07:09 PM.

  3. #3
    Join Date
    Oct 2008
    Fountain Hills, Arizona
    Rep Power

    Default Solved

    Foremost, thanks for taking time to help. I'm not sure how you took my symptoms and came up with such a precise recipe, but I appreciate your experience.

    I didn't completely trust the results initially, because, I could not find a log file that indicated that the rebuild occurred without any further error. However, I could verify that text searches were working.

    So, I followed your steps exactly. After (for good measure), I performed the following two commands:

    /opt/zimbra/bin/zmprov rim start

    Then, periodically:

    /opt/zimbra/bin/zmprov rim status

    I kept the user logged out during this 2nd rebuild. I was able to monitor the status while the re-build was happening. These two steps may not have been necessary, but, it gave me a good feeling. I also found the entry in mailbox.log that indicated:

    2008-10-07 23:22:56,710 INFO [Thread-262] [] mailbox - Re-Indexing: Mailbox 12 COMPLETED. Re-indexed 6302 items in 2733092ms. (avg 433ms/item= 2 items/sec) (0 failed)

    I have to say, it is very, very, very cool to do simple text searches across > 6000 messages and 1.2Gig of data. The results are amazingly split-second. Thanks for your fine software.

    Best Regards,
    Last edited by alahser; 10-07-2008 at 11:40 PM. Reason: removed personal email address

Similar Threads

  1. Error after installation
    By robsontuxlinux in forum Installation
    Replies: 13
    Last Post: 09-11-2008, 09:48 PM
  2. 4.0.4 to 4.5.6 upgrade failed in network edition
    By chenthil in forum Administrators
    Replies: 1
    Last Post: 08-27-2007, 09:36 AM
  3. [SOLVED] Simple backup question...
    By dameron in forum Administrators
    Replies: 3
    Last Post: 08-25-2007, 09:36 PM
  4. Error message in Server status
    By Max Ma in forum Installation
    Replies: 20
    Last Post: 04-19-2007, 08:55 AM
  5. The mailbox and mta dies in FC4 GA version
    By meikka in forum Installation
    Replies: 72
    Last Post: 03-16-2006, 04:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts