Results 1 to 3 of 3

Thread: [SOLVED] Zimlets not working in renamed domain

  1. #1
    Join Date
    Sep 2008
    Posts
    12
    Rep Power
    7

    Default [SOLVED] Zimlets not working in renamed domain

    when I setup my first zimbra server, I used a different domain name (office.company.com) instead of "company.com". I renamed the first domain according to the documentation and have had problems with the wiki not working, and now I notice that Zimlets aren't working either:

    They are defined in the COS, but when I enable new ones, I can't enable them for the primary domain, I get the following error:

    Mail: Invalid request: LDAP schema violation (LDAP: error code 65 - attribute 'zimbraZimletAvailableZimlets' not allowed) Errorcode service.INVALID_REQUEST Method: ZaDomainController.prototype.saveChangesCallback Details:soap:Sender

    How do I fixup my LDAP directory? Or do I need to re-setup the whole domain?

    Zimlets in additional domains are working fine

    thanks
    jens-christian

  2. #2
    Join Date
    Oct 2008
    Location
    Toronto
    Posts
    46
    Rep Power
    7

    Default Try this

    When saving the changes I made in the default domain COS, I get an error message.

    "Message: invalid request: LDAP schema violation: [LDAP: error code 65 - attribute 'zimbraZimletAvailableZimlets' not allowed] Error code: service.INVALID_REQUEST Method: ZaDomainController.prototype.saveChangesCallback Details:soap:Sender"

    To remove the error message and solve the problem, I run these commands:
    su - zimbra
    zmprov md example.com zimbraZimletDomainAvailableZimlets ""

    For Zimbra to be able to read the changes in the COS, reload Zimbra.

  3. #3
    Join Date
    Sep 2008
    Posts
    12
    Rep Power
    7

    Default thanks

    that solved the problem!

Similar Threads

  1. Replies: 7
    Last Post: 04-27-2009, 02:49 AM
  2. [SOLVED] Renamed domain name is not working.
    By nishith in forum Administrators
    Replies: 6
    Last Post: 06-26-2008, 12:49 AM
  3. Zimlets by domain
    By jamesdecker24 in forum Zimlets
    Replies: 2
    Last Post: 06-07-2008, 11:10 PM
  4. Replies: 20
    Last Post: 03-18-2008, 05:37 AM
  5. Zimlets all not working?
    By jadestorm in forum Administrators
    Replies: 16
    Last Post: 10-28-2007, 07:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •