Results 1 to 5 of 5

Thread: A network service error has occurred (zclient/io)

Hybrid View

  1. #1
    Join Date
    Feb 2008
    Posts
    9
    Rep Power
    7

    Default A network service error has occurred (zclient/io)

    I've just managed to a new install of 5.0.10 up and running on centos 5.2

    when I got to log into the web client I get this error:
    A network service error has occurred (zclient/io)

    Does anyone know what might causing this - and even better a fix?

    I have read another post about making sure jetty is listening on both the public ip address and the localhost 127.0.0.1.

    [root@cbt ~]# netstat -nplt | grep 80
    tcp 0 0 :::7780 :::* LISTEN 14112/httpd
    tcp 0 0 :::80 :::* LISTEN 1344/java

    From that it looks like jetty (java) is bound correctly.

    Any help much appreciated.

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Have you disabled SELinux and IPTables ?

  3. #3
    Join Date
    Feb 2008
    Posts
    9
    Rep Power
    7

    Default

    Selinux is disabled
    [root@cbt ~]# selinuxenabled && echo "YES"
    [root@cbt ~]#

    Iptables was enabled, but I've now stopped it, and unfortunately there's been no change in behaviour.

  4. #4
    Join Date
    Feb 2008
    Posts
    9
    Rep Power
    7

    Default

    Probably related, zmprov is also not working, here's the output when I run it

    [zimbra@cbt ~]$ zmprov
    ERROR: zclient.IO_ERROR (invoke cannot determine soap protocol in reply: Error 503 SERVICE_UNAVAILABLE

    HTTP ERROR: 503

    SERVICE_UNAVAILABLE

    RequestURI=/service/admin/soap/

    Powered by jetty://

    , server: localhost) (cause: com.zimbra.common.soap.SoapParseException cannot determine soap protocol in reply: Error 503 SERVICE_UNAVAILABLE

    HTTP ERROR: 503

    SERVICE_UNAVAILABLE

    RequestURI=/service/admin/soap/

    Powered by jetty://

    )
    [zimbra@cbt ~]$

  5. #5
    Join Date
    Feb 2008
    Posts
    9
    Rep Power
    7

    Default

    Ahm, that formatted it as html, lets try again.

    Code:
    [zimbra@cbt ~]$ zmprov 
    ERROR: zclient.IO_ERROR (invoke cannot determine soap protocol in reply: Error 503 SERVICE_UNAVAILABLE

    HTTP ERROR: 503

    SERVICE_UNAVAILABLE

    RequestURI=/service/admin/soap/

    Powered by jetty://

    , server: localhost) (cause: com.zimbra.common.soap.SoapParseException cannot determine soap protocol in reply: Error 503 SERVICE_UNAVAILABLE

    HTTP ERROR: 503

    SERVICE_UNAVAILABLE

    RequestURI=/service/admin/soap/

    Powered by jetty://

    )

Similar Threads

  1. A network service error has occurred (zclient/io).
    By kersfeeshaas in forum Administrators
    Replies: 1
    Last Post: 03-18-2009, 10:24 AM
  2. A network service error has occurred (zclient/io)
    By telescop in forum Installation
    Replies: 17
    Last Post: 12-19-2008, 08:22 AM
  3. Replies: 0
    Last Post: 08-20-2008, 09:24 AM
  4. Replies: 17
    Last Post: 04-19-2008, 10:27 AM
  5. Replies: 20
    Last Post: 03-18-2008, 06:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •