Results 1 to 10 of 15

Thread: no luck on Centos 4.1

Threaded View

  1. #1
    Join Date
    Oct 2005
    Posts
    25
    Rep Power
    10

    Default no luck on Centos 4.1 [H E L P ]

    Hi,

    i' m trying to install Zimbra on Centos 4.1 (RHEL 4 clone) and install fails...

    from the install log i can see that the drama start's with the ldap server ...

    Code:
    COMMAND: zmlocalconfig -e zimbra_server_hostname=zimbra.arq.up.pt
    COMMAND: zmlocalconfig -e ldap_host=zimbra.arq.up.pt
    COMMAND: zmlocalconfig -e ldap_port=389
    COMMAND: /opt/zimbra/libexec/zmldapinit
    Started slapd: pid
    ldap_bind: Can't contact LDAP server (-1)
    ldap_bind: Can't contact LDAP server (-1)
    COMMAND: zmprov cs zimbra.arq.up.pt
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException zimbra.arq.up.pt:389)
    COMMAND: zmprov cd alumni.arq.up.pt
    ... which doesn' t start. after some research and following the instructions from here...

    Code:
     su - zimbra
    bash -x bin/ldap start
    i get ...
    Code:
    (...) 
    + '[' -x /opt/zimbra/sleepycat/bin/db_recover ']'
    + /opt/zimbra/sleepycat/bin/db_recover -h /opt/zimbra/openldap-data -v
    db_recover: Finding last valid log LSN: file: 1 offset 28
    + /opt/zimbra/openldap/libexec/slapd -4 -u zimbra -h ldap://:7389/ -f /opt/zimbra/conf/slapd.conf
    + sleep 2
    (...)
    going after the slapd binary i found that it simply dies. With debug enabled i get...

    [zimbra@zimbra ~]$ /opt/zimbra/openldap/libexec/slapd -d 10 -4 -u zimbra -h ldap://:7389/ -f /opt/zimbra/conf/slapd.conf
    @(#) $OpenLDAP: slapd 2.2.26 (Aug 17 2005 00:15:16) $
    marcmac@depot.liquidsys.com:/space/home/marcmac/p4/main/ThirdParty/openldap/openldap-2.2.26/servers/slapd
    /opt/zimbra/openldap/etc/openldap/schema/zimbra.schema: line 1229: bad config line (ignored)
    bdb_db_init: Initializing BDB database
    bdb(): unable to initialize mutex: Function not implemented
    bdb(): /opt/zimbra/openldap-data/__db.001: unable to initialize environment lock: Function not implemented
    bdb_db_open: dbenv_open failed: Function not implemented (38)
    backend_startup: bi_db_open failed! (38)
    bdb(): DB_ENV->lock_id_free interface requires an environment configured for the locking subsystem
    bdb(): txn_checkpoint interface requires an environment configured for the transaction subsystem
    bdb_db_destroy: txn_checkpoint failed: Invalid argument (22)
    slapd stopped.

    connections_destroy: nothing to destroy.

    Any tips ?

    thanxs in advance and best regards.
    Last edited by antonio.meireles; 10-03-2005 at 11:16 AM. Reason: add more drama to subject

Similar Threads

  1. Replies: 8
    Last Post: 07-04-2007, 09:23 AM
  2. Migration problem from FC3 to Centos 4.3
    By kibo in forum Migration
    Replies: 5
    Last Post: 01-02-2007, 07:34 PM
  3. Issue with Centos 4.2-x86_64 and MYSQL
    By antiochguy in forum Installation
    Replies: 4
    Last Post: 03-10-2006, 05:45 PM
  4. Zimbra startup hangs after install CentOS 4.2
    By eger in forum Installation
    Replies: 4
    Last Post: 02-10-2006, 11:08 PM
  5. Replies: 1
    Last Post: 09-29-2005, 05:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •