Results 1 to 4 of 4

Thread: MySQL DB corrupt

Hybrid View

  1. #1
    Join Date
    Aug 2007
    Location
    Switzerland
    Posts
    14
    Rep Power
    8

    Question MySQL DB corrupt

    Help needed,

    my DB got corrupted after a system crash. I tried several DB checks but nothing worked till now and if I try to upgrade from 5.0.8_GA to 5.0.10_GA I am getting the following error:

    Do you want to verify message store database integrity? [Y]
    Verifying integrity of message store databases. This may take a while.
    mysqld is alive
    /opt/zimbra/mysql/bin/mysqlcheck: Got error: 2013: Lost connection to MySQL server during query when executing 'CHECK TABLE ... CHANGED'
    Generating report
    Database errors found.
    /opt/zimbra/mysql/bin/mysqlcheck --defaults-file=/opt/zimbra/conf/my.cnf -S /opt/zimbra/db/mysql.sock -A -C -s -u root --password=Xg8RyCgUi2TE2ilc1bCmK1s8UAt7e --auto-repair
    mboxgroup10.mail_item
    error : Corrupt
    command failed

    any help?

    Last edited by Urs; 11-03-2008 at 05:03 AM.

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

  3. #3
    Join Date
    Aug 2007
    Location
    Switzerland
    Posts
    14
    Rep Power
    8

    Default

    thanks uxbod for your replay.

    I read trou the thread, but it's to confusing to me.

    If I check the Status everything sems OK but still it does not work and the only errors I can see is the above mentoned errors

    zimbra@zimbra2:~$ zmcontrol status
    Host zimbra2.allved.com
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Running
    mta Running
    snmp Running
    spell Running
    stats Running
    zimbra@zimbra2:~$

    is there a way I can repair the MySQL DB?

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    It would appear you need to follow this Wiki :- Mysql Crash Recovery - Zimbra :: Wiki. Though make sure you backup your system first !!!

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 01:42 AM
  2. [SOLVED] Install Problem in Ubuntu 6.06 Server
    By xtimox in forum Installation
    Replies: 16
    Last Post: 03-27-2008, 10:36 AM
  3. DNS Questions and Trouble Installing
    By smurraysb in forum Installation
    Replies: 22
    Last Post: 03-14-2008, 04:27 PM
  4. Replies: 18
    Last Post: 03-20-2006, 02:22 PM
  5. Can't start MySQL to init db - Gentoo
    By fak3r in forum Installation
    Replies: 3
    Last Post: 10-10-2005, 07:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •