Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Zimbra dies after some time

  1. #11
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    Dear Kevin,

    I am sorry I am bothering you again. Zimbra has been dying since today evening again.

    This time I have completely disabled iptables.

    I restarted the machine - and it hasn't started still.

    Here is what I did. I called date in between executing two "ps" commands so you would know how long a process was alive.

    Code:
    [root@parshwanath ~]# iptables --list
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    [root@parshwanath ~]# /etc/rc.d/init.d/zimbra stop
    Host domain.net
            Stopping antispam...Done
            Stopping antivirus...Done
            Stopping ldap...Done
            Stopping logger...Done
            Stopping mailbox...Done
            Stopping mta...Done
            Stopping snmp...Done
            Stopping spell...Done
    [root@parshwanath ~]# ps ax | grep zimbra
     7097 ?        S      0:00 initlog -q -c /etc/rc3.d/S99zimbra start
     7098 ?        S      0:00 /bin/bash /etc/rc3.d/S99zimbra start
     7099 ?        S      0:00 su - zimbra -c zmcontrol startup
     7737 pts/0    S+     0:00 grep zimbra
    [root@parshwanath ~]# ps ax | grep zimbra
     7097 ?        S      0:00 initlog -q -c /etc/rc3.d/S99zimbra start
     7098 ?        S      0:00 /bin/bash /etc/rc3.d/S99zimbra start
     7099 ?        S      0:00 su - zimbra -c zmcontrol startup
     7739 ?        Ss     0:00 /usr/bin/perl /opt/zimbra/bin/zmstatuslog
     7746 ?        S      0:00 /usr/bin/perl /opt/zimbra/bin/zmcontrol status
     7758 ?        S      0:00 sh -c /opt/zimbra/bin/zmprov gs domain.net 2>/dev/null
     7759 ?        Sl     0:00 /opt/zimbra/java/bin/java -client -Xmx256m -Dzimbra.home=/opt/zimbra -Djava.library.path=/opt/zimbra/lib/jars -Djava.ext.dirs=/opt/zimbra/java/jre/lib/ext:/opt/zimbra/lib/jars com.zimbra.cs.account.ProvUtil gs domain.net
     7772 pts/0    S+     0:00 grep zimbra
    [root@parshwanath ~]# ps ax | grep zimbra
     7097 ?        S      0:00 initlog -q -c /etc/rc3.d/S99zimbra start
     7098 ?        S      0:00 /bin/bash /etc/rc3.d/S99zimbra start
     7099 ?        S      0:00 su - zimbra -c zmcontrol startup
     7774 pts/0    S+     0:00 grep zimbra
    [root@parshwanath ~]# ps ax | grep zimbra
     7097 ?        S      0:00 initlog -q -c /etc/rc3.d/S99zimbra start
     7098 ?        S      0:00 /bin/bash /etc/rc3.d/S99zimbra start
     7099 ?        S      0:00 su - zimbra -c zmcontrol startup
     7776 pts/0    S+     0:00 grep zimbra
    [root@parshwanath ~]# kill 7097 7098 7099
    [root@parshwanath ~]# ps ax | grep zimbra
     8158 pts/0    S+     0:00 grep zimbra
    [root@parshwanath ~]# /etc/rc.d/init.d/zimbra start
    Host domain.net
            Starting ldap...Done.
    [root@parshwanath ~]# ps ax | grep zimbra
     8260 ?        Ssl    0:00 /opt/zimbra/openldap-2.2.28/libexec/slapd -l LOCAL0 -4 -u zimbra -h ldaps:// ldap://:389/ -f /opt/zimbra/conf/slapd.conf
     8308 pts/0    S+     0:00 grep zimbra
    [root@parshwanath ~]# ps ax | grep zimbra
     8260 ?        Ssl    0:00 /opt/zimbra/openldap-2.2.28/libexec/slapd -l LOCAL0 -4 -u zimbra -h ldaps:// ldap://:389/ -f /opt/zimbra/conf/slapd.conf
     8310 pts/0    S+     0:00 grep zimbra
    [root@parshwanath ~]# date
    Thu Apr  6 21:03:58 IST 2006
    [root@parshwanath ~]# ps ax | grep zimbra
     8260 ?        Ssl    0:00 /opt/zimbra/openldap-2.2.28/libexec/slapd -l LOCAL0 -4 -u zimbra -h ldaps:// ldap://:389/ -f /opt/zimbra/conf/slapd.conf
     8313 ?        Ss     0:00 /usr/bin/perl /opt/zimbra/bin/zmstatuslog
     8320 ?        S      0:00 /usr/bin/perl /opt/zimbra/bin/zmcontrol status
     8332 ?        S      0:00 sh -c /opt/zimbra/bin/zmprov gs domain.net 2>/dev/null
     8333 ?        Sl     0:00 /opt/zimbra/java/bin/java -client -Xmx256m -Dzimbra.home=/opt/zimbra -Djava.library.path=/opt/zimbra/lib/jars -Djava.ext.dirs=/opt/zimbra/java/jre/lib/ext:/opt/zimbra/lib/jars com.zimbra.cs.account.ProvUtil gs domain.net
     8346 pts/0    S+     0:00 grep zimbra
    [root@parshwanath ~]# date
    Thu Apr  6 21:04:08 IST 2006
    [root@parshwanath ~]# ps ax | grep zimbra
     8260 ?        Ssl    0:00 /opt/zimbra/openldap-2.2.28/libexec/slapd -l LOCAL0 -4 -u zimbra -h ldaps:// ldap://:389/ -f /opt/zimbra/conf/slapd.conf
     8313 ?        Ss     0:00 /usr/bin/perl /opt/zimbra/bin/zmstatuslog
     8320 ?        S      0:00 /usr/bin/perl /opt/zimbra/bin/zmcontrol status
     8332 ?        S      0:00 sh -c /opt/zimbra/bin/zmprov gs domain.net 2>/dev/null
     8333 ?        Sl     0:00 /opt/zimbra/java/bin/java -client -Xmx256m -Dzimbra.home=/opt/zimbra -Djava.library.path=/opt/zimbra/lib/jars -Djava.ext.dirs=/opt/zimbra/java/jre/lib/ext:/opt/zimbra/lib/jars com.zimbra.cs.account.ProvUtil gs domain.net
     8349 pts/0    S+     0:00 grep zimbra
    [root@parshwanath ~]# date
    Thu Apr  6 21:04:16 IST 2006
    [root@parshwanath ~]# ps ax | grep zimbra
     8260 ?        Ssl    0:00 /opt/zimbra/openldap-2.2.28/libexec/slapd -l LOCAL0 -4 -u zimbra -h ldaps:// ldap://:389/ -f /opt/zimbra/conf/slapd.conf
     8352 pts/0    S+     0:00 grep zimbra
    [root@parshwanath ~]# date
    Thu Apr  6 21:04:26 IST 2006
    [root@parshwanath ~]#
    I also did: kill -QUIT 9189 (where 9189 was PID on my system) and it died silently.

    Code:
    [root@parshwanath ~]# ps ax | grep zimbra
     8744 ?        Ssl    0:00 /opt/zimbra/openldap-2.2.28/libexec/slapd -l LOCAL0 -4 -u zimbra -h ldaps:// ldap://:389/ -f /opt/zimbra/conf/slapd.conf
     8808 pts/0    S+     0:00 grep zimbra
    [root@parshwanath ~]# ps ax | grep zimbra
     8744 ?        Ssl    0:00 /opt/zimbra/openldap-2.2.28/libexec/slapd -l LOCAL0 -4 -u zimbra -h ldaps:// ldap://:389/ -f /opt/zimbra/conf/slapd.conf
     8810 ?        Ss     0:00 /usr/bin/perl /opt/zimbra/bin/zmstatuslog
     8817 ?        S      0:00 /usr/bin/perl /opt/zimbra/bin/zmcontrol status
     8829 ?        S      0:00 sh -c /opt/zimbra/bin/zmprov gs domain.net 2>/dev/null
     8830 ?        Sl     0:00 /opt/zimbra/java/bin/java -client -Xmx256m -Dzimbra.home=/opt/zimbra -Djava.library.path=/opt/zimbra/lib/jars -Djava.ext.dirs=/opt/zimbra/java/jre/lib/ext:/opt/zimbra/lib/jars com.zimbra.cs.account.ProvUtil gs domain.net
     8843 pts/0    S+     0:00 grep zimbra
    [root@parshwanath ~]# kill -QUIT 8830
    [root@parshwanath ~]# ps ax | grep zimbra
     8744 ?        Ssl    0:00 /opt/zimbra/openldap-2.2.28/libexec/slapd -l LOCAL0 -4 -u zimbra -h ldaps:// ldap://:389/ -f /opt/zimbra/conf/slapd.conf
     8845 pts/0    S+     0:00 grep zimbra
    [root@parshwanath ~]#
    Can you help me understand how I can get Zimbra to work again?

    Thanks again for your help.

    Sincerely,

    Chintan.

  2. #12
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Zimbra is not even starting.. All your seeing are a few config calls to get the data needed to start zimbra.

    Do you have a firewall other than iptables?
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #13
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    No Kevin,

    iptables is all I could afford at present

  4. #14
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Hard to say then. Can you telnet to 389 when LDAP is running?
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  5. #15
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    Yes, I can also telnet to 389 from a remote machine - on a different network - and also from localhost.

    Would looking at log files help? Please let me know if I should attach any logs.

    Also, I haven't installed anything on the server except Bind and Apache. And I am running only Bind - I am not even running Apache.

    In addition, this was a fresh install of CentOS 4.2.
    Last edited by czaveri; 04-06-2006 at 10:12 AM.

  6. #16
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Exclamation

    It is working again!

    Having done nothing at all - it's like a ghost in the system
    (I am the only person with root or shell access.)

    Even the firewall is active at this moment when this is working.

    Any idea what's going on?

  7. #17
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Quote Originally Posted by czaveri
    Any idea what's going on?
    Nope. Not something we've heard of... Although we do know that some old mailservers will haunt you, even after they are long dead and gone.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  8. #18
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    giving up eventually

    It's down again - really, I am not able to find any reason.

    Fresh install of CentOS 4.2 on AMD Sempron with 2 GB RAM
    Zimbra works sometimes - Dies sometimes
    No other app on system except Bind is running
    Hardly 20 MB of data everyday

    Maybe AMD Sempron has problems

    Anyways, I will continue to run Zimbra on other systems, ... and hope for it to work well.

Similar Threads

  1. Replies: 9
    Last Post: 03-01-2008, 08:21 PM
  2. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 09:55 AM
  3. upgrade woes -made into new thread
    By JustinHarlow in forum Installation
    Replies: 18
    Last Post: 06-08-2007, 01:11 PM
  4. Mail logs
    By Rick Baker in forum Installation
    Replies: 8
    Last Post: 01-17-2006, 04:33 PM
  5. Replies: 1
    Last Post: 11-23-2005, 01:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •