Results 1 to 2 of 2

Thread: [SOLVED] Connection to server timed out (port 25)

  1. #1
    Join Date
    Mar 2008
    Salt Lake City, Utah
    Rep Power

    Default [SOLVED] Connection to server timed out (port 25)

    I already solved this issue but it was such a pain in the arse I thought I would post my problem and results just in case anyone else has the same issue.


    Our network connectivity took a dive and we had to switch over to our redundant circuit. Unfortunately it is on an entirely different block of IP's (not really sure that was one of the issues in the chain though).

    After changing the IP and sending Zimbra back to the outside world the MTA would not deliver mail and get the error: Connection to server timed out (port 25).


    DNS lookup for the MTA is not running. Thus the MTA is looking at the address of the recipient (i.e. - the domain name) and not the MX record for the recipient. So it is attempting to deliver to the domain name which obviously does utilize port 25.

    Here is what to do:

    Confirm whether or not DNS lookup for the MTA is running:

    su - zimbra
    zmcontrol stop
    (....zimbra services stop....)
    zmprov gs | grep dns -i
    This will return:

    zimbraMtaDnsLookupsEnabled: FALSE
    If it says TRUE then this isn't your problem.

    Now activate DNS for your MTA (watch the case sensitivity).

    zmprov ms | zimbraMtaDnsLookupEnable TRUE
    (...restart zimbra...)
    zmcontrol start
    You may or may not need to reboot.

    And there you go. You should see your mail queue flush and the error go away.

    Hope this helps some poor schlump out there that is pulling his hair out as much as I was.

    vīdī, vīcī, vēnī

  2. #2
    Join Date
    May 2006
    Rep Power


    Thanks for the tip. Glad you got it working in the end.

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. server dropped connection
    By ferra in forum Installation
    Replies: 20
    Last Post: 10-06-2008, 04:32 PM
  3. Fresh Zimbra installation does not work
    By Datax in forum Installation
    Replies: 4
    Last Post: 08-18-2008, 01:18 PM
  4. Zimbra not listening on port 7071
    By carllerche in forum Installation
    Replies: 10
    Last Post: 04-03-2007, 09:23 PM
  5. Error 256 on Installation
    By RuinExplorer in forum Installation
    Replies: 5
    Last Post: 10-19-2006, 09:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts