While untaring the Ubuntu6 LTS version 5.0.11 - I get this error in the archive...

tar xzvf zcs-5.0.11_GA_2695.UBUNTU6.20081117053338.tgz
....
zcs-5.0.11_GA_2695.UBUNTU6.20081117053338/util/modules/postinstall.sh
gzip: stdin: invalid compressed data--crc error
zcs-5.0.11_GA_2695.UBUNTU6.20081117053338/util/utilfunc.sh

I have now tried downloading the file several times and always the same problem.