I had previously installed ZCS 5.0.x. I had installed /opt/zimbra onto an iSCSI LUN and /opt/zimbra/pri, /opt/zimbra/back onto NFS mounts. This config was working perfectly.

The server got compromised and I was focred to reinstall RHEL. Since the LUN and NFS mounts were fine (not compromised) my plan was to:

1. reinstall RHEL 5
2. Install ZCS onto a local drive (/opt/zimbra)
3. Stop all Zimbra services
4. mv /opt/zimbra /opt/zimbra.backup
5. mount the old /opt/zimbra (the iscsi lun)
6. start the ZCS services

Everything went fine with the RHEL re-install and the ZCS install. After I got to step 6 and tried to start the services (zmcontrol start) I received the following error:

Unable to determine enabled services from ldap.
Unable to determine enabled services. Cache is out of date or doesn't exist.

I've gone through the forums and checked/verified my DNS and /etc/hosts. Everything is fine. Interestingly enough, when I checked the /opt/zimbra/conf/localconfig.xml file I saw that all the values for ldap are correctly defined. Yet when I run the following command:

zmlocalconfig ldap_master_url ldap_url zimbra_server_hostname

I get "Warning local config file /opt/zimbra/conf/localconfig.xml is not readable

It then goes on to show the above values as blank for ldap_master_url and ldap_url, while zimbra_server_hostname = localhost

This is clearly not what's in the localconfig.xml file. In any case, why am I unable to start the services and what can I do to resolve??

If I unmount the iSCSI lun and mount the local /opt/zimbra (mv /opt/zimbra.backup /opt/zimbra) then I can start the services successfully. Problem is that this is a brand new ZCS install and if I mount the old mailstore (/opt/zimbra/pri on an nfs mount) I'm not sure things will be ok. That's why I was hoping to mount the old iSCSI lun.

I also have the old backups still on /opt/zimbra/back - which is also an nfs mount. If someone can tell me that I can do a completely new ZCS install and restore my most recent full backup (from the /opt/zimbra/back mount) and this will restore all ldap, mysql, indexes and mailstore data then I'll definitely go that way.