Page 4 of 4 FirstFirst ... 234
Results 31 to 40 of 40

Thread: ATTN: Ubuntu 8.04 Users

  1. #31
    Join Date
    Jul 2009
    Posts
    8
    Rep Power
    6

    Default

    Quote Originally Posted by just_me View Post
    In fact, i did, but this didn't help either. :-(. Still hostname: Unknown host...
    :-(
    jm
    But i just saw, that one thing changed:
    the prompt is now: : ~root@zimbra:~: not :~# oot@zimbra anymore

  2. #32
    Join Date
    Jul 2009
    Posts
    8
    Rep Power
    6

    Default

    Quote Originally Posted by just_me View Post
    Thank you very much for your fast reply.

    In fact, i did, but this didn't help either.Still hostname: Unknown host...
    :-(
    jm
    *push*

    Anybody to point me in the right direction, please?

  3. #33
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by just_me View Post
    Anybody to point me in the right direction, please?
    Well, you should post some diagnostic information like the ones in post #32
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #34
    Join Date
    Jul 2009
    Posts
    8
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    Well, you should post some diagnostic information like the ones in post #32
    here you are:

    hosts:

    Code:
    #::1     localhost ip6-localhost ip6-loopback
    #fe00::0 ip6-localnet
    #ff00::0 ip6-mcastprefix
    #ff02::1 ip6-allnodes
    #ff02::2 ip6-allrouters
    #ff02::3 ip6-allhosts
    127.0.0.1 localhost zimbra
    # Auto-generated hostname. Please do not remove this comment.
    99.99.99.99 zimbra.mydomain.com zimbra mail www

    hostname:

    Code:
    zimbra.mydomain.com
    dig zimbra.mydomain.com any:

    Code:
    ; <<>> DiG 9.4.2-P2 <<>> zimbra.isprz.de any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 11949
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;zimbra.mydomain.com               IN      ANY
    
    ;; ANSWER SECTION:
    zimbra.mydomain.com.        14379   IN      MX      10 99.99.99.99.
    
    ;; Query time: 3 msec
    ;; SERVER: 199.199.199.199#53(199.199.199.199)
    ;; WHEN: Mon Aug 24 10:29:28 2009
    ;; MSG SIZE  rcvd: 61
    Unfortunately, there seems, that some posts are missing, because the one you referred to isn't in anymore. Hope this information helps:

    Btw, it is a virtual root server (OPENVZ) with Ubuntu 8.04, reverse DNS has been set, the mx and A records in DNS as well.

    Thanks for *any* help.
    Best
    jm

  5. #35
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Yes, I moved those posts to another thread as they were no longer about this topic.

    Your hosts file is incorrect, it should read like this:
    Code:
    #::1     localhost ip6-localhost ip6-loopback
    #fe00::0 ip6-localnet
    #ff00::0 ip6-mcastprefix
    #ff02::1 ip6-allnodes
    #ff02::2 ip6-allrouters
    #ff02::3 ip6-allhosts
    127.0.0.1 localhost.localdomain localhost
    # Auto-generated hostname. Please do not remove this comment.
    99.99.99.99 zimbra.mydomain.com zimbra
    Your dig output shows no A record for your server. Make the change to the hosts file and then run the following commands (on the zimbra server):

    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain.com any
    dig yourdomain.com mx
    host `hostname`  <-- use that exact command with backticks not single quotes
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #36
    Join Date
    Jul 2009
    Posts
    8
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain.com any
    dig yourdomain.com mx
    host `hostname` <-- use that exact command with backticks not single quotes
    Here we are:

    cat /etc/hosts:

    Code:
    #::1     localhost ip6-localhost ip6-loopback
    #fe00::0 ip6-localnet
    #ff00::0 ip6-mcastprefix
    #ff02::1 ip6-allnodes
    #ff02::2 ip6-allrouters
    #ff02::3 ip6-allhosts
    127.0.0.1 localhost.localdomain localhost # Auto-generated hostname. Please do not remove
    99.99.99.99 zimbra.mydomain.com zimbra
    cat /etc/resolv.conf:

    Code:
    nameserver 213.133.98.98
    nameserver 145.253.2.75
    nameserver 193.254.185.254
    dig mydomain.com any:

    Code:
    ; <<>> DiG 9.4.2-P2 <<>> zimbra.isprz.de any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 2217
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;zimbra.mydomain.com.               IN      ANY
    
    ;; ANSWER SECTION:
    zimbra.mydomain.com.        14400   IN      MX      10 99.99.99.99.
    zimbra.mydomain.com.        14400   IN      A       99.99.99.99
    
    ;; Query time: 47 msec
    ;; SERVER: 213.133.98.98#53(213.133.98.98)
    ;; WHEN: Mon Aug 24 11:07:29 2009
    ;; MSG SIZE  rcvd: 77

    nslookup mydomain.com:
    Code:
    Server:         213.133.98.98
    Address:        213.133.98.98#53
    
    Non-authoritative answer:
    Name:   zimbra.mydomain.com
    Address: 99.99.99.99
    dig mydomain.com mx:

    Code:
    ; <<>> DiG 9.4.2-P2 <<>> zimbra.mydomain.com mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 11225
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;zimbra.mydomain.com.               IN      MX
    
    ;; ANSWER SECTION:
    zimbra.mydomain.com.        12121   IN      MX      10 99.99.99.99.
    
    ;; Query time: 4 msec
    ;; SERVER: 213.133.98.98#53(213.133.98.98)
    ;; WHEN: Mon Aug 24 11:07:07 2009
    ;; MSG SIZE  rcvd: 61

  7. #37
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    If this is behind a NAT router (or firewall) you should only have one DNS server in your resolv.conf (the DNS server that has your Zimbra records) and you should also have the following:

    Code:
    search yourdomain.com
    If it's not behind a NAT router is it on a public IP? Please also run the 'host' command I asked you for earlier. Otherwise everything looks OK. What problems do you have? Have you looked in the log files for any errors?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #38
    Join Date
    Jul 2009
    Posts
    8
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    If this is behind a NAT router (or firewall) you should only have one DNS server in your resolv.conf (the DNS server that has your Zimbra records) and you should also have the following:

    Code:
    search yourdomain.com
    If it's not behind a NAT router is it on a public IP? Please also run the 'host' command I asked you for earlier. Otherwise everything looks OK. What problems do you have? Have you looked in the log files for any errors?

    It is a virtual root server @ my providerds data center. I knew i was something missing..

    host `hostname`:

    Code:
    not found: 3 (NXDOMAIN)
    I didn't install at all, as long as:

    hostname -a

    Code:
    hostname: Unknown host
    and

    hostname -f

    Code:
    hostname: Unknown host

    won't work, i do not see any good in installing anyway. The installscript also complains about this:

    Code:
    hostname: Unknown host

    So what?
    Thanks for your help. I am trying to get this work for quite a long time...

    jm

  9. #39
    Join Date
    Jul 2009
    Posts
    8
    Rep Power
    6

    Default

    BIF, here my host.conf:

    Code:
    # The "order" line is only used by old versions of the C library.
    order hosts,bind
    multi on
    my /etc/bind/named.conf:

    Code:
    // This is the primary configuration file for the BIND DNS server named.
    //
    // Please read /usr/share/doc/bind9/README.Debian.gz for information on the
    // structure of BIND configuration files in Debian, *BEFORE* you customize
    // this configuration file.
    //
    // If you are just adding zones, please do that in /etc/bind/named.conf.local
    
    include "/etc/bind/named.conf.options";
    
    // prime the server with knowledge of the root servers
    zone "." {
            type hint;
            file "/etc/bind/db.root";
    };
    
    // be authoritative for the localhost forward and reverse zones, and for
    // broadcast zones as per RFC 1912
    
    zone "localhost" {
            type master;
            file "/etc/bind/db.local";
    };
    
    zone "127.in-addr.arpa" {
            type master;
            file "/etc/bind/db.127";
    };
    
    zone "0.in-addr.arpa" {
            type master;
            file "/etc/bind/db.0";
    };
    
    zone "255.in-addr.arpa" {
            type master;
            file "/etc/bind/db.255";
    };
    
    include "/etc/bind/named.conf.local";
    server 145.253.2.75 {
            };
    Anything else i am missing?
    Best and thanks

    jm
    Last edited by just_me; 08-24-2009 at 07:36 AM.

  10. #40
    Join Date
    May 2008
    Location
    Nigeria
    Posts
    92
    Rep Power
    7

    Default

    You may have add forwarders to your BIND, you can use you ISP's DNS servers.
    Last edited by emmaylots; 07-05-2010 at 06:55 AM. Reason: typo

Similar Threads

  1. Get emails out of zimbra or get it working again?
    By kingfeanor in forum Migration
    Replies: 9
    Last Post: 11-25-2008, 01:02 AM
  2. Replies: 4
    Last Post: 08-26-2008, 01:34 PM
  3. Replies: 4
    Last Post: 08-24-2008, 06:45 AM
  4. [SOLVED] ZCS 5.0.8 on Ubuntu 8.04
    By Dominic in forum Installation
    Replies: 5
    Last Post: 07-31-2008, 10:44 PM
  5. Installing Zimbra on Ubuntu 8.04 server
    By murphyml in forum Installation
    Replies: 8
    Last Post: 06-06-2008, 03:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •