Results 1 to 2 of 2

Thread: RHCS transfer even the ZCS service is well

  1. #1
    Join Date
    Apr 2008
    Posts
    7
    Rep Power
    7

    Default RHCS transfer even the ZCS service is well

    hi All,
    i have sth wrong about RHCS & ZCS
    OS: RHEL4u6 64bit
    ZCS: 5.0.7

    i have installed RHCS with ZCS, 3 active mbox and 1 standby.
    but they were seemed sth wrong, one of third mboxs transfer to the standby each 30 days, even the ZCS services are well.

    the RHCS log:
    Oct 27 04:01:32 icbu4 clurgmgrd: [5703]: Executing /opt/zimbra-cluster/bin/zmcluctl status
    Oct 27 04:02:02 icbu4 clurgmgrd: [5703]: Executing /opt/zimbra-cluster/bin/zmcluctl status
    Oct 27 04:02:05 icbu4 syslogd 1.4.1: restart (remote reception).
    Oct 27 04:02:07 icbu4 clurgmgrd: [5703]: script:zimbra: status of /opt/zimbra-cluster/bin/zmcluctl failed (returned 1)
    Oct 27 04:02:07 icbu4 clurgmgrd[5703]: status on script:zimbra returned 1 (generic error)
    Oct 27 04:02:07 icbu4 clurgmgrd[5703]: Stopping service vip.icbu4.com
    Oct 27 04:02:07 icbu4 clurgmgrd: [5703]: Executing /opt/zimbra-cluster/bin/zmcluctl stop
    Oct 27 04:02:13 icbu4 kernel: ZGQOUT:IN= OUT=lo SRC=127.0.0.1 DST=127.0.0.1 LEN=52 TOS=0x00 PREC=0x00 TTL=64 ID=32578 DF PROTO=TCP SPT=47298 DPT=443 WINDOW=1024 RES=0x00 ACK RST URGP=0
    Oct 27 04:02:14 icbu4 kernel: ZGQOUT:IN= OUT=lo SRC=127.0.0.1 DST=127.0.0.1 LEN=52 TOS=0x00 PREC=0x00 TTL=64 ID=37531 DF PROTO=TCP SPT=37964 DPT=443 WINDOW=1024 RES=0x00 ACK RST URGP=0

    the ZCS's log:
    /var/log/zimbra.log:
    Oct 27 04:02:05 icbu4 su(pam_unix)[9730]: session opened for user zimbra by (uid=0)
    Oct 27 04:02:05 icbu4 su(pam_unix)[9730]: session closed for user zimbra
    Oct 27 04:02:05 icbu4 su(pam_unix)[9729]: session opened for user zimbra by (uid=0)
    Oct 27 04:02:05 icbu4 su(pam_unix)[9729]: session closed for user zimbra
    Oct 27 04:02:05 icbu4 su(pam_unix)[9838]: session opened for user zimbra by (uid=0)
    Oct 27 04:02:05 icbu4 su(pam_unix)[9838]: session closed for user zimbra
    Oct 27 04:02:05 icbu4 su(pam_unix)[9837]: session opened for user zimbra by (uid=0)
    Oct 27 04:02:05 icbu4 su(pam_unix)[9837]: session closed for user zimbra
    Oct 27 04:02:06 icbu4 su(pam_unix)[9944]: session opened for user zimbra by (uid=0)
    Oct 27 04:02:06 icbu4 zimbramon[10135]: 10135:info: zmmtaconfig: zmmtaconfig started on vip.icbu4.com with loglevel
    =3 pid=10135
    Oct 27 04:02:06 icbu4 su(pam_unix)[9944]: session closed for user zimbra
    Oct 27 04:02:07 icbu4 sudo: zimbra : TTY=unknown ; PWD=/opt/zimbra-cluster/mountpoints/vip.icbu4.com ; USER=root
    ; COMMAND=/opt/zimbra/libexec/zmmailboxdmgr status
    Oct 27 04:02:07 icbu4 zmmailboxdmgr[10157]: status requested
    Oct 27 04:02:07 icbu4 zmmailboxdmgr[10157]: status OK
    Oct 27 04:02:07 icbu4 su(pam_unix)[9521]: session closed for user zimbra
    Oct 27 04:02:07 icbu4 zimbra-cluster[9230]: status - rc=1 from zmcontrol
    Oct 27 04:02:08 icbu4 su(pam_unix)[10398]: session opened for user zimbra by (uid=0)
    Oct 27 04:02:08 icbu4 zimbramon[10399]: 10399:info: Stopping services initiated by zmcontrol
    Oct 27 04:02:09 icbu4 zimbramon[10399]: 10399:info: Stopping stats via zmcontrol

    and that was happened again after 30 days
    the RHCS log:
    Nov 25 04:02:13 icbu7 su(pam_unix)[19118]: session closed for user zimbra
    Nov 25 04:02:14 icbu7 su(pam_unix)[18775]: session closed for user zimbra
    Nov 25 04:02:14 icbu7 zimbra-cluster[18581]: status - rc=1 from zmcontrol
    Nov 25 04:02:14 icbu7 clurgmgrd: [5466]: script:zimbra: status of /opt/zimbra-cluster/bin/zmcluctl failed (returned 1)
    Nov 25 04:02:14 icbu7 clurgmgrd[5466]: status on script:zimbra returned 1 (generic error)
    Nov 25 04:02:14 icbu7 clurgmgrd[5466]: Stopping service vip.icbu4.com
    Nov 25 04:02:14 icbu7 clurgmgrd: [5466]: Executing /opt/zimbra-cluster/bin/zmcluctl stop
    Nov 25 04:02:15 icbu7 su(pam_unix)[19522]: session opened for user zimbra by (uid=0)

    could you do me a favor?

    thanks a million,
    Aileen

  2. #2
    Join Date
    Nov 2008
    Posts
    7
    Rep Power
    7

    Default maybe the zmcluctl's timeout is the problem

    status on script:zimbra returned 1 (generic error)

    I'm Rhel 5.2 with ZCS 5.0.16
    I had a similar problem with
    status on script:zimbra returned 1 (generic error)

    but I modified /opt/zimbra-cluster/bin/zmcluctl script and I changed this line:
    my $TIMEOUT = 60; # seconds
    my $AGE_LIMIT = 60; # seconds

    by

    my $TIMEOUT = 6000; # seconds
    my $AGE_LIMIT = 6000; # seconds

    growing up the timeout ....

    try it ...


    Quote Originally Posted by aileen View Post
    hi All,
    i have sth wrong about RHCS & ZCS
    OS: RHEL4u6 64bit
    ZCS: 5.0.7

    i have installed RHCS with ZCS, 3 active mbox and 1 standby.
    but they were seemed sth wrong, one of third mboxs transfer to the standby each 30 days, even the ZCS services are well.

    the RHCS log:
    Oct 27 04:01:32 icbu4 clurgmgrd: [5703]: Executing /opt/zimbra-cluster/bin/zmcluctl status
    Oct 27 04:02:02 icbu4 clurgmgrd: [5703]: Executing /opt/zimbra-cluster/bin/zmcluctl status
    Oct 27 04:02:05 icbu4 syslogd 1.4.1: restart (remote reception).
    Oct 27 04:02:07 icbu4 clurgmgrd: [5703]: script:zimbra: status of /opt/zimbra-cluster/bin/zmcluctl failed (returned 1)
    Oct 27 04:02:07 icbu4 clurgmgrd[5703]: status on script:zimbra returned 1 (generic error)
    Oct 27 04:02:07 icbu4 clurgmgrd[5703]: Stopping service vip.icbu4.com
    Oct 27 04:02:07 icbu4 clurgmgrd: [5703]: Executing /opt/zimbra-cluster/bin/zmcluctl stop
    Oct 27 04:02:13 icbu4 kernel: ZGQOUT:IN= OUT=lo SRC=127.0.0.1 DST=127.0.0.1 LEN=52 TOS=0x00 PREC=0x00 TTL=64 ID=32578 DF PROTO=TCP SPT=47298 DPT=443 WINDOW=1024 RES=0x00 ACK RST URGP=0
    Oct 27 04:02:14 icbu4 kernel: ZGQOUT:IN= OUT=lo SRC=127.0.0.1 DST=127.0.0.1 LEN=52 TOS=0x00 PREC=0x00 TTL=64 ID=37531 DF PROTO=TCP SPT=37964 DPT=443 WINDOW=1024 RES=0x00 ACK RST URGP=0

    the ZCS's log:
    /var/log/zimbra.log:
    Oct 27 04:02:05 icbu4 su(pam_unix)[9730]: session opened for user zimbra by (uid=0)
    Oct 27 04:02:05 icbu4 su(pam_unix)[9730]: session closed for user zimbra
    Oct 27 04:02:05 icbu4 su(pam_unix)[9729]: session opened for user zimbra by (uid=0)
    Oct 27 04:02:05 icbu4 su(pam_unix)[9729]: session closed for user zimbra
    Oct 27 04:02:05 icbu4 su(pam_unix)[9838]: session opened for user zimbra by (uid=0)
    Oct 27 04:02:05 icbu4 su(pam_unix)[9838]: session closed for user zimbra
    Oct 27 04:02:05 icbu4 su(pam_unix)[9837]: session opened for user zimbra by (uid=0)
    Oct 27 04:02:05 icbu4 su(pam_unix)[9837]: session closed for user zimbra
    Oct 27 04:02:06 icbu4 su(pam_unix)[9944]: session opened for user zimbra by (uid=0)
    Oct 27 04:02:06 icbu4 zimbramon[10135]: 10135:info: zmmtaconfig: zmmtaconfig started on vip.icbu4.com with loglevel
    =3 pid=10135
    Oct 27 04:02:06 icbu4 su(pam_unix)[9944]: session closed for user zimbra
    Oct 27 04:02:07 icbu4 sudo: zimbra : TTY=unknown ; PWD=/opt/zimbra-cluster/mountpoints/vip.icbu4.com ; USER=root
    ; COMMAND=/opt/zimbra/libexec/zmmailboxdmgr status
    Oct 27 04:02:07 icbu4 zmmailboxdmgr[10157]: status requested
    Oct 27 04:02:07 icbu4 zmmailboxdmgr[10157]: status OK
    Oct 27 04:02:07 icbu4 su(pam_unix)[9521]: session closed for user zimbra
    Oct 27 04:02:07 icbu4 zimbra-cluster[9230]: status - rc=1 from zmcontrol
    Oct 27 04:02:08 icbu4 su(pam_unix)[10398]: session opened for user zimbra by (uid=0)
    Oct 27 04:02:08 icbu4 zimbramon[10399]: 10399:info: Stopping services initiated by zmcontrol
    Oct 27 04:02:09 icbu4 zimbramon[10399]: 10399:info: Stopping stats via zmcontrol

    and that was happened again after 30 days
    the RHCS log:
    Nov 25 04:02:13 icbu7 su(pam_unix)[19118]: session closed for user zimbra
    Nov 25 04:02:14 icbu7 su(pam_unix)[18775]: session closed for user zimbra
    Nov 25 04:02:14 icbu7 zimbra-cluster[18581]: status - rc=1 from zmcontrol
    Nov 25 04:02:14 icbu7 clurgmgrd: [5466]: script:zimbra: status of /opt/zimbra-cluster/bin/zmcluctl failed (returned 1)
    Nov 25 04:02:14 icbu7 clurgmgrd[5466]: status on script:zimbra returned 1 (generic error)
    Nov 25 04:02:14 icbu7 clurgmgrd[5466]: Stopping service vip.icbu4.com
    Nov 25 04:02:14 icbu7 clurgmgrd: [5466]: Executing /opt/zimbra-cluster/bin/zmcluctl stop
    Nov 25 04:02:15 icbu7 su(pam_unix)[19522]: session opened for user zimbra by (uid=0)

    could you do me a favor?

    thanks a million,
    Aileen

Similar Threads

  1. Trouble Sending mail - All Messages deferred!
    By SiteDiscovery in forum Administrators
    Replies: 7
    Last Post: 09-03-2009, 05:52 AM
  2. Replies: 5
    Last Post: 05-28-2009, 01:53 AM
  3. Replies: 20
    Last Post: 03-18-2008, 06:37 AM
  4. Replies: 41
    Last Post: 10-29-2007, 03:36 PM
  5. ZCS 3.2 Beta Available
    By KevinH in forum Announcements
    Replies: 31
    Last Post: 07-07-2006, 04:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •