Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Outgoing mail works, incoming does not

Hybrid View

  1. #1
    Join Date
    Apr 2007
    Posts
    17
    Rep Power
    8

    Default Outgoing mail works, incoming does not

    Can anyone help me out here? Just let me know which logs you need?

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Some idea of which version/release of zimbra and which operating would be a start. Is this a new install or an upgrade? A re you behind a router and do you have a Split DNS set-up? Have a look in the log files and see what errors you're getting. Is it all incoming mail that you're having a problem with or just from some domains? Is there any firewall and/or SElinux enabled on your server?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Apr 2007
    Posts
    17
    Rep Power
    8

    Default

    Sorry, late post before bed, just being lazy.

    - Cent OS 5.2
    - Current release of Zimbra
    - Split DNS (Bind internal and external pointing at public)
    - New installation, got MX DNS error during setup
    - Behind a firewall, opened port 25 to the server
    - I only have one domain, I changed the admin@server.domain.com to admin@domain.com (that should work right?)
    - Disabled SELinux on the server and no other firewall should be running.

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    If the MX check failed then it could be how your DNS is setup. Please post the following
    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain.com mx
    dig yourdomain.com any
    host `hostname` <- note backticks and not singles quotes

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    The usual questions follow. Please post the output of the following commands (run on the zimbra server):

    Code:
    host `hostname`  <-- use backticks not single quotes
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain.com mx
    dig yourdomain.com any
    To make your output easier to read please format the output of each command with the code tag (highlight the text and hit the # symbol above the edit box).
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    Join Date
    Apr 2007
    Posts
    17
    Rep Power
    8

    Default

    I have my MX record pointed at an A record that points to the public IP.

    Code:
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1       localhost.localdomain   localhost
    192.168.0.200   server01.domain.net server01
    ::1     localhost6.localdomain6 localhost6
    Code:
    search domain.net
    nameserver 192.168.0.200
    Code:
    ; <<>> DiG 9.3.4-P1 <<>> domain.net mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 3105
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 4, ADDITIONAL: 4
    
    ;; QUESTION SECTION:
    ;domain.net.               IN      MX
    
    ;; ANSWER SECTION:
    domain.net.        300     IN      MX      10 domain.net.
    
    ;; AUTHORITY SECTION:
    domain.net.        145329  IN      NS      Public DNS.
    domain.net.        145329  IN      NS      Public DNS.
    domain.net.        145329  IN      NS      Public DNS.
    domain.net.        145329  IN      NS      Public DNS.
    
    ;; ADDITIONAL SECTION:
    Public DNS.       147668  IN      A       
    Public DNS.       147668  IN      A       
    Public DNS.       147668  IN      A       
    Public DNS.       147668  IN      A       
    
    ;; Query time: 66 msec
    ;; SERVER: 192.168.0.200#53(192.168.0.200)
    ;; WHEN: Mon Dec  1 08:09:07 2008
    ;; MSG SIZE  rcvd: 194
    Code:
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33929
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 4, ADDITIONAL: 4
    
    ;; QUESTION SECTION:
    ;deobfuscate.net.               IN      ANY
    
    ;; ANSWER SECTION:
    domain.net.        118     IN      MX      10 domain.net.
    domain.net.        145147  IN      NS      .
    domain.net.        145147  IN      NS      .
    domain.net.        145147  IN      NS      .
    domain.net.        145147  IN      NS      .
    
    ;; AUTHORITY SECTION:
    domain.net.        145147  IN      NS      .
    domain.net.        145147  IN      NS      .
    domain.net.        145147  IN      NS      .
    domain.net.        145147  IN      NS      .
    
    ;; ADDITIONAL SECTION:
    .       147486  IN      A       
    .       147486  IN      A       
    .       147486  IN      A       
    .       147486  IN      A       
    
    ;; Query time: 1 msec
    ;; SERVER: 192.168.0.200#53(192.168.0.200)
    ;; WHEN: Mon Dec  1 08:12:09 2008
    ;; MSG SIZE  rcvd: 250
    Code:
    server01.domain.net has address 
    Host server01.domain.net not found: 3(NXDOMAIN)

  7. #7
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    A and MX records should be pointing at your internal IP for the ZCS server and not the public one.

  8. #8
    Join Date
    Apr 2007
    Posts
    17
    Rep Power
    8

    Default

    You are talking about the internal DNS right not the public one? If so where would I make that change?

  9. #9
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    The internal DNS should point to your LAN IP not the external IP, details here: Split DNS - Zimbra :: Wiki
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    In addition, your MX record should be the FQDN of your server not the domain name.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 06:01 AM
  2. Zimbra won't start: slapd loglevel wildness
    By blackpuma in forum Administrators
    Replies: 6
    Last Post: 03-23-2009, 08:07 PM
  3. [SOLVED] mailbox and apache not running
    By rtwick in forum Administrators
    Replies: 4
    Last Post: 11-15-2008, 07:21 AM
  4. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 08:09 AM
  5. Mail not getting to mail boxes
    By ehults in forum Installation
    Replies: 5
    Last Post: 10-31-2005, 08:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •