Results 1 to 3 of 3

Thread: Mailboxd fails to start after install due to java heap memory percent

Hybrid View

  1. #1
    Join Date
    Jan 2008
    Posts
    10
    Rep Power
    7

    Default Mailboxd fails to start after install due to java heap memory percent

    I've been having consistent problems(last 4 upgrades) where during the final stage of the upgrade, the mailbox service does not start because of the java heap memory percent being allocated too large. I have to manually go into the zmmailboxdctl file in /opt/zimbra/bin and hard code a jm=1300 size which sets the mailboxd_java_heap_memory_percent to 46 instead of letting the system calculate it on it's own. I am running 4GB of memory at FC7. Bug 21348 seems to be the orignal problem but it was closed as fixed but I still have the issue. I have seen tuning notes about the default max user space being 2GB in a 32 bit environment but it seems like the install scripts calculates over that amount. Any help would be appreciated.

    One fallout is this in the log:

    Upgrading Document templates...
    Sat Dec 13 22:01:04 2008 *** Running as zimbra user: /opt/zimbra/bin/zmprov ut -h zimbra.acme.com /opt/zimbra/wiki/Template
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
    Sat Dec 13 22:01:05 2008 failed.
    Sat Dec 13 22:01:05 2008 Restarting mailboxd...
    Sat Dec 13 22:01:05 2008 *** Running as zimbra user: /opt/zimbra/bin/zmmailboxdctl restart
    Stopping mailboxd...mailboxd is not running
    Last edited by ozlee; 12-15-2008 at 11:36 AM.

  2. #2
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    Instead of modifying the startup script you should change the localconfig value for mailboxd_java_heap_memory_percent to something suitable for your system. That value should then be retained during upgrades.

    On a 32bit 4GB system it should be set to 37 or lower.

    Code:
    zmlocalconfig -e mailboxd_java_heap_memory_percent=37
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    Join Date
    Jan 2008
    Posts
    10
    Rep Power
    7

    Default

    Have changed the value to 37 per your recommendation and will see if it is retained during the next upgrade. Thx for the help.

Similar Threads

  1. Errors installing Outlook Connector
    By Tim G in forum Zimbra Connector for Outlook
    Replies: 57
    Last Post: 05-05-2011, 03:27 PM
  2. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  3. Replies: 4
    Last Post: 10-22-2007, 02:42 PM
  4. Error Installing Outlook Connector
    By DanO in forum Zimbra Connector for Outlook
    Replies: 17
    Last Post: 08-28-2007, 10:35 AM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •