Results 1 to 9 of 9

Thread: Problems receiving mail from external mailserver

Hybrid View

  1. #1
    Join Date
    Mar 2006
    Posts
    5
    Rep Power
    9

    Default Problems receiving mail from external mailserver

    I have looked over this forum, and found several things close, but nothing that addresses this issues in a helpful manner.

    Zimbra is running, and working just fine. The only problem is receiving mail from external mail servers. I can send and receive fine internally, and send find externally. When a user sends an email from an external account (yahoo.com, gmail.com, etc) they get a bounce back saying the message could not be delivered.

    We are using a spam filtering system with our ISP. All mail sent to your domian is first sent to their mail server (mail.isp.com) and then passed on to ours. The error comes up when their mail server (mail.isp.com) tries and handoff the mail to us.

    I have spoken with the ISP on this, and they are saying that my mail server (zimbra I assume?) is refusing to accept the mail from their mail server.

    My question:
    How do I setup Zimbra to accept incoming mail from their mail server?

    Thanks for any help.

  2. #2
    Join Date
    Nov 2005
    Posts
    518
    Rep Power
    10

    Default

    have you looked in /var/log/zimbra.log to see what postfix says when it bounces their deliveries? to what domain(s) are the inbound messages destined? are those domains provisioned in zimbra (zmprov gad)?

  3. #3
    Join Date
    Nov 2005
    Posts
    518
    Rep Power
    10

    Default

    assuming your server is behind a firewall, is it forwarding inbound traffic on port 25 to the server? does the machine itself have the firewall in effect (iptables --list)?

  4. #4
    Join Date
    Mar 2006
    Posts
    5
    Rep Power
    9

    Default

    Bobby,
    Im not at the server right now, so i can't post logs, but if needed i will when i return to that location. as far as the questions, to my understanding the mail is arriving at the zimbra mail server, and is being rejected because its from an unknown sender. (what im getting from the ISP is: my mail server isn't allowing mail.isp.com to delivar mail for @mydomain.com)

    Zimbra is setup for my domian, the firewall is fowarded and all. I can telnet to the mail server on port 25 and "hand deliver" a message just fine. When i receive mail from zimbra on an external address, such as my personal yahoo mail, the message headers indicate its comming from my mail server from the correct user. The only problem with the setup, from what i can figure out, is that the postfix inside Zimbra isn;t letting the ISP email forward/relay/ mail to the zimbra server.

    As you can tell, I don't know much about email, if i made any errors in the syntax of things let me know.

  5. #5
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Hi,
    Out of curiosity, what makes you think the mail is getting to the server?

  6. #6
    Join Date
    Mar 2006
    Posts
    5
    Rep Power
    9

    Default

    Quote Originally Posted by wannabetenor
    Hi,
    Out of curiosity, what makes you think the mail is getting to the server?
    I receive a message from the ISP's mail server saying
    Code:
    This message was created automatically by mail delivery software.
    
    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:
    
     an undisclosed address
       (generated from administrator@XXX.com)
    I talked with the email guys at the ISP, and they checked their logs. They are saying the message is getting to their email system its doing the scrubbing/scanning/whatever and then attempts to hand it off to our email server, at this point, the connection is refused. What I am getting from them is along the lines of "when 'we' try and pass the mail to 'you' your mail server is refusing because 'you' don't accept relayed messages".

    I only understand about 60% of what they are telling me. I will be happy to provide as much information as is needed, but I am not sure what you guys will need, so just ask. Thanks.

    Also, I have been reading on the postfix website, (which is the email server Zimbra uses, correct?) in the docs, it talks about the $relayhost parameter. Would adding their mail server name to this parameter solve this problem? Or am I on the wrong thing again?

    Thanks for the help.

Similar Threads

  1. Problems with port 25
    By yogiman in forum Installation
    Replies: 57
    Last Post: 06-13-2011, 01:55 PM
  2. Replies: 7
    Last Post: 02-03-2011, 06:01 AM
  3. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 08:09 AM
  4. DynDNS and Zimbra
    By afterwego in forum Installation
    Replies: 30
    Last Post: 04-01-2007, 03:34 PM
  5. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 03:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •