Page 3 of 3 FirstFirst 123
Results 21 to 29 of 29

Thread: Network problems

  1. #21
    Join Date
    Apr 2006
    Posts
    25
    Rep Power
    9

    Default

    Quote Originally Posted by KevinH
    Tomcat will redirect to the name of the server that is defined in zimbra. If you have the latest 3.1 release you can set a redirect=0 in the url to prevent the redirect.
    Kevin,

    Successfully update to 3.1. Still getting redirect to tmocon.com.

    Where do I update redirect=0 in the url

    to prevent redirect?

    Thanks.
    Tom

  2. #22
    Join Date
    Apr 2006
    Posts
    25
    Rep Power
    9

    Default

    Kevin,

    Also just retried to send myself email from another domain and I watched /var/log/zimbra.log and got what I did before.

    Apr 16 19:06:23 enterprise postfix/smtpd[23794]: initializing the server-side TLS engine
    Apr 16 19:06:23 enterprise postfix/smtpd[23794]: connect from static24-72-53-29.regina.accesscomm.ca[24.72.53.29]
    Apr 16 19:06:24 enterprise postfix/smtpd[23794]: 303CF11105E7: client=static24-72-53-29.regina.accesscomm.ca[24.72.53.29]
    Apr 16 19:06:24 enterprise postfix/cleanup[23797]: 303CF11105E7: message-id=<200604170206.k3H263H06694@cawsey.com>
    Apr 16 19:06:24 enterprise postfix/qmgr[20496]: 303CF11105E7: from=, size=511, nrcpt=1 (queue active)
    Apr 16 19:06:24 enterprise postfix/smtpd[23794]: disconnect from static24-72-53-29.regina.accesscomm.ca[24.72.53.29]
    Apr 16 19:06:24 enterprise amavis[17942]: (17942-01) ESMTP::10024 /opt/zimbra/amavisd/tmp/amavis-20060416T190624-17942: -> Received: SIZE=511 from enterprise.office.tmocon.com ([127.0.0.1]) by localhost (enterprise.office.tmocon.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 17942-01 for ; Sun, 16 Apr 2006 19:06:24 -0600 (MDT)
    Apr 16 19:06:24 enterprise amavis[17942]: (17942-01) Checking: K3LdiiAYyLxW [24.72.53.29] ->
    Apr 16 19:06:24 enterprise clamd[18413]: SelfCheck: Database status OK.
    Apr 16 19:06:25 enterprise postfix/smtpd[23802]: initializing the server-side TLS engine
    Apr 16 19:06:25 enterprise postfix/smtpd[23802]: connect from localhost.localdomain[127.0.0.1]
    Apr 16 19:06:25 enterprise postfix/smtpd[23802]: BBE6311105E8: client=localhost.localdomain[127.0.0.1]
    Apr 16 19:06:25 enterprise postfix/cleanup[23797]: BBE6311105E8: message-id=<200604170206.k3H263H06694@cawsey.com>
    Apr 16 19:06:25 enterprise postfix/qmgr[20496]: BBE6311105E8: from=, size=1372, nrcpt=1 (queue active)
    Apr 16 19:06:25 enterprise amavis[17942]: (17942-01) FWD via SMTP: -> , 250 2.6.0 Ok, id=17942-01, from MTA([127.0.0.1]:10025): 250 Ok: queued as BBE6311105E8
    Apr 16 19:06:25 enterprise amavis[17942]: (17942-01) Passed CLEAN, [24.72.53.29] [24.72.53.29] -> , Message-ID: <200604170206.k3H263H06694@cawsey.com>, mail_id: K3LdiiAYyLxW, Hits: -1.966, 1424 ms
    Apr 16 19:06:25 enterprise amavis[17942]: (17942-01) extra modules loaded: Net/LDAP/Bind.pm
    Apr 16 19:06:25 enterprise postfix/smtpd[23802]: disconnect from localhost.localdomain[127.0.0.1]
    Apr 16 19:06:25 enterprise postfix/smtp[23798]: 303CF11105E7: to=, relay=127.0.0.1[127.0.0.1], delay=1, status=sent (250 2.6.0 Ok, id=17942-01, from MTA([127.0.0.1]:10025): 250 Ok: queued as BBE6311105E8)
    Apr 16 19:06:25 enterprise postfix/qmgr[20496]: 303CF11105E7: removed
    Apr 16 19:06:25 enterprise postfix/lmtp[23803]: BBE6311105E8: to=, relay=none, delay=0, status=deferred (connect to tmocon.com[142.179.181.139]: Connection refused)

  3. #23
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    - Add ?redirect=0 to the URL.

    - The reason your getting initMode=http is you have the https/tls type set to mixed or both. If you want only http or https just reset that value.
    su - zimbra
    zmtlsctl https (or both, http, mixed)
    tomcat stop
    tomcat start

    - Still looks like you have DNS issues where the domains are resolving to an external IP/domain rather than to the local/internal IP.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  4. #24
    Join Date
    Apr 2006
    Posts
    25
    Rep Power
    9

    Default

    Kevin,

    I still can't receive email, so I'm going to try and solve the other problems first. Before when I logged in I used the URL vortex.tmocon.com/zimbra

    Now I have to use the URL vortex.tmocon.com/zimbra/?redirect=0

    What would have changed to force me to do this?

    Also, when I do finally login I get an error saying this is the wrong host you want tmocon.com. I've attached a screen shot.

    Tom
    Attached Files Attached Files

  5. #25
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    What name does zmhostname return?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #26
    Join Date
    Apr 2006
    Posts
    25
    Rep Power
    9

    Default

    zmhostname returns enterprise.office.tmocon.com which is a private interface on my zimbra box.

    Tom

  7. #27
    Join Date
    Apr 2006
    Posts
    25
    Rep Power
    9

    Default

    Also, zmprov gs enterprise.office.tmocon.com returns:

    prov> gs enterprise.office.tmocon.com
    # name enterprise.office.tmocon.com
    cn: enterprise.office.tmocon.com
    objectClass: zimbraServer
    zimbraAdminPort: 7071
    zimbraFileUploadMaxSize: 10485760
    zimbraId: 9636bfbb-a0d8-4df9-9ca8-417b68f8032d
    zimbraImapBindOnStartup: TRUE
    zimbraImapBindPort: 143
    zimbraImapCleartextLoginEnabled: FALSE
    zimbraImapNumThreads: 200
    zimbraImapSSLBindOnStartup: TRUE
    zimbraImapSSLBindPort: 993
    zimbraImapSSLServerEnabled: TRUE
    zimbraImapServerEnabled: TRUE
    zimbraLmtpBindOnStartup: FALSE
    zimbraLmtpBindPort: 7025
    zimbraLmtpNumThreads: 20
    zimbraMailMode: http
    zimbraMailPort: 80
    zimbraMailSSLPort: 443
    zimbraMessageCacheSize: 1671168
    zimbraMtaAuthEnabled: TRUE
    zimbraMtaAuthHost: enterprise.office.tmocon.com
    zimbraMtaAuthURL: http://enterprise.office.tmocon.com:80/service/soap/
    zimbraMtaDnsLookupsEnabled: TRUE
    zimbraMtaTlsAuthOnly: TRUE
    zimbraPop3BindOnStartup: TRUE
    zimbraPop3BindPort: 110
    zimbraPop3CleartextLoginEnabled: FALSE
    zimbraPop3NumThreads: 20
    zimbraPop3SSLBindOnStartup: TRUE
    zimbraPop3SSLBindPort: 995
    zimbraPop3SSLServerEnabled: TRUE
    zimbraPop3ServerEnabled: TRUE
    zimbraRedoLogArchiveDir: redolog/archive
    zimbraRedoLogDeleteOnRollover: TRUE
    zimbraRedoLogEnabled: TRUE
    zimbraRedoLogFsyncIntervalMS: 10
    zimbraRedoLogLogPath: redolog/redo.log
    zimbraRedoLogRolloverFileSizeKB: 102400
    zimbraRemoteManagementCommand: /opt/zimbra/libexec/zmrcd
    zimbraRemoteManagementPort: 22
    zimbraRemoteManagementPrivateKeyPath: /opt/zimbra/.ssh/zimbra_identity
    zimbraRemoteManagementUser: zimbra
    zimbraServiceEnabled: antivirus
    zimbraServiceEnabled: antispam
    zimbraServiceEnabled: logger
    zimbraServiceEnabled: mailbox
    zimbraServiceEnabled: mta
    zimbraServiceEnabled: snmp
    zimbraServiceEnabled: ldap
    zimbraServiceEnabled: spell
    zimbraServiceHostname: enterprise.office.tmocon.com
    zimbraServiceInstalled: antivirus
    zimbraServiceInstalled: antispam
    zimbraServiceInstalled: logger
    zimbraServiceInstalled: mailbox
    zimbraServiceInstalled: mta
    zimbraServiceInstalled: snmp
    zimbraServiceInstalled: ldap
    zimbraServiceInstalled: spell
    zimbraSmtpHostname: localhost
    zimbraSmtpPort: 25
    zimbraSmtpSendPartial: FALSE
    zimbraSmtpTimeout: 60
    zimbraSpellCheckURL: http://enterprise.office.tmocon.com:7780/aspell.php
    zimbraTableMaintenanceGrowthFactor: 10
    zimbraTableMaintenanceMaxRows: 1000000
    zimbraTableMaintenanceMinRows: 10000
    zimbraTableMaintenanceOperation: ANALYZE
    zimbraVirusDefinitionsUpdateFrequency: 2h

  8. #28
    Join Date
    Apr 2006
    Posts
    25
    Rep Power
    9

    Default

    1) I shutdown zimbra.
    2) I moved /opt/zimbra to /opt/zimbra_saved
    3) I changed my hostname to the one that is associated with my public IP Address
    4) I ran zcs/uninstall.sh -u to remove zimbra
    5) I ran zcs/install.sh to install zimbra
    6) Everything is working as expected (including sending/receiving email and no page redirections to unexpected domain names).

    One last thing: now I'm stuck with users email, folders and contacts that are in /opt/zimbra_saved

    Can you help me to figure out how I can move folders, emails and contacts from /opt/zimbra_saved (corrupted install) to /opt/zimbra (working install).

    Thanks.
    Tom

  9. #29
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Well glad you got yourself on a single hostname now, but not sure how to migrate over the mail. In general we don't have tools to read all the data raw and feed it back in. You could try to use lmtpinject but this won't get folders, tags, unread/read, etc.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

Similar Threads

  1. Replies: 0
    Last Post: 03-26-2007, 06:06 AM
  2. Replies: 1
    Last Post: 12-19-2006, 02:58 PM
  3. Network Edition restore problems??
    By jdell in forum Administrators
    Replies: 0
    Last Post: 10-25-2006, 06:00 PM
  4. Problems while installing Zimbra Network Edition
    By mansuper in forum Installation
    Replies: 8
    Last Post: 06-29-2006, 04:42 AM
  5. Network M2 slow/"slow to respond" issues
    By Sam Hunter in forum Installation
    Replies: 8
    Last Post: 12-29-2005, 11:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •