Results 1 to 10 of 10

Thread: install error. SLAPD not starting?

  1. #1
    Join Date
    Oct 2005
    Posts
    10
    Rep Power
    9

    Default install error. SLAPD not starting?

    When i install I get this error
    Starting servers...Calling GetServiceInfoRequest (zimbra.onamia.k12.mn.us)

    RESPONSE: (Zimbra::Mon::serviceInfo)
    host
    ip 10.0.176.39
    name zimbra.onamia.k12.mn.us
    done
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException zimbra.onamia.k12.mn.us:389)

    Installation complete!

    when I do a ps -uux | grep for slapd or zimbra, I get nothing returned indacating slapd. When I search on zimbra I get a lot of mysql/jave/ perl misc stuff but no ldap.
    Any ideas?
    Also, i should mention that I installed this on FC4 so that may be the issue.

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Try: ldd /opt/zimbra/openldap/libexec/slapd

    If that looks ok then try the instructions here:
    http://www.zimbra.com/forums/showthr...=slapd#post142

  3. #3
    Join Date
    Oct 2005
    Posts
    10
    Rep Power
    9

    Default tried that

    when I run the last command I get an error while loading shared libraries: libssl.so.4
    I have copied the results of the command below. Do I need to sym link the library file from somewhere else?


    [zimbra@zimbra ~]$ /opt/zimbra/libexec/zmldapinit
    /opt/zimbra/openldap/sbin/slappasswd: error while loading shared libraries: libssl.so.4: cannot open shared object file: No such file or directory
    /opt/zimbra/openldap/sbin/slappasswd: error while loading shared libraries: libssl.so.4: cannot open shared object file: No such file or directory
    db_recover: Finding last valid log LSN: file: 1 offset 28
    /opt/zimbra/openldap/libexec/slapd: error while loading shared libraries: libssl.so.4: cannot open shared object file: No such file or directory
    Started slapd: pid
    /opt/zimbra/openldap/bin/ldapmodify: error while loading shared libraries: libssl.so.4: cannot open shared object file: No such file or directory
    /opt/zimbra/openldap/bin/ldapmodify: error while loading shared libraries: libssl.so.4: cannot open shared object file: No such file or directory
    [zimbra@zimbra ~]$

  4. #4
    Join Date
    Oct 2005
    Posts
    10
    Rep Power
    9

    Default more infor on libs not found

    [root@zimbra ~]# ldd /opt/zimbra/openldap/libexec/slapd
    linux-gate.so.1 => (0x00718000)
    libdb-4.2.so => /opt/zimbra/lib/libdb-4.2.so (0x00bdc000)
    libsasl2.so.2 => /opt/zimbra/cyrus-sasl/lib/libsasl2.so.2 (0x008b7000)
    libssl.so.4 => not found
    libcrypto.so.4 => not found
    libresolv.so.2 => /lib/libresolv.so.2 (0x00655000)
    libpthread.so.0 => /lib/libpthread.so.0 (0x00641000)
    libc.so.6 => /lib/libc.so.6 (0x004d4000)
    libdl.so.2 => /lib/libdl.so.2 (0x00600000)
    /lib/ld-linux.so.2 (0x004b6000)

  5. #5
    Join Date
    Oct 2005
    Posts
    10
    Rep Power
    9

    Default fixed

    I made sym links to the libssl.so.5 and libcrypto.so.5 and all is well

    ln -s /lib/libssl.so.5 /lib/libssl.so.4
    ln -s /lib/libcrypto.so.5 /lib/libcrypto.so.4

    then reinstalled and all works well now.

  6. #6
    Join Date
    Oct 2005
    Posts
    15
    Rep Power
    9

    Default how do you make these links

    can you just specify how to make these sym links, like what is the syntax

  7. #7
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Quote Originally Posted by ramidotcom
    can you just specify how to make these sym links, like what is the syntax
    What superman posted is the exact syntax.

  8. #8
    Join Date
    Oct 2005
    Location
    Saint Louis, MO
    Posts
    16
    Rep Power
    9

    Default

    Quote Originally Posted by ramidotcom
    can you just specify how to make these sym links, like what is the syntax
    Code:
    ln -s /usr/lib/libssl.so.0.9.7 /lib/libssl.so.4
    ln -s /usr/lib/libpcre.so.3 /lib/libpcre.so.0
    ln -s /usr/lib/libcrypto.so.0.9.7 /lib/libcrypto.so.4
    fak3r

  9. #9
    Join Date
    Mar 2007
    Posts
    10
    Rep Power
    8

    Unhappy How to unlinks.

    Quote Originally Posted by superman View Post
    I made sym links to the libssl.so.5 and libcrypto.so.5 and all is well

    ln -s /lib/libssl.so.5 /lib/libssl.so.4
    ln -s /lib/libcrypto.so.5 /lib/libcrypto.so.4

    then reinstalled and all works well now.
    I follow your way, it doesn't work. How can I unlinks that I did links before? Thanks.

  10. #10
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    rm /lib/libssl.so.4
    rm /lib/libcrypto.so.4

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 06:01 AM
  2. postfix stopped
    By riegersteve in forum Administrators
    Replies: 1
    Last Post: 05-15-2007, 03:25 PM
  3. Error after install when starting up
    By tedharris in forum Installation
    Replies: 3
    Last Post: 04-19-2006, 05:06 PM
  4. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 10:11 PM
  5. Zimbra on Debian?
    By omry_y in forum Installation
    Replies: 25
    Last Post: 11-04-2005, 10:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •