Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 30

Thread: fc4 zcs-3.0.1 -> 3.1 upgrade worked great.. almost

  1. #11
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    zimbra user. Is port 22 open on your firewall? Is this a single node install?
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  2. #12
    Join Date
    Sep 2005
    Posts
    135
    Rep Power
    10

    Default

    its a single node install, the ssh port is open, and i changed the zimbraRemoteManagementPort to the correct ssh port.

    running zmqstat as the zimbra user now works from a shell, after changing the spool/ dir to chmod 440 (zimbra is in the postfix group, which is the file group).

    getting the same error in the admin console (which accurately reflects the correct ssh port).

    do i have to do a tomcat restart?

  3. #13
    Join Date
    Sep 2005
    Posts
    135
    Rep Power
    10

    Default

    tomcat restart didn't fix it either.
    also
    Code:
    [zimbra@mail postfix-2.2.9]$ /opt/zimbra/libexec/zmqstat all
    Can't chdir to /opt/zimbra/postfix-2.2.9/spool/all at /opt/zimbra/libexec/zmqstat line 182.
    [zimbra@mail postfix-2.2.9]$

  4. #14
    Join Date
    Sep 2005
    Posts
    135
    Rep Power
    10

    Default

    clicking on the individual queue tabs works.. so it updates each queue individually, just not the summary data.

    is it sending the command "zmqstat all" and what is it looking to recieve?

    ive tried hacking it to return the summary data for each queue, and setting $readfiles=1 for all.

    both throw the same exception.

    Message: system failure: exception executing command: zmqstat all

  5. #15
    Join Date
    Sep 2005
    Posts
    274
    Rep Power
    10

    Default

    adobrin,

    zmqstat is invoked with sudo.

    $ sudo /opt/zimbra/libexec/zmqstat

    Does that work for you?
    Bugzilla - Wiki - Downloads - Before posting... Search!

  6. #16
    Join Date
    Sep 2005
    Posts
    135
    Rep Power
    10

    Default

    yes, from a shell.

  7. #17
    Join Date
    Sep 2005
    Posts
    274
    Rep Power
    10

    Default

    adobrin,

    it is very strange that individual queues work, but not the global queue count. They all use the same underlying calls (pretty much). I don't know why your zmqstat (the all version) command is erroring with 127.

    can you run this command (with your server name ofcourse). If it runs, then it there is a problem in the Java ssh client level otherwise it is in the sshd/zmrcd level. Let's find out.

    Code:
          $ /opt/zimbra/libexec/zmrc bolton.liquidsys.com
          HOST:bolton.liquidsys.com zmqstat all
    (out) hold=5071
    (out) corrupt=0
    (out) deferred=2
    (out) active=0
    (out) incoming=0
    Note that the lines marked OUT are the lines you should get - in your case the counts are probably 0 though.

    Since you seem to be hacking zmqstat and what not you should be aware that the "zmqstat all" gets translated into plain "zmqstat" by zmrcd.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  8. #18
    Join Date
    Sep 2005
    Posts
    135
    Rep Power
    10

    Default

    anand,


    the zmrc command is saying "port 22: Connection Refused"

    note that neither zmlocalconfig zimbraRemoteManagementPort, nor zmprov ms mailserver.tld zimbraRemoteManagementPort are set to 22.

  9. #19
    Join Date
    Sep 2005
    Posts
    135
    Rep Power
    10

    Default

    if i manually add -p [zimbraRemoteManagementPort] to zmrc, the following error:

    bash: /opt/zimbra/bin/zmrcd: No such file or directory

    and a symbolic link from libexec/zmrcd to bin/zmrcd solves the issue.

    thanks!

  10. #20
    Join Date
    Sep 2005
    Posts
    274
    Rep Power
    10

    Default

    yeah zmrc is hardcoded to use port 22 (hmm that might have to be bugzilla'd).

    Try this instead (changing port number and host name):
    Code:
    $ echo "HOST:bolton.liquidsys.com zmqstat all" | ssh -T -i /opt/zimbra/.ssh/zimbra_identity -p 22 zimbra@bolton.liquidsys.com
    I get:
    Code:
    hold=5071
    corrupt=0
    deferred=2
    active=0
    incoming=0
    Bugzilla - Wiki - Downloads - Before posting... Search!

Similar Threads

  1. Trouble Sending mail - All Messages deferred!
    By SiteDiscovery in forum Administrators
    Replies: 7
    Last Post: 09-03-2009, 04:52 AM
  2. ZCS 3.2 Beta Available
    By KevinH in forum Announcements
    Replies: 31
    Last Post: 07-07-2006, 03:46 PM
  3. ZCS 3.1 upgrade
    By dent in forum Administrators
    Replies: 29
    Last Post: 05-16-2006, 12:33 AM
  4. Interupted 3.0 -> 3.1 upgrade
    By bin2hex in forum Installation
    Replies: 10
    Last Post: 05-03-2006, 09:07 PM
  5. From 3.0.1 --> 3.1 issues -- fixes
    By shankwc in forum Administrators
    Replies: 5
    Last Post: 04-28-2006, 09:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •