Page 1 of 4 123 ... LastLast
Results 1 to 10 of 31

Thread: mailbox services stopped after hostname change and reboot

  1. #1
    Join Date
    Jan 2009
    Posts
    22
    Rep Power
    6

    Default mailbox services stopped after hostname change and reboot

    I change the hostname by typing hostname MYNEWEHOSTNAME

    restarted zimbra all works fine but now I needed to reboot the system and mailbox did not start (or started and stopped again)

    this is what the mailbox.log say's (from where the error occurs)
    Code:
    2009-01-12 12:03:57,918 INFO  [main] [] system - Setting mysql connector property: maxActive=100
    2009-01-12 12:03:58,069 FATAL [main] [] system - Config initialization failed
    com.zimbra.common.service.ServiceException: system failure: getting all config entries
    ExceptionId:main:1231758238068:46d4502cfd85f9f6
    Code:service.FAILURE
            at com.zimbra.common.service.ServiceException.FAILURE(ServiceException.java:253)
            at com.zimbra.cs.db.DbConfig.getAll(DbConfig.java:166)
            at com.zimbra.cs.util.Config.init(Config.java:66)
            at com.zimbra.cs.util.Config.initConfig(Config.java:91)
            at com.zimbra.cs.util.Config.getString(Config.java:103)
            at com.zimbra.cs.db.Versions.checkDBVersion(Versions.java:77)
            at com.zimbra.cs.db.Versions.checkVersions(Versions.java:73)
            at com.zimbra.cs.util.Zimbra.startup(Zimbra.java:156)
            at com.zimbra.cs.util.Zimbra.startup(Zimbra.java:129)
            at com.zimbra.soap.SoapServlet.init(SoapServlet.java:114)
            at javax.servlet.GenericServlet.init(GenericServlet.java:241)
            at org.mortbay.jetty.servlet.ServletHolder.initServlet(ServletHolder.java:433)
            at org.mortbay.jetty.servlet.ServletHolder.doStart(ServletHolder.java:256)
            at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:40)
            at org.mortbay.jetty.servlet.ServletHandler.initialize(ServletHandler.java:612)
            at org.mortbay.jetty.servlet.Context.startContext(Context.java:139)
            at org.mortbay.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1222)
            at org.mortbay.jetty.handler.ContextHandler.doStart(ContextHandler.java:501)
            at org.mortbay.jetty.webapp.WebAppContext.doStart(WebAppContext.java:449)
            at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:40)
            at org.mortbay.jetty.handler.HandlerCollection.doStart(HandlerCollection.java:147)
            at org.mortbay.jetty.handler.ContextHandlerCollection.doStart(ContextHandlerCollection.java:161)
            at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:40)
            at org.mortbay.jetty.handler.HandlerCollection.doStart(HandlerCollection.java:147)
            at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:40)
            at org.mortbay.jetty.handler.HandlerWrapper.doStart(HandlerWrapper.java:117)
            at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:40)
            at org.mortbay.jetty.handler.HandlerWrapper.doStart(HandlerWrapper.java:117)
            at org.mortbay.jetty.Server.doStart(Server.java:217)
            at org.mortbay.setuid.SetUIDServer.doStart(SetUIDServer.java:100)
            at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:40)
            at org.mortbay.xml.XmlConfiguration.main(XmlConfiguration.java:979)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:585)
            at org.mortbay.start.Main.invokeMain(Main.java:183)
            at org.mortbay.start.Main.start(Main.java:497)
            at org.mortbay.start.Main.main(Main.java:115)
    Caused by: java.sql.SQLException: Incorrect information in file: './zimbra/config.frm'
    
    Query being executed when exception was thrown:
    
    SELECT * FROM config
            at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:946)
            at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:2870)
            at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:1573)
            at com.mysql.jdbc.MysqlIO.sqlQueryDirect(MysqlIO.java:1665)
            at com.mysql.jdbc.Connection.execSQL(Connection.java:3124)
            at com.mysql.jdbc.PreparedStatement.executeInternal(PreparedStatement.java:1149)
            at com.mysql.jdbc.PreparedStatement.executeQuery(PreparedStatement.java:1262)
            at org.apache.commons.dbcp.DelegatingPreparedStatement.executeQuery(DelegatingPreparedStatement.java:205)
            at com.zimbra.cs.db.DbConfig.getAll(DbConfig.java:160)
            ... 37 more
    this part is also weard:
    Code:
    Caused by: java.sql.SQLException: Incorrect information in file: './zimbra/config.frm'
    this file does not exist, there is a file called config.7558 but user zimbra has no rights to read that file.

    I tryed copying that file to config.frm and zet chmod to 777 but that did not help.

    I have no idea what the error means and where to look at. the system worked fine for some weeks.

    Help would be very much appreciated.
    especially because this is a production/live server and mail is now not working.

    Dimitri

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Welcome to the forums

    ZCS is tied to the server hostname ! Did you check the wiki for :-

    ZmSetServerName - Zimbra :: Wiki

  3. #3
    Join Date
    Jan 2009
    Posts
    22
    Rep Power
    6

    Default

    Thank you for your welcome.

    I did run that tool also with the same results.
    should i reset the hostname back for it to work?
    I changed this because we got list in CBL for wrong HELO so i needed to change this.

    what does the error say? or can I find out what is wrong in the config?

    thanks for your fast reply and help.

    Dimitri

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Validate that your hosts file is correct and the DNS resolution is working.
    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain mx
    dig yourdomain any
    host `hostname` <- note backticks and not single quotes

  5. #5
    Join Date
    Jan 2009
    Posts
    22
    Rep Power
    6

    Default

    I have split dns setup that is not changed as far as I can see

    Code:
    zimbra@mail:/root$ cat /etc/hosts
    127.0.0.1       localhost localhost.localdomain
    192.168.1.2     zimbra.1-vision.nl zimbra
    #80.101.83.132  zimbra.1-vision.nl
    
    # The following lines are desirable for IPv6 capable hosts
    #::1     ip6-localhost ip6-loopback
    #fe00::0 ip6-localnet
    #ff00::0 ip6-mcastprefix
    #ff02::1 ip6-allnodes
    #ff02::2 ip6-allrouters
    #ff02::3 ip6-allhosts
    
    #192.168.1.1     fileserv
    #192.168.1.3     testlab
    #192.168.1.175   terastation     tera
    #192.168.1.254   gateway
    Code:
    zimbra@mail:/root$ cat /etc/resolv.conf
    nameserver 192.168.1.2
    nameserver 194.109.6.66
    nameserver 194.109.9.99
    Code:
    zimbra@mail:/root$ dig zimbra.1-vision.nl mx
    
    ; <<>> DiG 9.3.2-P2.1 <<>> zimbra.1-vision.nl mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 24726
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;zimbra.1-vision.nl.            IN      MX
    
    ;; ANSWER SECTION:
    zimbra.1-vision.nl.     2592000 IN      MX      10 zimbra.1-vision.nl.
    
    ;; AUTHORITY SECTION:
    zimbra.1-vision.nl.     2592000 IN      NS      192.168.1.2.zimbra.1-vision.nl.
    
    ;; ADDITIONAL SECTION:
    zimbra.1-vision.nl.     2592000 IN      A       192.168.1.2
    
    ;; Query time: 0 msec
    ;; SERVER: 192.168.1.2#53(192.168.1.2)
    ;; WHEN: Mon Jan 12 13:01:20 2009
    ;; MSG SIZE  rcvd: 94
    Code:
    zimbra@mail:/root$ dig zimbra.1-vision.nl any
    
    ; <<>> DiG 9.3.2-P2.1 <<>> zimbra.1-vision.nl any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 11293
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 1, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;zimbra.1-vision.nl.            IN      ANY
    
    ;; ANSWER SECTION:
    zimbra.1-vision.nl.     2592000 IN      MX      10 zimbra.1-vision.nl.
    zimbra.1-vision.nl.     2592000 IN      A       192.168.1.2
    zimbra.1-vision.nl.     2592000 IN      NS      192.168.1.2.zimbra.1-vision.nl.
    zimbra.1-vision.nl.     2592000 IN      SOA     zimbra.1-vision.nl. hostmaster.zimbra.1-vision.nl. 10118 43200 3600 3600000 2592000
    
    ;; AUTHORITY SECTION:
    zimbra.1-vision.nl.     2592000 IN      NS      192.168.1.2.zimbra.1-vision.nl.
    
    ;; ADDITIONAL SECTION:
    zimbra.1-vision.nl.     2592000 IN      A       192.168.1.2
    
    ;; Query time: 0 msec
    ;; SERVER: 192.168.1.2#53(192.168.1.2)
    ;; WHEN: Mon Jan 12 13:01:59 2009
    ;; MSG SIZE  rcvd: 171
    mm this last option is not working for me also tryed it as root:
    Code:
    zimbra@mail:/root$ host `zimbra.1-vision.nl`
    bash: zimbra.1-vision.nl: command not found
    Usage: host [-aCdlriTwv] [-c class] [-N ndots] [-t type] [-W time]
                [-R number] hostname [server]
           -a is equivalent to -v -t *
           -c specifies query class for non-IN data
           -C compares SOA records on authoritative nameservers
           -d is equivalent to -v
           -l lists all hosts in a domain, using AXFR
           -i IP6.INT reverse lookups
           -N changes the number of dots allowed before root lookup is done
           -r disables recursive processing
           -R specifies number of retries for UDP packets
           -t specifies the query type
           -T enables TCP/IP mode
           -v enables verbose output
           -w specifies to wait forever for a reply
           -W specifies how long to wait for a reply
           -4 use IPv4 query transport only
           -6 use IPv6 query transport only
    zimbra@mail:/root$
    the others look as the were before

  6. #6
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Code:
    host `hostname`
    type it as is hostname is a system command so please do not replace with your actual hostname. The system will work out what it thinks it is.

  7. #7
    Join Date
    Jan 2009
    Posts
    22
    Rep Power
    6

    Default

    oop sorry ok now it worked:
    Code:
    root@mail ~ # host `hostname`
    zimbra.1-vision.nl has address 192.168.1.2
    zimbra.1-vision.nl mail is handled by 10 zimbra.1-vision.nl.

  8. #8
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Hmmm ... okay lets see what this shows
    Code:
    su - zimbra
    zmcontrol stop
    zmcontrol start
    ps aux | grep mysql

  9. #9
    Join Date
    Jan 2009
    Posts
    22
    Rep Power
    6

    Default

    ok here we go:
    Code:
    root@mail ~ # su - zimbra
    zimbra@zimbra:~$ zmcontrol stop
    Host zimbra.1-vision.nl
            Stopping stats...Done
            Stopping mta...Done
            Stopping spell...Done
            Stopping snmp...Done
            Stopping archiving...Done
            Stopping antivirus...Done
            Stopping antispam...Done
            Stopping imapproxy...Done
            Stopping mailbox...Done
            Stopping logger...Done
            Stopping ldap...Done
    Code:
    zimbra@zimbra:~$ zmcontrol start
    Host zimbra.1-vision.nl
            Starting ldap...Done.
            Starting logger...Done.
            Starting mailbox...Done.
            Starting imapproxy...Done.
            Starting antispam...Done.
            Starting antivirus...Done.
            Starting snmp...Done.
            Starting spell...Done.
            Starting mta...Done.
            Starting stats...Done.
    Code:
    zimbra@zimbra:~$ ps aux | grep mysql
    zimbra   16056  0.0  0.0   6416  1728 pts/0    S    13:27   0:00 /bin/sh /opt/zimbra/logger/mysql/bin/mysqld_safe --defaults-file=/opt/zimbra/conf/my.logger.cnf --external-locking --log-error=/opt/zimbra/log/logger_mysql_error.log --ledir=/opt/zimbra/logger/mysql/libexec
    zimbra   16116  0.0  0.4 129064 18840 pts/0    Sl   13:27   0:00 /opt/zimbra/logger/mysql/libexec/mysqld --defaults-file=/opt/zimbra/conf/my.logger.cnf --basedir=/opt/zimbra/logger/mysql --datadir=/opt/zimbra/logger/db/data --pid-file=/opt/zimbra/logger/db/mysql.pid --skip-external-locking --port=7307 --socket=/opt/zimbra/logger/db/mysql.sock --external-locking
    zimbra   16665  0.0  0.0   6424  1728 pts/0    S    13:27   0:00 /bin/sh /opt/zimbra/mysql/bin/mysqld_safe --defaults-file=/opt/zimbra/conf/my.cnf --external-locking --log-error=/opt/zimbra/log/mysql_error.log --ledir=/opt/zimbra/mysql/libexec
    zimbra   16747  0.1  2.6 1086368 107248 pts/0  Sl   13:27   0:00 /opt/zimbra/mysql/libexec/mysqld --defaults-file=/opt/zimbra/conf/my.cnf --basedir=/opt/zimbra/mysql --datadir=/opt/zimbra/db/data --pid-file=/opt/zimbra/db/mysql.pid --skip-external-locking --port=7306 --socket=/opt/zimbra/db/mysql.sock --external-locking
    zimbra   19432  0.0  0.1  14928  4468 pts/0    S    13:28   0:00 /usr/bin/perl -w /opt/zimbra/libexec/zmstat-mysql
    zimbra   20573  0.0  0.0   2712   580 pts/0    S+   13:29   0:00 grep mysql
    zimbra@zimbra:~$

  10. #10
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Everything has started okay so what is showing in /var/log/zimbra.log and /opt/zimbra/log/mailbox.log ?

Similar Threads

  1. Mailbox stopped, redo.log permissons problem
    By mjfleck2000 in forum Administrators
    Replies: 21
    Last Post: 06-16-2006, 05:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •