Results 1 to 3 of 3

Thread: SSH Authorization problem?

  1. #1
    Join Date
    Jan 2009
    Posts
    8
    Rep Power
    6

    Question SSH Authorization problem?

    I have seen several posts about this issue, and I really feel I have done due diligence to figure this out on my own but with no luck. I am running an Ubuntu 8.04.1 Server. I recently switched to zimbra from Desknow and for the most part I like zimbra better. However I am having a problem when I enter the administration screen and either go to the mail queues or try to edit the server config. Both messages are very simular:
    When trying to edit the server config:
    Message: system failure: exception during auth {RemoteManager:myservername.com->zimbra@myservername.com:22} Error code: service.FAILUE Method: GetServerNIfsRequest Details: soap:Receiver

    When trying to enter the mail queues:
    Message: system failure: exception during auth {RemoteManager:myservername.com->zimbra@myservername.com:22} Error code: service.FAILUE Method: GetMailQueueInfoRequest Details: soap:Receiver

    In the posts I have read, I have tried regenerating the keys, verifying the ssh port, resetting the directory permissions and have even checked to see if the zimbra account was disabled (It was and I used usermod -U zimbra to clear it).

    When I try to ssh into the server as zimbra I get these messages:

    debug1: Connection established.
    debug1: identity file /opt/zimbra/.ssh/zimbra_identity type 2
    debug1: Remote protocol version 2.0, remote software version OpenSSH_4.7p1 Debian-8ubuntu1.2
    debug1: match: OpenSSH_4.7p1 Debian-8ubuntu1.2 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_4.7p1 Debian-8ubuntu1.2
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-cbc hmac-md5 none
    debug1: kex: client->server aes128-cbc hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host 'myservername.com' is known and matches the RSA host key.
    debug1: Found key in /opt/zimbra/.ssh/known_hosts:1
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue: publickey,password
    debug1: Next authentication method: publickey
    debug1: Offering public key: /opt/zimbra/.ssh/zimbra_identity
    debug1: Authentications that can continue: publickey,password
    debug1: Next authentication method: password
    zimbra@myservername.com's password:

    I have tried removing zimbra's password and no luck. I have verified that zimbra is on the line with AllowedUsers in the sshd_config file. I have verified that ssh works from various hosts on the network including local hosts. I also use a private/public keypair to connect and it works fine for my account.
    I have tried flushing my cache and clearing the /opt/jetty/zimbra/work directory. Now I am out of ideas.

    Help??!?!?

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Welcome to the forums

    Code:
    su - zimbra
    zmcontrol -v

  3. #3
    Join Date
    Jan 2009
    Posts
    8
    Rep Power
    6

    Default

    I get:
    Release 5.0.11_GA_2695.UBUNTU8_64 UBUNTU8_64 FOSS edition

Similar Threads

  1. Replies: 0
    Last Post: 07-08-2008, 04:01 PM
  2. Missing Email Problem
    By prox in forum Zimbra Connector for Outlook
    Replies: 6
    Last Post: 03-16-2008, 11:01 PM
  3. Zimbra, WM5.0, AS + problem with regional fonts
    By wojo2000 in forum Zimbra Mobile
    Replies: 7
    Last Post: 06-25-2007, 02:04 AM
  4. Mail Queue SSH Public Key problem
    By markymarknz in forum Installation
    Replies: 6
    Last Post: 06-05-2007, 05:43 PM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •