I migrated from windows to Linux because of its stability,and after the installation of my Red Hat Linux according to the zimbra specification of specifying the partitions.i tried running ./install.sh,i got the following error.

Please fix ur /etc/hosts file to contain:
127.0.0.1 localhost.localdomain localhost

I fixed my/etc/hosts file as follows :
127.0.0.1 localhost.localdomain localhost
192.168.2.188 servername.domain.com servername

The installation continued and got to another question about changing my hostname,i selected no,another came about MX records,i have a webmail running,i changed my domain name to mydomain.com and continued the installation.
After the installation,i created two accounts,i tried sending mails to each of them,it said message sent but i cant find anything on their inboxes.
I am not sure of my global settings and account settings.please help me.

I also downloaded fetchmail for receiving my external mails but cant get it working.
How do i solve these problems and can i use zimbra without the fetchmail.