Results 1 to 6 of 6

Thread: [SOLVED] Issues Reindexing Mail Accounts

Hybrid View

  1. #1
    Join Date
    Mar 2008
    Location
    Sioux Falls
    Posts
    150
    Rep Power
    7

    Default [SOLVED] Issues Reindexing Mail Accounts

    We are having a few users on our systems that are having issues searchign through their inboxes. Well when we go to re-index the mailbox it acts like there is nothing inside the box. Here are the logs that I pulled, Any Ideas?

    2009-02-03 10:00:06,082 WARN [LmtpServer-224942] [name=Email;mid=844;] index - Possibly corrupt index: 1 indexing operations failed in mailbox transaction.
    2009-02-03 10:01:24,915 WARN [LmtpServer-224934] [name=Email;mid=844;] index - Possibly corrupt index: 1 indexing operations failed in mailbox transaction.
    2009-02-03 10:02:46,768 WARN [LmtpServer-224947] [name=Email;mid=844;] index - Possibly corrupt index: 1 indexing operations failed in mailbox transaction.
    2009-02-03 10:11:48,233 WARN [LmtpServer-225021] [name=Email;mid=844;] index - Possibly corrupt index: 5 indexing operations failed in mailbox transaction.
    2009-02-03 10:11:48,233 WARN [LmtpServer-225021] [name=Email;mid=844;] index - Possibly corrupt index: Too many failures (5) trying to indexItemList (total list size=5140) Aborting
    2009-02-03 10:11:48,233 INFO [LmtpServer-225021] [name=Email;mid=844;] mailbox - Deferred Indexing: successfully indexed 0 items in 67ms (0.0/sec). (5 items failed to index). IndexDeferredCount now at 5140
    Eric J Lynner
    Dynamic Business Solutions

    “Computers are good at following instructions, but not at reading your mind.”
    – Donald Knuth

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Have a read through Admin Tools & Tidbits - Part 2 » Zimbra :: Blog as you may be able to use the optimize script to rebuild the tables and generate the indexes. Have not done this myself before but may be a better option that Wiki :: MySQL Crash Recovery. Remember to take a backup first !

  3. #3
    Join Date
    Mar 2008
    Location
    Sioux Falls
    Posts
    150
    Rep Power
    7

    Default

    This is the Fix that Zimbra Gave us today and it worked great. Thanks! Zimbra!!!

    zmprov gmi user@domain.com

    You will get this result:
    zmprov gmi user@domain.com
    mailboxId: ####
    quotaUsed: ######

    This will give you the mailboxId.
    Next go to the index directory:

    cd /opt/zimbra/index/0/{mailboxId}/index/0

    For Example:
    /opt/zimbra/index/0/1244/index/0

    And delete the contents of the above directory.

    Then you can run the indexing command through the command line:

    zmprov rim user@domain.com start.
    Eric J Lynner
    Dynamic Business Solutions

    “Computers are good at following instructions, but not at reading your mind.”
    – Donald Knuth

  4. #4
    Join Date
    Jul 2009
    Posts
    5
    Rep Power
    6

    Default

    I probe this solution, and doesn't work, I'm using zimbra network edition 6.0.1.

    I search the message that I have infront of my, and doesn't find?

    any idea?

  5. #5
    Join Date
    Dec 2009
    Posts
    3
    Rep Power
    5

    Default

    seconded, this did not work for me either.

  6. #6
    Join Date
    Sep 2007
    Posts
    24
    Rep Power
    8

    Default

    This worked perfectly for me.

    I had 2 accounts that would not re index, the other accounts would work fine.

    I had tried re-indexing from the GUI, and the CLI both in and out of maintenance. I followed the steps mentioned there and they worked perfectly, and users can now search their inboxes.

    Thanks for the information

Similar Threads

  1. Mail deferred with Connection timed out
    By Miklos Kalman in forum Administrators
    Replies: 7
    Last Post: 11-17-2012, 06:11 AM
  2. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  3. Migration Assistance
    By dwill in forum Administrators
    Replies: 10
    Last Post: 12-02-2008, 08:20 AM
  4. Help needed to setup up third party Antivirus scanning
    By curious_guy in forum Installation
    Replies: 1
    Last Post: 10-01-2006, 07:15 AM
  5. Mail not getting to mail boxes
    By ehults in forum Installation
    Replies: 5
    Last Post: 10-31-2005, 09:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •