Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 28

Thread: ldap is not starting in new installation

  1. #11
    Join Date
    Dec 2007
    Posts
    445
    Rep Power
    8

    Default

    ok. in future i will take care of it.

    Output is as below :

    # dig any

    ; <<>> DiG 9.3.3rc2 <<>> any
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 859
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    IN ANY

    ;; ANSWER SECTION:
    86400 IN SOA . root.. 20080103 28800 14400 3600000 86400
    86400 IN NS .
    86400 IN A
    86400 IN MX 10 .

    ;; ADDITIONAL SECTION:
    86400 IN A

    ;; Query time: 1 msec
    ;; SERVER: ip#53(ip)
    ;; WHEN: Wed Feb 4 14:56:42 2009
    ;; MSG SIZE rcvd: 152

    # dig mx

    ; <<>> DiG 9.3.3rc2 <<>> mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 11777
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 2

    ;; QUESTION SECTION:
    . IN MX

    ;; ANSWER SECTION:
    . 86400 IN MX 10 .

    ;; AUTHORITY SECTION:
    . 86400 IN NS hostname.

    ;; ADDITIONAL SECTION:
    . 86400 IN A ip
    hostname. 86400 IN A ip

    ;; Query time: 1 msec
    ;; SERVER: ip#53(ip)
    ;; WHEN: Wed Feb 4 14:57:47 2009
    ;; MSG SIZE rcvd: 111


    pls let me know if you need any more details.

  2. #12
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Just performing a dig mx or dig any will not show the necessary information. Use you actual domain but when you post the output just change the domain to something like example.com in the text

  3. #13
    Join Date
    Dec 2007
    Posts
    445
    Rep Power
    8

    Default

    Alright...so here we go ..


    # dig demo.com any

    ; <<>> DiG 9.3.3rc2 <<>> demo.com any
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 859
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;demo.com. IN ANY

    ;; ANSWER SECTION:
    demo.com. 86400 IN SOA abc.com. root.abc.com. 20080103 28800 14400 3600000 86400
    demo.com. 86400 IN NS abc.com.
    demo.com. 86400 IN A 172.16.216.11
    demo.com. 86400 IN MX 10 demo.com.

    ;; ADDITIONAL SECTION:
    abc.com. 86400 IN A 172.16.216.11

    ;; Query time: 1 msec
    ;; SERVER: 172.16.216.11#53(172.16.216.11)
    ;; WHEN: Wed Feb 4 14:56:42 2009
    ;; MSG SIZE rcvd: 152

    # dig demo.com mx

    ; <<>> DiG 9.3.3rc2 <<>> demo.com mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 11777
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 2

    ;; QUESTION SECTION:
    ;demo.com. IN MX

    ;; ANSWER SECTION:
    demo.com. 86400 IN MX 10 demo.com.

    ;; AUTHORITY SECTION:
    demo.com. 86400 IN NS abc.com.

    ;; ADDITIONAL SECTION:
    demo.com. 86400 IN A 172.16.216.11
    abc.com. 86400 IN A 172.16.216.11

    ;; Query time: 1 msec
    ;; SERVER: 10.10.44.112#53(172.16.216.11)
    ;; WHEN: Wed Feb 4 14:57:47 2009
    ;; MSG SIZE rcvd: 111

    # host `hostname`
    abc.com has address 172.16.216.11
    # cat /etc/resolv.conf
    nameserver 172.16.216.11


    I hope this will help...

  4. #14
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Code:
    ;; ADDITIONAL SECTION:
    demo.com. 86400 IN A 172.16.216.11
    abc.com. 86400 IN A 172.16.216.11
    Why do you have two hosts with the same IP address ? This is why the hostname is returning a different name to what you are digging against.

  5. #15
    Join Date
    Dec 2007
    Posts
    445
    Rep Power
    8

    Default

    well..here abc.com is teh hostname of the server on which i have installed zimbra. and demo.com is the domain name.

    please find my DNS entry for your reference :

    @ IN SOA abc.com. root.abc.com. (
    20080103 ; serial (d. adams)
    28800 ; Refresh
    14400 ; Retry
    3600000 ; Expire
    86400 ) ; Minimum



    ;Define the Nameservers


    IN NS abc.com.



    ;Define the Mailservers - Used by sendmail zimbra MTA in RHiL




    demo.com. IN A 172.16.216.11

    IN MX 10 demo.com.








    ;Define localhost

    localhost IN A 127.0.0.1



    and i have configured DNS on the same server ( zimbra server ) where ip address : 172.16.216.11 , hostname is abc.com and domain is demo.com.

    please correct me if i am wrong..

  6. #16
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    I would not do it that way to be honest as there is very little point and it over complicates matters.

    Why not install the server something like zimbra.demo.com, which within the Admin GUI will give you a server called the same name. You can then add a domain alias called demo.com so that any email accounts created will be user@demo.com. If you want abc.com aswell just add that as a separate domain. zimbra.demo.com will require a DNS A record plus a MX record which points demo at zimbra.demo.com.

    If you wish to add abc.com aswell then create a MX record which also points at zimbra.demo.com.

  7. #17
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by chandu View Post
    hostname is abc.com and domain is demo.com.

    please correct me if i am wrong..
    You are not describing a hostname as abc.com - that is a domain name. You should use an FQDN of something like mail.abc.com for the server name (hostname) - your DNS set-up is incorrect and needs to be fixed.
    Last edited by phoenix; 02-05-2009 at 12:44 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #18
    Join Date
    Dec 2007
    Posts
    445
    Rep Power
    8

    Default

    thanks both of u. i am doing changes in DNS as per above instruction n will update you the output of the installation.

  9. #19
    Join Date
    Dec 2007
    Posts
    445
    Rep Power
    8

    Default :(

    i have done below changes in DNS ..pls have a look
    and yes my exiting domain is it demo.example.com

    ##################################################

    [root@mail etc]# tail -30f named.conf



    zone "mail.abc.com" IN {
    type master;
    file "db.mail.abc.com";
    allow-update { none; };
    };


    zone "216.16.172.in-addr.arpa" IN {
    type master;
    file "named.172.16.216";
    allow-update { none; };
    };



    zone "demo.example.com" IN {
    type master;
    file "db.demo.example.com";
    allow-update { none; };
    };


    ################################################## #########################


    [root@mail named]# cat db.mail.abc.com

    ;
    ; Addresses and other host information.
    ;
    @ IN SOA mail.abc.com root.mail.abc.com. (
    10118 ; Serial
    43200 ; Refresh
    3600 ; Retry
    3600000 ; Expire
    2592000 ) ; Minimum
    ; Define the nameservers and the mail servers
    IN NS 172.16.216.11
    IN A 172.16.216.11

    ################################################## ################################################## ###


    [root@mail named]# cat db.demo.example.com
    $TTL 86400
    @ IN SOA mail.abc.com. root.mail.abc.com. (
    20080103 ; serial (d. adams)
    28800 ; Refresh
    14400 ; Retry
    3600000 ; Expire
    86400 ) ; Minimum



    ;Define the Nameservers


    IN NS mail.abc.com.



    ;Define the Mailservers - Used by sendmail zimbra MTA in RHiL




    demo.example.com. IN A 172.16.216.11


    IN MX 10 demo.example.com.



    ;Define localhost

    localhost IN A 127.0.0.1


    [root@mail named]#


    ################################################## ############################################



    [root@mail named]# cat named.172.16.216
    ; This is the .0.168.192.in-addr.arpa. domain database for reverse [zone] mappings

    $TTL 86400
    @ IN SOA mail.abc.com. root.mail.abc.com. (

    20080103 ; Serial
    28800 ; Refresh
    14400 ; Retry
    3600000 ; Expire
    86400 ) ; Minimum

    ; Define the Nameservers

    IN NS mail.abc.com.


    ; Define IP mappings to Hostname in this zone


    11 IN PTR mail.abc.com.

    [root@mail named]#

    ################################################## ############################

    [root@mail etc]# cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    ::1 localhost6.localdomain6 localhost6

    172.16.216.11 mail.abc.com mail

    ################################################## ##########################


    [root@mail etc]# cat /etc/resolv.conf
    nameserver 172.16.216.11
    [root@mail etc]#

    ################################################## ###########################

    [root@mail etc]# hostname
    mail.abc.com
    [root@mail etc]# host `hostname`
    mail.abc.com has address 172.16.216.11
    [root@mail etc]#

    ################################################## #############################


    [root@mail named]# dig demo.example.com mx

    ; <<>> DiG 9.3.3rc2 <<>> demo.example.com mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 32364
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 2

    ;; QUESTION SECTION:
    ;demo.example.com. IN MX

    ;; ANSWER SECTION:
    demo.example.com. 86400 IN MX 10 demo.example.com.

    ;; AUTHORITY SECTION:
    demo.example.com. 86400 IN NS mail.abc.com.

    ;; ADDITIONAL SECTION:
    demo.example.com. 86400 IN A 172.16.216.11
    mail.abc.com. 2592000 IN A 172.16.216.11
    ;; Query time: 1 msec
    ;; SERVER: 172.16.216.11#53(172.16.216.11)
    ;; WHEN: Fri Feb 6 12:10:15 2009
    ;; MSG SIZE rcvd: 116

    ################################################## ################################################## ####

    [root@mail named]# dig demo.example.com any

    ; <<>> DiG 9.3.3rc2 <<>> demo.example.com any
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 5135
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;demo.example.com. IN ANY

    ;; ANSWER SECTION:
    demo.example.com. 86400 IN SOA mail.abc.com. root.mail.abc.com. 20080103 28800 14400 3600000 86400
    demo.example.com. 86400 IN NS mail.abc.com.
    demo.example.com. 86400 IN A 172.16.216.11
    demo.example.com. 86400 IN MX 10 demo.example.com.

    ;; ADDITIONAL SECTION:
    mail.abc.com. 2592000 IN A 172.16.216.11

    ;; Query time: 1 msec
    ;; SERVER: 172.16.216.11#53(172.16.216.11)
    ;; WHEN: Fri Feb 6 12:10:21 2009
    ;; MSG SIZE rcvd: 157

    [root@mail named]#


    ################################################## ################################################## ##

  10. #20
    Join Date
    Dec 2007
    Posts
    445
    Rep Power
    8

    Default

    and if ran the setup then getting below error :


    ** Retrieving CA private key from ldap...failed.
    ** Retrieving CA cert from ldap...failed.
    ** Creating CA private key /opt/zimbra/ssl/zimbra/ca/ca.key...done.
    ** Creating CA cert /opt/zimbra/ssl/zimbra/ca/ca.pem...done.
    Thu Feb 5 11:38:53 2009 done.
    Thu Feb 5 11:38:53 2009 Deploying CA to /opt/zimbra/conf/ca ...
    Thu Feb 5 11:38:53 2009 *** Running as root user: /opt/zimbra/bin/zmcertmgr deployca -localonly
    ** Importing CA /opt/zimbra/ssl/zimbra/ca/ca.pem into CACERTS...done.
    ** Copying CA to /opt/zimbra/conf/ca...done.
    Thu Feb 5 11:38:59 2009 done.
    Thu Feb 5 11:38:59 2009 Creating SSL certificate...
    Thu Feb 5 11:38:59 2009 *** Running as root user: /opt/zimbra/bin/zmcertmgr createcrt self
    ** Creating /opt/zimbra/conf/zmssl.cnf...done
    ** Backup /opt/zimbra/ssl/zimbra to /opt/zimbra/ssl/zimbra.20090205113901
    ** Retrieving server config key zimbraSSLCertificate...failed.
    ** Retrieving server config key zimbraSSLPrivateKey...failed.
    ** Generating a server csr for download
    ** Backup /opt/zimbra/ssl/zimbra to /opt/zimbra/ssl/zimbra.20090205113905
    ** Creating server cert request /opt/zimbra/ssl/zimbra/server/server.csr...done.
    ** Saving server config key zimbraSSLPrivateKey...failed.
    ** Signing cert request /opt/zimbra/ssl/zimbra/server/server.csr...done.
    Thu Feb 5 11:39:08 2009 done.
    Thu Feb 5 11:39:08 2009 Installing mailboxd SSL certificates...
    Thu Feb 5 11:39:08 2009 *** Running as root user: /opt/zimbra/bin/zmcertmgr deploycrt self
    ** Saving server config key zimbraSSLCertificate...failed.
    ** Saving server config key zimbraSSLPrivateKey...failed.
    ** Installing mta certificate and key...done.
    ** Installing slapd certificate and key...done.
    ** Installing proxy certificate and key...done.
    ** Creating pkcs12 file /opt/zimbra/ssl/zimbra/jetty.pkcs12...done.
    ** Creating keystore file /opt/zimbra/mailboxd/etc/keystore...done.
    ** Installing CA to /opt/zimbra/conf/ca...done.
    Thu Feb 5 11:39:16 2009 done.
    Thu Feb 5 11:39:16 2009 checking isEnabled zimbra-ldap
    Thu Feb 5 11:39:16 2009 zimbra-ldap is enabled
    Thu Feb 5 11:39:16 2009 Initializing ldap...
    Thu Feb 5 11:39:16 2009 *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
    IO::Socket::INET: connect: Connection refused at /opt/zimbra/libexec/zmldapinit line 160.
    Thu Feb 5 11:40:22 2009 failed. (28416)
    Thu Feb 5 11:40:22 2009

    ERROR

    Thu Feb 5 11:40:22 2009

    Configuration failed

    Thu Feb 5 11:40:22 2009 Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to
    Thu Feb 5 11:40:22 2009 complete the configuration.
    Thu Feb 5 11:40:22 2009
    Errors have been logged to /tmp/zmsetup.02052009-113240.log



    ################################################

    I have installed zimbra serveral time in past but never faced any problem during installation...i dont knw what's wrong ...pls suggest...

    and one more in the same server zimbra was running fine i have just removed it due to somer requirement and trying to install again ....

    i tried different version of zimbra ..4.5.10 , 5.0.11 and 5.0.12 but in all versions getting same ldap and ssl error....i gone mad now ...pls check above DNS config if any changes need...

Similar Threads

  1. upgrading from 5.0.4 to 5.0.5 opensource
    By smoke in forum Installation
    Replies: 4
    Last Post: 10-19-2008, 11:38 AM
  2. Installation Issues - SLES 10_Zimbra 5.0 Beta 3
    By rhartman in forum Installation
    Replies: 3
    Last Post: 01-14-2008, 07:18 AM
  3. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 11:12 AM
  4. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 07:45 AM
  5. Zimbra on Debian?
    By omry_y in forum Installation
    Replies: 25
    Last Post: 11-04-2005, 11:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •