Results 1 to 9 of 9

Thread: Some mail being deferred

  1. #1
    Join Date
    Apr 2006
    Posts
    4
    Rep Power
    9

    Default Some mail being deferred

    I am tring to send email out to my gmail and to other people and some of the emails just show up in the deferred list in the queues. I can recieve mail, send to other zimbra accounts and most mail gets delivered but not all.

    the error that returns is "connection refussed"

    I do not have a FQDN is that the issue?

    here is my log file

    Code:
     postfix/smtpd[11072]: connect from mailhost.abc.abc[machine_IP]
     postfix/smtpd[11072]: 9E839BC816C: client=mailhost.abc.abc[machine_IP]
     postfix/cleanup[11075]: 9E839BC816C: message-id=<8055815.1871145560823454.JavaMail.root@mailhost>
     postfix/qmgr[8542]: 9E839BC816C: from=, size=894, nrcpt=1 (queue active)
     postfix/smtpd[11072]: disconnect from mailhost.abc.abc[machine_IP]
     amavis[15322]: (15322-10) ESMTP::10024 /opt/zimbra/amavisd/tmp/amavis-20060419T130120-15322:  -> <123@shaw.ca> Recei
    ved: SIZE=894 from mailhost.abc.abc ([127.0.0.1]) by localhost (mailhost.abc.abc [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 15322-10 for <123@shaw.ca>; Thu, 20 Apr 2006
    13:20:23 -0600 (MDT)
     amavis[15322]: (15322-10) Checking: rU48JybOpFQ9 [machine_IP]  -> <123@shaw.ca>
     postfix/smtpd[11080]: connect from localhost.localdomain[127.0.0.1]
     postfix/smtpd[11080]: 15AF7BC8171: client=localhost.localdomain[127.0.0.1]
     postfix/cleanup[11075]: 15AF7BC8171: message-id=<8055815.1871145560823454.JavaMail.root@mailhost>
     postfix/qmgr[8542]: 15AF7BC8171: from=, size=1677, nrcpt=1 (queue active)
     postfix/smtpd[11080]: disconnect from localhost.localdomain[127.0.0.1]
     amavis[15322]: (15322-10) FWD via SMTP:  -> <123@shaw.ca>, 250 2.6.0 Ok, id=15322-10, from MTA([127.0.0.1]:10025): 250 Ok: queued as 15AF
    7BC8171
     amavis[15322]: (15322-10) Passed CLEAN, [machine_IP] [machine_IP]  -> <123@shaw.ca>, Message-ID: <8055815.1871145560823454.JavaMail.roo
    t@mailhost>, mail_id: rU48JybOpFQ9, Hits: -2.608, 497 ms
     postfix/smtp[11076]: 9E839BC816C: to=<123@shaw.ca>, relay=127.0.0.1[127.0.0.1], delay=1, status=sent (250 2.6.0 Ok, id=15322-10, from MTA([127.0.0.1]:10
    025): 250 Ok: queued as 15AF7BC8171)
     postfix/qmgr[8542]: 9E839BC816C: removed
     amavis[15322]: (15322-10) extra modules loaded: Net/LDAP/Bind.pm
     postfix/smtp[11655]: connect to shaw.ca[204.209.208.8]: Connection refused (port 25)
     postfix/smtp[11655]: 15AF7BC8171: to=<123@shaw.ca>, relay=none, delay=0, status=deferred (connect to shaw.ca[204.209.208.8]: Connection refused)
     postfix/smtpd[11072]: connect from unknown[63.216.32.53]

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Hi

    Welcome to the forums.

    It's possible they're rejecting the mail becasue you're on a dynamic(?) IP address. AOL also reject mail from dynamic IP 'home' user running mail servers. The thinking is that the server may be an open relay and they'll stop spam like that.

    If that is the reason then you'd be better off relaying the mail through your ISPs mail server or getting a fixed IP address and 'proper' DNS records.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    123@shaw.ca is that a real address? Did you send that mail? Seems postfix can't connect to 204.209.208.8.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  4. #4
    Join Date
    Apr 2006
    Posts
    4
    Rep Power
    9

    Default

    Thanks for the welcome I have been lurking for a few months off and on and have had my questions addressed digging around the forums

    It's possible they're rejecting the mail becasue you're on a dynamic
    I thought thats what it might be I will try going through an isp for the MTA.

    No that is not a real address I just didn't think that this guy would like it if his email address was public with out his knowledge. It is a working address. the same thing happens when I am sending to my gmail account too. That 204.209.208.8 must be a shaw server (Canadian ISP).


    Thanks

  5. #5
    Join Date
    Apr 2006
    Posts
    4
    Rep Power
    9

    Default

    ok so I have had no luck.

    I followed the post on relaying mail through the ISP with no success.

    so I have setup an additional MX record for the server so it resolves and yet some mail is still getting put into deffered queues.

    I have port 25 open to the server so I am a bit perplexed any help would be great.

    here is the log file of new mail I tried to send. the address work because the are all mine and i was able to send to them in other mail programs.

    Code:
    Apr 21 13:04:20 mailhost postfix/smtp[4045]: connect to gmail.com[216.239.57.83]: Connection timed out (port 25)
    Apr 21 13:04:20 mailhost postfix/smtp[4045]: 9EDEDBC816D: to=, relay=none, delay=75088, status=deferred (connect to gmail.com[216.239.57.83]: Connection timed out)
    Apr 21 13:04:20 mailhost postfix/smtp[4047]: connect to gmail.com[64.233.171.83]: Connection timed out (port 25)
    Apr 21 13:04:20 mailhost postfix/smtp[4047]: DE31FBC816F: to=, relay=none, delay=75089, status=deferred (connect to gmail.com[64.233.171.83]: Connection timed out)
    Apr 21 13:05:34 mailhost postfix/smtpd[4942]: initializing the server-side TLS engine
    Apr 21 13:05:34 mailhost postfix/smtpd[4942]: connect from mailhost.nwp.ca[128.8.1.253]
    Apr 21 13:05:34 mailhost postfix/smtpd[4942]: 298C5BC8169: client=mailhost.nwp.ca[128.8.1.253]
    Apr 21 13:05:34 mailhost postfix/cleanup[4944]: 298C5BC8169: message-id=<5693946.2051145646334065.JavaMail.root@mailhost>
    Apr 21 13:05:34 mailhost postfix/qmgr[17750]: 298C5BC8169: from=, size=649, nrcpt=3 (queue active)
    Apr 21 13:05:34 mailhost postfix/smtpd[4942]: disconnect from mailhost.nwp.ca[128.8.1.253]
    Apr 21 13:05:34 mailhost amavis[17772]: (17772-07) ESMTP::10024 /opt/zimbra/amavisd/tmp/amavis-20060420T163105-17772:  -> ,, Received: SIZE=649 from mailhost.nwp.ca ([127.0.0.1]) by localhost (mailhost.nwp.ca [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 17772-07; Fri, 21 Apr 2006 13:05:34 -0600 (MDT)
    Apr 21 13:05:34 mailhost amavis[17772]: (17772-07) Checking: TIu7WseEVnSD [128.8.1.253]  -> ,,
    Apr 21 13:05:34 mailhost postfix/smtpd[4949]: initializing the server-side TLS engine
    Apr 21 13:05:34 mailhost postfix/smtpd[4949]: connect from localhost.localdomain[127.0.0.1]
    Apr 21 13:05:34 mailhost postfix/smtpd[4949]: AFEFCBC8172: client=localhost.localdomain[127.0.0.1]
    Apr 21 13:05:34 mailhost postfix/cleanup[4944]: AFEFCBC8172: message-id=<5693946.2051145646334065.JavaMail.root@mailhost>
    Apr 21 13:05:34 mailhost postfix/qmgr[17750]: AFEFCBC8172: from=, size=1385, nrcpt=3 (queue active)
    Apr 21 13:05:34 mailhost amavis[17772]: (17772-07) FWD via SMTP:  -> , , , 250 2.6.0 Ok, id=17772-07, from MTA([127.0.0.1]:10025): 250 Ok: queued as AFEFCBC8172
    Apr 21 13:05:34 mailhost postfix/smtpd[4949]: disconnect from localhost.localdomain[127.0.0.1]
    Apr 21 13:05:34 mailhost amavis[17772]: (17772-07) Passed CLEAN, [128.8.1.253] [128.8.1.253]  -> ,,, Message-ID: <5693946.2051145646334065.JavaMail.root@mailhost>, mail_id: TIu7WseEVnSD, Hits: -2.628, 609 ms
    Apr 21 13:05:34 mailhost postfix/smtp[4945]: 298C5BC8169: to=, relay=127.0.0.1[127.0.0.1], delay=0, status=sent (250 2.6.0 Ok, id=17772-07, from MTA([127.0.0.1]:10025): 250 Ok: queued as AFEFCBC8172)
    Apr 21 13:05:34 mailhost postfix/smtp[4945]: 298C5BC8169: to=, relay=127.0.0.1[127.0.0.1], delay=0, status=sent (250 2.6.0 Ok, id=17772-07, from MTA([127.0.0.1]:10025): 250 Ok: queued as AFEFCBC8172)
    Apr 21 13:05:34 mailhost postfix/smtp[4945]: 298C5BC8169: to=, relay=127.0.0.1[127.0.0.1], delay=0, status=sent (250 2.6.0 Ok, id=17772-07, from MTA([127.0.0.1]:10025): 250 Ok: queued as AFEFCBC8172)
    Apr 21 13:05:34 mailhost amavis[17772]: (17772-07) extra modules loaded: Net/LDAP/Bind.pm
    Apr 21 13:05:34 mailhost postfix/qmgr[17750]: 298C5BC8169: removed
    Apr 21 13:06:03 mailhost zimbramon[5196]: 5196:info: 2006-04-21 13:06:01, STATUS: mailhost.nwp.ca: antispam: Running
    Apr 21 13:06:03 mailhost zimbramon[5196]: 5196:info: 2006-04-21 13:06:01, STATUS: mailhost.nwp.ca: antivirus: Running
    Apr 21 13:06:03 mailhost zimbramon[5196]: 5196:info: 2006-04-21 13:06:01, STATUS: mailhost.nwp.ca: ldap: Running
    Apr 21 13:06:03 mailhost zimbramon[5196]: 5196:info: 2006-04-21 13:06:01, STATUS: mailhost.nwp.ca: logger: Running
    Apr 21 13:06:03 mailhost zimbramon[5196]: 5196:info: 2006-04-21 13:06:01, STATUS: mailhost.nwp.ca: mailbox: Running
    Apr 21 13:06:03 mailhost zimbramon[5196]: 5196:info: 2006-04-21 13:06:01, STATUS: mailhost.nwp.ca: mta: Running
    Apr 21 13:06:03 mailhost zimbramon[5196]: 5196:info: 2006-04-21 13:06:01, STATUS: mailhost.nwp.ca: snmp: Running
    Apr 21 13:06:03 mailhost zimbramon[5196]: 5196:info: 2006-04-21 13:06:01, STATUS: mailhost.nwp.ca: spell: Running
    Apr 21 13:06:04 mailhost postfix/smtp[4047]: connect to gmail.com[64.233.171.83]: Connection timed out (port 25)
    Apr 21 13:06:04 mailhost postfix/smtp[4045]: connect to mac.com[17.250.248.32]: Connection timed out (port 25)
    Apr 21 13:06:04 mailhost postfix/smtp[4045]: AFEFCBC8172: to=, relay=none, delay=30, status=deferred (connect to mac.com[17.250.248.32]: Connection timed out)
    Apr 21 13:06:34 mailhost postfix/smtp[4047]: connect to gmail.com[64.233.161.83]: Connection timed out (port 25)
    Apr 21 13:07:04 mailhost postfix/smtp[4047]: connect to gmail.com[216.239.57.83]: Connection timed out (port 25)
    Apr 21 13:07:04 mailhost postfix/smtp[4047]: AFEFCBC8172: to=, relay=none, delay=90, status=deferred (connect to gmail.com[216.239.57.83]: Connection timed out)
    Thanks

  6. #6
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Does reverse DNS match your server's DNS. ie run "host "

    My guess is your IP block is either black listed or fails the reverse DNS test to these mailservers are blocking you. In almost every case the only solution will to use your ISP's mail relay.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  7. #7
    Join Date
    Apr 2006
    Posts
    4
    Rep Power
    9

    Default

    Thanks
    I added the relay in the admin console server mta feild and it seems to be working now.

  8. #8
    Join Date
    May 2008
    Location
    Perugia
    Posts
    5
    Rep Power
    7

    Default Some mail being deferred

    Hello everyone,

    i have the same error of this post:
    http://www.zimbra.com/forums/adminis...html#post15700

    but my problem still persist. When I added the relay in the admin console server mta feild and it seems to be working for same hours... but now I have the same problem...

    Anyone have an idea???

    Thanks in advance.

    Fabrizio Ortolani

  9. #9
    Join Date
    May 2008
    Location
    Perugia
    Posts
    5
    Rep Power
    7

    Default

    Quote Originally Posted by chreestopher View Post
    Thanks
    I added the relay in the admin console server mta feild and it seems to be working now.
    In my case it works only for 1 day.. now i have the same problem...

    Someone has solved the problem?

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  2. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 09:09 AM
  3. Replies: 3
    Last Post: 07-19-2007, 03:00 AM
  4. DynDNS and Zimbra
    By afterwego in forum Installation
    Replies: 30
    Last Post: 04-01-2007, 04:34 PM
  5. Mail not getting to mail boxes
    By ehults in forum Installation
    Replies: 5
    Last Post: 10-31-2005, 09:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •