Page 1 of 5 123 ... LastLast
Results 1 to 10 of 47

Thread: [SOLVED] MTA Relay

  1. #1
    Join Date
    Jan 2009
    Location
    manila
    Posts
    59
    Rep Power
    6

    Default [SOLVED] MTA Relay

    Fellows;


    We have an existing mail server. This is our primary. Then we set up Zimbra as second mail server.

    Both server's IP are private and are matched to their corresponding public IPs.

    The problem is i cant force the Zimbra (mail2.xxxxxxx.net) to not use MTA Relay (Relay MTA for external delivery: mail.xxxxxxx.net port:25).

    If i disable this or leave it blank this is what happens;

    1) Acounts made by second server can not send mails to the accounts made from the primary server but can receive mails from it. (POP3 ok but SMTP is not ok)

    2) I can receive and send mails to Yahoo Mail.

    Our concern is that it seems like our Zimbra box is dependent on the primary server (Mdaemon on Windows Server) for its outgoing mail traffic.

    What we wanted is that Zimbra must not rely on the primary server so that even if it bogs down, Zimbra can still function.

    HOW CAN I FORCE ZIMBRA TO BE INDEPENDENT?

    When i leave MTA blank, i cant send mails to the primary server anymore.
    Last edited by emcampos; 02-28-2009 at 11:55 PM.

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    What happens ? Also, would you please post what version you are using
    Code:
    su - zimbra
    zmcontrol -v

  3. #3
    Join Date
    Jan 2009
    Location
    manila
    Posts
    59
    Rep Power
    6

    Default cant send mail to 1st local mail server when MTA Relay is blank

    zimbra@mail2:/home/boss$ zmcontrol -v


    Release 5.0.12_GA_2789.UBUNTU8 UBUNTU8 FOSS edition

    =============================================


    When I installed Ubuntu, i only activated SSH for SSL connection (putty).

    Then I configured the IP address. These are local IP addresses. These are bonded to public IP addresses. Both are served by the same DNS (ISP's DNS). Both public ip for the 2 mail servers have an MX and A records already. We also have a local DNS and the IP address bonded to the hostnames for the 2 servers are local IP addresses. Both MX and A record were added.

    After this, I installed Zimbra. No other configurations done except putting the FQDN of the primary server into the Relay MTA and the email accounts.

    Once, i remove this MTA Relay, it cannot send mail to the primary server anymore.


    ==============


    By the way, here is the error message in the log file;


    zimbra@mail2:/var/log$ sudo tail -f zimbra.log


    Feb 12 16:44:17 mail2 postfix/smtpd[27398]: connect from localhost[127.0.0.1]
    Feb 12 16:44:17 mail2 postfix/smtpd[27398]: B76E9146B01: client=localhost[127.0.0.1]
    Feb 12 16:44:17 mail2 postfix/cleanup[26639]: B76E9146B01: message-id=<29534499.15411234428247768.JavaMail.root@mail2>
    Feb 12 16:44:17 mail2 postfix/smtpd[27398]: disconnect from localhost[127.0.0.1]
    Feb 12 16:44:17 mail2 postfix/qmgr[14661]: B76E9146B01: from=, size=2046, nrcpt=1 (queue active)
    Feb 12 16:44:17 mail2 amavis[12978]: (12978-07) FWD via SMTP: -> ,BODY=7BIT 250 2.6.0 Ok, id=12978-07, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as B76E9146B01
    Feb 12 16:44:17 mail2 postfix/smtp[28081]: connect to xxxxxxxxxx.xxx[10.10.10.250]: Connection refused (port 25)
    Feb 12 16:44:17 mail2 postfix/smtp[28081]: connect to xxxxxxxxxx.xxx[192.168.10.250]: Connection refused (port 25)
    Feb 12 16:44:17 mail2 postfix/smtp[28081]: connect to xxxxxxxxxx.xxx[172.16.10.250]: Connection refused (port 25)
    Feb 12 16:44:18 mail2 amavis[12978]: (12978-07) Passed CLEAN, LOCAL [127.0.0.1] [127.0.0.1] -> , Message-ID: <29534499.15411234428247768.JavaMail.root@mail2>, mail_id: ivWmlSs2GI87, Hits: -4.295, size: 1583, queued_as: B76E9 146B01, 7446 ms
    Feb 12 16:44:18 mail2 postfix/smtp[26728]: 84EE9146AF9: to=, relay=127.0.0.1[127.0.0.1]:10024, delay=8.7, delays=0 .07/0/2.5/6.1, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as B76E9146B01)
    Feb 12 16:44:18 mail2 postfix/qmgr[14661]: 84EE9146AF9: removed
    Feb 12 16:44:18 mail2 postfix/smtp[28081]: B76E9146B01: to=, relay=none, delay=0.11, delays=0.09/0.01/0.01/0, dsn= 4.4.1, status=deferred (connect to xxxxxxxxxx.net[172.16.0.3]: Connection refused)
    Feb 12 16:44:47 mail2 zmmailboxdmgr[29581]: status requested
    Feb 12 16:44:47 mail2 zmmailboxdmgr[29581]: status OK
    Feb 12 16:44:48 mail2 zmmailboxdmgr[29637]: status requested
    Feb 12 16:44:48 mail2 zmmailboxdmgr[29637]: status OK
    Feb 12 16:45:17 mail2 sshd[29675]: Accepted publickey for zimbra from 192.168.1.253 port 45564 ssh2
    Feb 12 16:45:17 mail2 sshd[29678]: Accepted publickey for zimbra from 192.168.1.253 port 45565 ssh2
    Feb 12 16:45:20 mail2 sshd[29681]: Received disconnect from 192.168.1.253: 11: Closed due to user request.
    Feb 12 16:45:20 mail2 sshd[29682]: Received disconnect from 192.168.1.253: 11: Closed due to user request.
    Feb 12 16:45:39 mail2 sshd[29857]: Accepted publickey for zimbra from 192.168.1.253 port 45569 ssh2
    Feb 12 16:45:39 mail2 sshd[29856]: Accepted publickey for zimbra from 192.168.1.253 port 45568 ssh2
    Feb 12 16:45:41 mail2 sshd[29862]: Received disconnect from 192.168.1.253: 11: Closed due to user request.
    Feb 12 16:45:42 mail2 sshd[29882]: Received disconnect from 192.168.1.253: 11: Closed due to user request.
    Feb 12 16:45:57 mail2 sshd[30191]: Accepted publickey for zimbra from 192.168.1.253 port 47143 ssh2
    Feb 12 16:45:59 mail2 postfix/postsuper[30254]: B76E9146B01: removed
    Feb 12 16:45:59 mail2 postfix/postsuper[30254]: Deleted: 1 message
    Feb 12 16:45:59 mail2 sshd[30194]: Received disconnect from 192.168.1.252 11: Closed due to user request.
    Feb 12 16:46:04 mail2 zmmailboxdmgr[30416]: status requested
    Feb 12 16:46:04 mail2 zmmailboxdmgr[30416]: status OK



    mail server 1 IP (MDaemon) (2 int) = 192.168.1.252 172.16.10.252

    mail server 2 (Zimbra) = 192.168.1.253

    local DNS (2 int) = 192.168.1.3 172.16.10.3
    Last edited by emcampos; 02-26-2009 at 06:45 PM.

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Quote Originally Posted by emcampos View Post
    If i disable this or leave it blank this is what happens;
    So what does happen when you set the relay to blank ? Did you restart ZCS once you made that change ?

  5. #5
    Join Date
    Jan 2009
    Location
    manila
    Posts
    59
    Rep Power
    6

    Default

    reference:


    zimbra@mail2:/home/xxxx$ zmcontrol status
    Host mail2.xxxxxxxx.xxx
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Running
    mta Running
    snmp Running
    spell Running
    stats Running

    ================================================== ======
    Last edited by emcampos; 02-12-2009 at 03:00 AM.

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by emcampos View Post
    Release 5.0.12_GA_2789.UBUNTU8 UBUNTU8 FOSS edition
    Please update your forum profile with that information.

    Who set-up the MDaemon server as the relay (and how did they do it) or is this actually a Split Domain set-up? If it's a Split Domain set-up then just reverse the changes that were made to your server.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Join Date
    Jan 2009
    Location
    manila
    Posts
    59
    Rep Power
    6

    Default

    The Mdaemon server was already there when i got in. It's handling 500 users and we are out of slots. We are now trying to find a backup server. If this backup server performs well, we will replace the old server with it.

    I already installed a SquirrelMail on UBUNTU for this second server and I HAD NO HASSLE INSTALLING IT.

    I had no problems at all. It worked fine. It can communicate with the old server without any problem.

    But we decided to try Zimbra.

    Zimbra is feature-rich. It's pretty neat.

    But configuring it is a headache when the setup is complicated.

    I dont know if the old server was configured to be a relay MTA but since the Zimbra worked when i put its FQDN in the Relay MTA field, then it must have been configured to be as such.

    But I was able to put up SquirrelMail without any hassle, then why this with Zimbra now?

    Please help.
    Last edited by emcampos; 02-12-2009 at 03:07 AM.

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    If you wish to run a Zimbra server in the same domain as your MDaemon server then you'll need to set-up a Split Domain system, read the article in the link I've given you in my post above.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    Join Date
    Jan 2009
    Location
    manila
    Posts
    59
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    If you wish to run a Zimbra server in the same domain as your MDaemon server then you'll need to set-up a Split Domain system, read the article in the link I've given you in my post above.
    but we want to make it fully independent from the first server. is this not possible?

    we were able to do that on SquirrelMail. No hassle in installing.

  10. #10
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    You can run it with a different domain name on the Zimbra server, if you want to have the Zimbra server in the same domain as your other mail server then you'll need a Split Domain set-up.

    Squirrelmail is a web front-end for a mail server isn't it? That's not what Zimbra is, it's a full mail server and collaboration suite - you're not comparing like with like.

    What, exactly, is it that you're trying to achieve by using Zimbra?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Daily mail report always reports "No messages found"
    By McPringle in forum Installation
    Replies: 42
    Last Post: 06-13-2011, 09:57 AM
  2. Spam filters bypassed when Relay MTA used.
    By Jimbud in forum Administrators
    Replies: 0
    Last Post: 01-22-2009, 04:47 AM
  3. admin reports being sent to MTA relay
    By dhickey in forum Administrators
    Replies: 5
    Last Post: 09-14-2007, 01:03 PM
  4. Relay MTA
    By PNE in forum Administrators
    Replies: 9
    Last Post: 03-12-2007, 03:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •