Results 1 to 9 of 9

Thread: Hostname on url

Hybrid View

  1. #1
    Join Date
    Nov 2005
    Posts
    96
    Rep Power
    9

    Default Hostname on url

    Hi,

    I upgraded the open source version of 3.0.1 to 3.1 this morning.

    My hostname is abc. And I got a dns setting that say efg points to the global ip of abc.

    with 3.0.1, I used to be able to put efg.mydomain and the web url will not change even after login.

    After I have upgraded, when I put efg.mydomain, I still see the front page but when I login using my username and password, the url changes from efg.mydomain to abc.mydomain which is unresolvable.

    Is there anything that change on this? How can I solve it?

    adrian

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Add ?redirect=0 to the URL and it will force Zimbra not to redirect.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    Join Date
    Nov 2005
    Posts
    96
    Rep Power
    9

    Default

    Hi Kelvin,

    But how can I make that a global change? Since my users will be horrified to know that they have to type that everytime.

    Thanks.

    adrian

  4. #4
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    It's not possible to make this global today. If you want it to be seemless to user's then you'll have to rename your host or update DNS so the servername defined in Zimbra is resolvable via DNS. In the future we plan to add more options to control the redirect and it's value from the admin UI.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  5. #5
    Join Date
    Oct 2005
    Location
    Belgium
    Posts
    68
    Rep Power
    10

    Default

    After I have upgraded, when I put efg.mydomain, I still see the front page but when I login using my username and password, the url changes from efg.mydomain to abc.mydomain which is unresolvable.
    Are you using an Apache server with mod_proxy in front of zimbra?
    If so, you can use mod_rewrite to add ?redirect=0 to the URL

  6. #6
    Join Date
    Nov 2005
    Posts
    96
    Rep Power
    9

    Default

    Hi,

    I got a hack from a forum that used to modify the js files and restarting tomcat.

    It is working now.

    adrian

Similar Threads

  1. Changing Your Hostname
    By manthrax3 in forum Administrators
    Replies: 2
    Last Post: 12-27-2007, 05:15 PM
  2. Change hostname and IP Address!
    By celeron in forum Administrators
    Replies: 6
    Last Post: 07-15-2007, 09:27 PM
  3. Web mail MTA Hostname
    By melody in forum Administrators
    Replies: 16
    Last Post: 04-19-2007, 10:11 AM
  4. rest url and accents
    By lfasci in forum Developers
    Replies: 1
    Last Post: 03-02-2007, 09:58 AM
  5. Installation Cancelled - Zimbra-spell !
    By Ledg in forum Installation
    Replies: 4
    Last Post: 10-19-2006, 02:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •