Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: [SOLVED] Disable AntiSpam

  1. #1
    Join Date
    Jul 2008
    Location
    Montevideo - Uruguay
    Posts
    106
    Rep Power
    7

    Default [SOLVED] Disable AntiSpam

    Hi,

    I have a seperate server running my antispam and antivirus so I would like to disable this services on the Zimbra box.
    I did on the GUI but is still taggin mail as junk, any idea?

    Regards,
    Andres

  2. #2
    Join Date
    Jul 2007
    Location
    San Jose, CA
    Posts
    1,027
    Rep Power
    10

    Default

    After disabling on the GUI did you stop & restart Zimbra services? I don't know if that should be necessary but it might be.

    It should be possible to just prevent the service from starting, but I'm not a good enough search wizard to figure out the right keywords to do this. . .all I can find are other people who wanted to disable it but could not. So try with the GUI and stop/restart, and if this doesn't work please post back.
    Cheers,

    Dan

  3. #3
    Join Date
    Jul 2007
    Location
    San Jose, CA
    Posts
    1,027
    Rep Power
    10

    Default

    I just traded notes with a techie who knows a lot more than I do. . .

    If you haven't already, go to the "Server" section of the GUI, select your domain server (this can only be done on a domain level, not global), click on the "Services" tab, and then uncheck both "Anti-spam" and "Anti-virus" checkboxes. Then go down to the command line and stop, then restart Zimbra (zmcontrol stop and then zmcontrol start).

    If you still are getting stuff in the junk folders after that, double-check to make sure it's Zimbra and not your mail client (Outlook or Thunderbird both do their own spam checking) that's putting stuff in the folders.

    If it is in fact still misbehaving please post back here and we'll file a bug.
    Cheers,

    Dan

  4. #4
    Join Date
    Jul 2008
    Location
    Montevideo - Uruguay
    Posts
    106
    Rep Power
    7

    Default

    Hi Dan, thank you for your reply.

    I still not working. In fact when I installed Zimbra I disabeled those services. Now to be sure that Thunderbird were doing spam checking, I went and check mail mail from the Zimbra WEBMAIL, and the mails were at the Junk Folder.

    I have both, Anti-Spam and Anti-Virus services disabled.
    I'm using Zimbra 5.0.13 GA Release over CentOS 5.2 but I have the same problem (on other servers) running Zimbra 5.0.10 GA Release.

    Thanks for your help.
    Regards,
    Andres

  5. #5
    Join Date
    Jul 2007
    Location
    San Jose, CA
    Posts
    1,027
    Rep Power
    10

    Default

    Quote Originally Posted by agd View Post
    Hi Dan, thank you for your reply.

    I still not working. In fact when I installed Zimbra I disabeled those services. Now to be sure that Thunderbird were doing spam checking, I went and check mail mail from the Zimbra WEBMAIL, and the mails were at the Junk Folder.

    I have both, Anti-Spam and Anti-Virus services disabled.
    I'm using Zimbra 5.0.13 GA Release over CentOS 5.2 but I have the same problem (on other servers) running Zimbra 5.0.10 GA Release.

    Thanks for your help.
    Regards,
    Andres
    Andres, please don't be insulted but I need to be absolutely sure we're looking at apples and apples here. If Thunderbird moves a message to the Junk folder, it will be in the junk folder when you log onto webmail too. There are only two ways to determine which program is tagging the message as spam:
    1. You can just not log onto the server using webmail and wait for NEW messages to come in, and see which folder they land in via webmail;
    2. You can look at the complete headers of the message (this is what I recommend) and see if they have Zimbra's spam headers in them. If they don't, Zimbra isn't the one moving them there.
    I say this because I had some messages that were inexplicably showing up in junk, that had no Zimbra headers on them. It was driving me crazy till I realized that Thunderbird was the one classifying them as spam. The way IMAP works, the junk folder is the same either way unless you tell Thunderbird to put ITS junk in a different place.

    So check out the headers of a junk message, and maybe post them here (with necessary private information obfuscated if you like). It'll help us understand what's up.
    Cheers,

    Dan

  6. #6
    Join Date
    Jul 2008
    Location
    Montevideo - Uruguay
    Posts
    106
    Rep Power
    7

    Default

    Dan, thank you for your time.

    I did exacly what you said ...

    First, I logon at the Webmail with a user account (with Thunderbird closed). At the AntiSpam box I released a message, and the mail (at the Webmail) went directly to the Junk folder.

    I also attach the header of the mail.

    Regards,
    Andres

    "st.mail-srv.com" is the AntiSpam BOX
    "mail.mail-srv.com" is the MX record, and alse the name of the Zimbra mail server.

    Return-Path: tstable@rtmyarn.com
    Received: from mail-srv.com (LHLO mail.mail-srv.com) (192.168.235.1) by
    mail.mail-srv.com with LMTP; Sat, 21 Feb 2009 23:58:53 -0200 (UYST)
    Received: from st.mail-srv.com (unknown [192.168.235.101])
    by mail.mail-srv.com (Postfix) with ESMTP id 610A147902D9
    for ; Sat, 21 Feb 2009 23:58:53 -0200 (UYST)
    Received: from localhost (localhost [127.0.0.1])
    by st.mail-srv.com (Postfix) with ESMTP id EB85EF5D503
    for ; Sat, 21 Feb 2009 23:59:44 +0000 (GMT)
    Resent-From: "Content-filter at st.mail-srv.com"
    Resent-To:
    Resent-Date: Sat, 21 Feb 2009 23:59:44 +0000 (GMT)
    Resent-Message-ID:
    Received: from unknown ([127.0.0.1])
    by localhost (st.mail-srv.com [127.0.0.1]) (amavisd-new, port 9998)
    id vr3RnZ4v59j7 for ;
    Sat, 21 Feb 2009 23:59:44 +0000 (GMT)
    X-Spam-Flag: YES
    X-Spam-Score: 5.327
    X-Spam-Level: *****
    X-Spam-Status: Yes, score=5.327 tag=-999 tag2=4.9 kill=4.9
    tests=[BAYES_99=3.5, DRUGS_ERECTILE=0.282, FB_CIALIS_LEO3=1.441,
    HS_INDEX_PARAM=0.001, RDNS_NONE=0.1, SUBJECT_DRUG_GAP_C=0.003]
    Received: from st.mail-srv.com ([127.0.0.1])
    by localhost (st.mail-srv.com [127.0.0.1]) (amavisd-new, port 10024)
    with ESMTP id vr3RnZ4v59j7 for ;
    Fri, 20 Feb 2009 07:04:14 +0000 (GMT)
    Received: from rtmyarn.com (unknown [84.22.42.50])
    by st.mail-srv.com (Postfix) with SMTP id 28608F5D5B4
    for ; Fri, 20 Feb 2009 07:04:12 +0000 (GMT)
    Received: from flakdonia863ad ([131.231.99.218]:9725 "HELO flakdonia863ad"
    smtp-auth: TLS-CIPHER: TLS-PEER-CN1: )
    by 322a1654rtmyarn.com with ESMTP id 103659952821 (ORCPT
    );
    Fri, 20 Feb 2009 01:03:17 -0800
    Message-ID: <001701c992f7$039df230$062acbcc@flakdonia863ad>
    From: Pete Goode
    To: usuario@mail-srv.com
    Subject: Generic Cialis, branded quality@
    Date: Fri, 20 Feb 2009 01:03:17 -0800
    MIME-Version: 1.0
    Content-Type: text/plain;
    charset="iso-8859-1"
    Content-Transfer-Encoding: 7bit
    X-Priority: 3
    X-MSMail-Priority: Normal
    X-Mailer: Microsoft Outlook Express 6.00.2800.0000
    X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1158
    Last edited by agd; 02-22-2009 at 05:23 PM.

  7. #7
    Join Date
    Jan 2008
    Location
    Pretoria
    Posts
    133
    Rep Power
    7

    Default

    on your servers running zimbra-mta
    zmprov ms -zimbraServiceEnabled antispam
    restart zimbra-mta
    zmmtactl restart

  8. #8
    Join Date
    Jul 2008
    Location
    Montevideo - Uruguay
    Posts
    106
    Rep Power
    7

    Default

    Hi bonobo,

    I did:

    [zimbra@mail ~]$ zmprov ms mail.mail-srv.com -zimbraServiceEnabled Antispam
    [zimbra@mail ~]$ zmmtactl restart
    Rewriting configuration files...done.
    Stopping zmmtaconfig...done.
    Starting zmmtaconfig...done.
    postfix/postfix-script: refreshing the Postfix mail system
    Stopping saslauthd...done.
    Starting saslauthd...done.


    and the problem still happens.
    This configuration is applied at the server configuration, not to the domains, isn't it?

    Thanks,
    Andres
    Last edited by agd; 02-22-2009 at 05:54 PM.

  9. #9
    Join Date
    Jan 2008
    Location
    Pretoria
    Posts
    133
    Rep Power
    7

    Default

    Anti spam is server level. You need to disable for every server you have.
    Maybe try after disabling antispam:
    zmcontrol restart

  10. #10
    Join Date
    Jul 2008
    Location
    Montevideo - Uruguay
    Posts
    106
    Rep Power
    7

    Default

    OK, I restarted Zimbra services and is still continuing checking the antispam/antivirus traffic.

    Is there any service or configuration file that I can check?

    ----

    [zimbra@mail-srv ~]$ zmcontrol stop
    Host mail.mail-srv.com
    Stopping stats...Done
    Stopping mta...Done
    Stopping spell...Done
    Stopping snmp...Done
    Stopping archiving...Done
    Stopping antivirus...Done
    Stopping antispam...Done
    Stopping imapproxy...Done
    Stopping mailbox...Done
    Stopping logger...Done
    Stopping ldap...Done
    [zimbra@mail-srv ~]$ zmcontrol start
    Host mail.mail-srv.com
    Starting ldap...Done.
    Starting logger...Done.
    Starting mailbox...Done.
    Starting snmp...Done.
    Starting spell...Done.
    Starting mta...Done.
    Starting stats...Done.
    [zimbra@mail-srv ~]$ zmcontrol status
    Host mail.mail-srv.com
    ldap Running
    logger Running
    mailbox Running
    mta Running
    snmp Running
    spell Running
    stats Running
    Last edited by agd; 02-24-2009 at 10:14 AM.

Similar Threads

  1. [SOLVED] Disable Thread Function
    By danielw in forum Administrators
    Replies: 2
    Last Post: 10-13-2008, 03:05 AM
  2. [SOLVED] Disable antivirus and antispam
    By wiscalico in forum Installation
    Replies: 2
    Last Post: 06-06-2008, 03:36 AM
  3. AntiSpam
    By osiris in forum Administrators
    Replies: 6
    Last Post: 02-05-2008, 08:14 AM
  4. antispam not working?
    By moebis in forum Installation
    Replies: 16
    Last Post: 12-03-2005, 07:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •