Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: changed ip addr/zmmailboxdctl not running

  1. #1
    Join Date
    Mar 2009
    Posts
    17
    Rep Power
    6

    Unhappy changed ip addr/zmmailboxdctl not running

    I know this topic has been beaten to death(I looked thru all the other posts to no avail...), but I cannot find a solution...although I have found the problem.
    I am running Ubuntu 6.06LTS and Zimbra 5.04 open source. We recently changed ISP providers and got a new set of IP addresses. Unfortunately, the previous ISP dropped me before I could change my servers over gracefully. When I found out what happened, I changed the servers IP address, updated the /etc/hosts file, changed the DNS records and all that good stuff. The hostname was NOT changed. After making all the changes, the mailbox server would still not start. After this, I ran install again which opened up a whole can of worms. Since then, I had to change the LDAP passwords and the MySql passwords, which got the server a little bit better, but the Mailbox server still would not start. Here are the logs/config files:

    Host mail2.leetackle.com
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Stopped
    zmmailboxdctl is not running
    mta Running
    snmp Running
    spell Running
    stats Running


    /etc/hosts

    127.0.0.1 localhost.localdomain localhost
    174.141.0.158 mail2.leetackle.com mail2


    /etc/resolv.conf

    nameserver 174.141.0.151


    #dig mx leetackle.com

    ; <<>> DiG 9.5.0-P2 <<>> mx leetackle.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 6090
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:


    #dig a mail2.leetackle.com

    ; <<>> DiG 9.5.0-P2 <<>> a mail2.leetackle.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 24713
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;mail2.leetackle.com. IN A

    ;; ANSWER SECTION:
    mail2.leetackle.com. 3600 IN A 174.141.0.158

    ;; Query time: 4 msec
    ;; SERVER: 174.141.0.151#53(174.141.0.151)
    ;; WHEN: Tue Mar 3 17:07:05 2009
    ;; MSG SIZE rcvd: 53

    ;leetackle.com. IN MX

    ;; ANSWER SECTION:
    leetackle.com. 3600 IN MX 10 mail2.leetackle.com.

    ;; ADDITIONAL SECTION:
    mail2.leetackle.com. 3600 IN A 174.141.0.158

    ;; Query time: 4 msec
    ;; SERVER: 174.141.0.151#53(174.141.0.151)
    ;; WHEN: Tue Mar 3 17:06:24 2009
    ;; MSG SIZE rcvd: 69


    /var/log/zimbra.log

    Mar 3 17:37:33 mail2 su[3778]: (pam_unix) session opened for user zimbra by (uid=0)
    Mar 3 17:37:36 mail2 zimbramon[3782]: 3782:info: Starting services
    Mar 3 17:37:37 mail2 slapd[3821]: @(#) $OpenLDAP: slapd 2.3.41 (Feb 27 2008 16:13:23) $ ^Iroot@build13.re.zimbra.com:/home/build/p4/main/ThirdParty/openldap/openldap-2.3.41.6z/servers/slapd
    Mar 3 17:37:38 mail2 slapd[3822]: slapd starting
    Mar 3 17:37:45 mail2 zimbramon[3782]: 3782:info: Rewriting configs antispam amavis antivirus amavis webxml mailbox amavis antispam antivirus mta sasl
    Mar 3 17:37:55 mail2 zimbramon[3782]: 3782:info: Starting logger
    Mar 3 17:37:56 mail2 zimbramon[3782]: 3782:info: Starting mailbox
    Mar 3 17:37:56 mail2 zimbramon[4132]: 4132:info: zmmtaconfig: zmmtaconfig started on mail2.leetackle.com with loglevel=3 pid=4132
    Mar 3 17:38:01 mail2 CRON[4336]: (pam_unix) session opened for user zimbra by (uid=0)
    Mar 3 17:38:05 mail2 zmmailboxdmgr[4529]: status requested
    Mar 3 17:38:05 mail2 zmmailboxdmgr[4529]: stale pid 11095 found in /opt/zimbra/log/zmmailboxd.pid: No such process
    Mar 3 17:38:05 mail2 zmmailboxdmgr[4529]: assuming no other instance is running
    Mar 3 17:38:05 mail2 zmmailboxdmgr[4529]: no manager process is running
    Mar 3 17:38:08 mail2 zimbramon[4337]: 4337:info: 2009-03-03 17:38:01, STATUS: mail2.leetackle.com: antispam: Stopped
    Mar 3 17:38:08 mail2 zimbramon[4337]: 4337:info: 2009-03-03 17:38:01, STATUS: mail2.leetackle.com: antivirus: Stopped
    Mar 3 17:38:08 mail2 zimbramon[4337]: 4337:info: 2009-03-03 17:38:01, STATUS: mail2.leetackle.com: ldap: Running
    Mar 3 17:38:08 mail2 zimbramon[4337]: 4337:info: 2009-03-03 17:38:01, STATUS: mail2.leetackle.com: logger: Running
    Mar 3 17:38:08 mail2 zimbramon[4337]: 4337:info: 2009-03-03 17:38:01, STATUS: mail2.leetackle.com: mailbox: Stopped
    Mar 3 17:38:08 mail2 zimbramon[4337]: 4337:info: 2009-03-03 17:38:01, STATUS: mail2.leetackle.com: mta: Stopped
    Mar 3 17:38:08 mail2 zimbramon[4337]: 4337:info: 2009-03-03 17:38:01, STATUS: mail2.leetackle.com: snmp: Stopped
    Mar 3 17:38:08 mail2 zimbramon[4337]: 4337:info: 2009-03-03 17:38:01, STATUS: mail2.leetackle.com: spell: Stopped
    Mar 3 17:38:08 mail2 zimbramon[4337]: 4337:info: 2009-03-03 17:38:01, STATUS: mail2.leetackle.com: stats: Stopped
    Mar 3 17:38:08 mail2 CRON[4336]: (pam_unix) session closed for user zimbra
    Mar 3 17:38:15 mail2 zmmailboxdmgr[4718]: status requested
    Mar 3 17:38:15 mail2 zmmailboxdmgr[4718]: stale pid 11095 found in /opt/zimbra/log/zmmailboxd.pid: No such process
    Mar 3 17:38:15 mail2 zmmailboxdmgr[4718]: assuming no other instance is running
    Mar 3 17:38:15 mail2 zmmailboxdmgr[4718]: no manager process is running
    Mar 3 17:38:15 mail2 zmmailboxdmgr[4725]: start requested
    Mar 3 17:38:15 mail2 zmmailboxdmgr[4725]: checking if another instance of manager is already running
    Mar 3 17:38:15 mail2 zmmailboxdmgr[4725]: stale pid 11095 found in /opt/zimbra/log/zmmailboxd.pid: No such process
    Mar 3 17:38:15 mail2 zmmailboxdmgr[4725]: assuming no other instance is running
    Mar 3 17:38:15 mail2 zmmailboxdmgr[4726]: wrote manager pid 4726 to /opt/zimbra/log/zmmailboxd.pid
    Mar 3 17:38:15 mail2 zmmailboxdmgr[4726]: manager started mailboxd/JVM with pid 4727
    Mar 3 17:38:15 mail2 zimbramon[3782]: 3782:info: Starting antispam
    Mar 3 17:38:16 mail2 zimbramon[4735]: 4735:info: zmmtaconfig: zmmtaconfig already running at 4132
    Mar 3 17:38:18 mail2 amavis[4768]: starting. /opt/zimbra/amavisd/sbin/amavisd at mail2.leetackle.com amavisd-new-2.5.2 (20070627), Unicode aware, LANG="C"
    Mar 3 17:38:18 mail2 amavis[4768]: user=1001, EUID: 1001 (1001); group=, EGID: 1001 1002 1001 5 4 (1001 1002 1001 5 4)
    Mar 3 17:38:18 mail2 amavis[4768]: Perl version 5.008007
    Mar 3 17:38:19 mail2 zmmailboxdmgr[4726]: manager woke up from wait on mailboxd/JVM with pid 4727
    Mar 3 17:38:19 mail2 zmmailboxdmgr[4726]: manager started mailboxd/JVM with pid 4770
    Mar 3 17:38:20 mail2 zmmailboxdmgr[4726]: manager woke up from wait on mailboxd/JVM with pid 4770
    Mar 3 17:38:20 mail2 zmmailboxdmgr[4726]: mailboxd/JVM exited twice in 1 seconds (tolerance=60)
    Mar 3 17:38:20 mail2 amavis[4768]: SpamControl: init_pre_chroot done
    Mar 3 17:38:20 mail2 amavis[4779]: Net::Server: Process Backgrounded
    Mar 3 17:38:20 mail2 amavis[4779]: Net::Server: 2009/03/03-17:38:20 Amavis (type Net::Server::PreForkSimple) starting! pid(4779)
    Mar 3 17:38:20 mail2 amavis[4779]: Net::Server: Binding to UNIX socket file /opt/zimbra/data/amavisd/amavisd.sock using SOCK_STREAM
    Mar 3 17:38:20 mail2 amavis[4779]: Net::Server: Binding to TCP port 10024 on host 127.0.0.1
    Mar 3 17:38:20 mail2 amavis[4779]: Net::Server: Group Not Defined. Defaulting to EGID '1001 1002 1001 5 4'
    Mar 3 17:38:20 mail2 amavis[4779]: Net::Server: User Not Defined. Defaulting to EUID '1001'
    Mar 3 17:38:20 mail2 amavis[4779]: Module Amavis::Conf 2.091
    Mar 3 17:38:20 mail2 amavis[4779]: Module Archive::Zip 1.23
    Mar 3 17:38:20 mail2 amavis[4779]: Module Compress::Zlib 1.42
    Mar 3 17:38:20 mail2 amavis[4779]: Module Convert::TNEF 0.17
    Mar 3 17:38:20 mail2 amavis[4779]: Module Convert::UUlib 1.09
    Mar 3 17:38:20 mail2 amavis[4779]: Module DBD::mysql 4.006
    Mar 3 17:38:20 mail2 amavis[4779]: Module DBI 1.602
    Mar 3 17:38:20 mail2 amavis[4779]: Module DB_File 1.816
    Mar 3 17:38:20 mail2 amavis[4779]: Module Digest::MD5 2.33
    Mar 3 17:38:20 mail2 amavis[4779]: Module Digest::SHA1 2.11
    Mar 3 17:38:20 mail2 amavis[4779]: Module MIME::Entity 5.423
    Mar 3 17:38:20 mail2 amavis[4779]: Module MIME::Parser 5.423
    Mar 3 17:38:20 mail2 amavis[4779]: Module MIME::Tools 5.423
    Mar 3 17:38:20 mail2 amavis[4779]: Module Mail::Header 2.02
    Mar 3 17:38:20 mail2 amavis[4779]: Module Mail::Internet 2.02
    Mar 3 17:38:20 mail2 amavis[4779]: Module Mail::SpamAssassin 3.002004
    Mar 3 17:38:20 mail2 amavis[4779]: Module Net:NS 0.63
    Mar 3 17:38:20 mail2 amavis[4779]: Module Net::LDAP 0.34
    Mar 3 17:38:20 mail2 amavis[4779]: Module Net::Server 0.97
    Mar 3 17:38:20 mail2 amavis[4779]: Module Time::HiRes 1.9712
    Mar 3 17:38:20 mail2 amavis[4779]: Module URI 1.35
    Mar 3 17:38:20 mail2 amavis[4779]: Module Unix::Syslog 1.0
    Mar 3 17:38:20 mail2 amavis[4779]: Amavis:B code NOT loaded
    Mar 3 17:38:20 mail2 amavis[4779]: Amavis::Cache code NOT loaded
    Mar 3 17:38:20 mail2 amavis[4779]: SQL base code NOT loaded
    Mar 3 17:38:20 mail2 amavis[4779]: SQL::Log code NOT loaded
    Mar 3 17:38:20 mail2 amavis[4779]: SQL::Quarantine NOT loaded
    Mar 3 17:38:20 mail2 amavis[4779]: Lookup::SQL code NOT loaded
    Mar 3 17:38:20 mail2 amavis[4779]: Lookup::LDAP code loaded
    Mar 3 17:38:20 mail2 amavis[4779]: AM.PDP-in proto code loaded
    Mar 3 17:38:20 mail2 amavis[4779]: SMTP-in proto code loaded
    Mar 3 17:38:20 mail2 amavis[4779]: Courier proto code NOT loaded
    Mar 3 17:38:20 mail2 amavis[4779]: SMTP-out proto code loaded
    Mar 3 17:38:20 mail2 amavis[4779]: Pipe-out proto code NOT loaded
    Mar 3 17:38:20 mail2 amavis[4779]: BSMTP-out proto code NOT loaded
    Mar 3 17:38:20 mail2 amavis[4779]: Local-out proto code loaded
    Mar 3 17:38:20 mail2 amavis[4779]: OS_Fingerprint code NOT loaded
    Mar 3 17:38:20 mail2 amavis[4779]: ANTI-VIRUS code loaded
    Mar 3 17:38:20 mail2 amavis[4779]: ANTI-SPAM code loaded
    Mar 3 17:38:20 mail2 amavis[4779]: ANTI-SPAM-SA code loaded
    Mar 3 17:38:20 mail2 amavis[4779]: Unpackers code loaded
    Mar 3 17:38:20 mail2 amavis[4779]: Found $file at /usr/bin/file
    Mar 3 17:38:20 mail2 amavis[4779]: No $dspam, not using it
    Mar 3 17:38:20 mail2 amavis[4779]: No $altermime, not using it
    Mar 3 17:38:20 mail2 amavis[4779]: Internal decoder for .mail
    Mar 3 17:38:20 mail2 amavis[4779]: Internal decoder for .asc
    Mar 3 17:38:20 mail2 amavis[4779]: Internal decoder for .uue
    Mar 3 17:38:20 mail2 amavis[4779]: Internal decoder for .hqx
    Mar 3 17:38:20 mail2 amavis[4779]: Internal decoder for .ync
    Mar 3 17:38:20 mail2 amavis[4779]: No decoder for .F tried: unfreeze, freeze -d, melt, fcat
    Mar 3 17:38:20 mail2 amavis[4779]: Found decoder for .Z at /bin/uncompress
    Mar 3 17:38:20 mail2 amavis[4779]: Found decoder for .gz at /bin/gzip -d
    Mar 3 17:38:20 mail2 amavis[4779]: Found decoder for .bz2 at /usr/bin/bzip2 -d
    Mar 3 17:38:20 mail2 amavis[4779]: No decoder for .lzo tried: lzop -d
    Mar 3 17:38:20 mail2 amavis[4779]: No decoder for .rpm tried: rpm2cpio.pl, rpm2cpio
    Mar 3 17:38:20 mail2 amavis[4779]: Found decoder for .cpio at /bin/cpio
    Mar 3 17:38:20 mail2 amavis[4779]: Found decoder for .tar at /bin/cpio
    Mar 3 17:38:20 mail2 amavis[4779]: No decoder for .deb tried: ar
    Mar 3 17:38:20 mail2 amavis[4779]: Internal decoder for .zip
    Mar 3 17:38:20 mail2 amavis[4779]: No decoder for .7z tried: 7zr, 7za, 7z
    Mar 3 17:38:20 mail2 amavis[4779]: No decoder for .rar tried: rar, unrar
    Mar 3 17:38:20 mail2 amavis[4779]: No decoder for .arj tried: arj, unarj
    Mar 3 17:38:20 mail2 amavis[4779]: No decoder for .arc tried: nomarch, arc
    Mar 3 17:38:20 mail2 amavis[4779]: No decoder for .zoo tried: zoo, unzoo
    Mar 3 17:38:20 mail2 amavis[4779]: No decoder for .lha tried: lha
    Mar 3 17:38:20 mail2 amavis[4779]: No decoder for .cab tried: cabextract
    Mar 3 17:38:20 mail2 amavis[4779]: No decoder for .tnef tried: tnef
    Mar 3 17:38:20 mail2 amavis[4779]: Internal decoder for .tnef
    Mar 3 17:38:20 mail2 amavis[4779]: No decoder for .exe tried: rar, unrar; lha; arj, unarj
    Mar 3 17:38:20 mail2 amavis[4779]: Using primary internal av scanner code for ClamAV-clamd
    Mar 3 17:38:20 mail2 amavis[4779]: SpamControl: initializing Mail::SpamAssassin
    Mar 3 17:38:21 mail2 zimbramon[3782]: 3782:info: Starting antivirus
    Mar 3 17:38:21 mail2 zimbramon[4788]: 4788:info: zmmtaconfig: zmmtaconfig already running at 4132
    Mar 3 17:38:22 mail2 clamd[4826]: clamd daemon 0.92.1 (OS: linux-gnu, ARCH: i386, CPU: i686)
    Mar 3 17:38:22 mail2 clamd[4826]: Log file size limited to 20971520 bytes.
    Mar 3 17:38:22 mail2 clamd[4826]: Reading databases from /opt/zimbra/data/clamav/db
    Mar 3 17:38:22 mail2 clamd[4826]: Not loading PUA signatures.
    Mar 3 17:38:22 mail2 amavis[4779]: SpamControl: init_pre_fork done
    Mar 3 17:38:31 mail2 clamd[4826]: Loaded 513588 signatures.
    Mar 3 17:38:31 mail2 clamd[4826]: Bound to tcp port 3310
    Mar 3 17:38:31 mail2 clamd[4826]: Setting connection queue length to 15
    Mar 3 17:38:31 mail2 clamd[4826]: Archive: Archived file size limit set to 104857600 bytes.
    Mar 3 17:38:31 mail2 clamd[4826]: Archive: Recursion level limit set to 8.
    Mar 3 17:38:31 mail2 clamd[4826]: Archive: Files limit set to 1000.
    Mar 3 17:38:31 mail2 clamd[4826]: Archive: Compression ratio limit set to 250.
    Mar 3 17:38:31 mail2 clamd[4826]: Archive support enabled.
    Mar 3 17:38:31 mail2 clamd[4826]: Algorithmic detection enabled.
    Mar 3 17:38:31 mail2 clamd[4826]: Portable Executable support enabled.
    Mar 3 17:38:31 mail2 clamd[4826]: ELF support enabled.
    Mar 3 17:38:31 mail2 clamd[4826]: Mail files support enabled.
    Mar 3 17:38:31 mail2 clamd[4826]: Mail: Recursion level limit set to 64.
    Mar 3 17:38:31 mail2 clamd[4826]: OLE2 support enabled.
    Mar 3 17:38:31 mail2 clamd[4826]: PDF support disabled.
    Mar 3 17:38:31 mail2 clamd[4826]: HTML support enabled.
    Mar 3 17:38:31 mail2 clamd[4826]: Self checking every 1800 seconds.
    Mar 3 17:38:31 mail2 zimbramon[3782]: 3782:info: Starting snmp
    Mar 3 17:38:31 mail2 zimbramon[3782]: 3782:info: Starting spell
    Mar 3 17:38:32 mail2 zimbramon[3782]: 3782:info: Starting mta
    Mar 3 17:38:32 mail2 zimbramon[4873]: 4873:info: zmmtaconfig: zmmtaconfig already running at 4132
    Mar 3 17:38:34 mail2 postfix/postfix-script[4950]: warning: not owned by root: /opt/zimbra/postfix-2.4.3.4z/conf/main.cf
    Mar 3 17:38:34 mail2 postfix/postfix-script[4963]: starting the Postfix mail system
    Mar 3 17:38:34 mail2 postfix/master[4964]: daemon started -- version 2.4.3, configuration /opt/zimbra/postfix-2.4.3.4z/conf
    Mar 3 17:38:34 mail2 postfix/qmgr[4976]: 0783E200251: from=<>, size=4935, nrcpt=1 (queue active)
    Mar 3 17:38:34 mail2 saslauthd[4979]: detach_tty : master pid is: 4979
    Mar 3 17:38:34 mail2 saslauthd[4979]: ipc_init : listening on socket: /opt/zimbra/cyrus-sasl-2.1.22.3z/state/mux
    Mar 3 17:38:34 mail2 zimbramon[3782]: 3782:info: Starting stats
    Mar 3 17:38:34 mail2 postfix/qmgr[4976]: 0A5F22000E3: from=<>, size=22001, nrcpt=1 (queue active)
    Mar 3 17:38:34 mail2 postfix/qmgr[4976]: 0F043200135: from=<>, size=3942, nrcpt=1 (queue active)
    Mar 3 17:38:34 mail2 postfix/qmgr[4976]: 137E1200059: from=<>, size=46983, nrcpt=1 (queue active)
    Mar 3 17:38:34 mail2 postfix/qmgr[4976]: 243AE200228: from=<>, size=4150, nrcpt=1 (queue active)
    Mar 3 17:38:34 mail2 postfix/qmgr[4976]: 2D00D2002DD: from=<>, size=5271, nrcpt=1 (queue active)
    Mar 3 17:38:34 mail2 postfix/qmgr[4976]: 3B6D020028F: from=<>, size=3188, nrcpt=1 (queue active)
    Mar 3 17:38:34 mail2 postfix/qmgr[4976]: 3B35A20028A: from=<>, size=3840, nrcpt=1 (queue active)
    Mar 3 17:38:34 mail2 postfix/qmgr[4976]: 363C52001D3: from=<>, size=3760, nrcpt=1 (queue active)
    Mar 3 17:38:34 mail2 postfix/qmgr[4976]: 7B4D02000C7: from=<>, size=4149, nrcpt=1 (queue active)
    Mar 3 17:38:34 mail2 postfix/qmgr[4976]: 753C1200299: from=<>, size=4459, nrcpt=1 (queue active)
    Mar 3 17:38:34 mail2 postfix/qmgr[4976]: 8AA6420014E: from=<>, size=3556, nrcpt=1 (queue active)
    Mar 3 17:38:34 mail2 postfix/qmgr[4976]: 903DF20029D: from=<>, size=5056, nrcpt=1 (queue active)
    Mar 3 17:38:34 mail2 postfix/qmgr[4976]: 9809A2000CF: from=<>, size=16145, nrcpt=1 (queue active)
    Mar 3 17:38:34 mail2 postfix/qmgr[4976]: B53D1200226: from=<>, size=5284, nrcpt=1 (queue active)
    Mar 3 17:38:34 mail2 postfix/qmgr[4976]: BC6F3200256: from=<>, size=16151, nrcpt=1 (queue active)
    Mar 3 17:38:34 mail2 postfix/qmgr[4976]: C93A5200277: from=<>, size=5116, nrcpt=1 (queue active)
    Mar 3 17:38:34 mail2 postfix/qmgr[4976]: CA91A200287: from=<>, size=3641, nrcpt=1 (queue active)
    Mar 3 17:38:34 mail2 postfix/qmgr[4976]: D9D91200369: from=<>, size=15925, nrcpt=1 (queue active)
    Mar 3 17:38:34 mail2 postfix/qmgr[4976]: EDE6620033F: from=<>, size=42023, nrcpt=1 (queue active)
    Mar 3 17:38:34 mail2 postfix/qmgr[4976]: 0C71D2002B0: from=<>, size=7066, nrcpt=1 (queue active)
    Mar 3 17:38:34 mail2 postfix/qmgr[4976]: 0E3E12002C7: from=<>, size=7009, nrcpt=1 (queue active)
    Mar 3 17:38:34 mail2 postfix/qmgr[4976]: 12506200319: from=<2transatlantic@kevinmd.com>, size=1674, nrcpt=1 (queue active)
    Mar 3 17:38:35 mail2 postfix/qmgr[4976]: 12D242003C8: from=, size=33286, nrcpt=2 (queue active)
    Mar 3 17:38:35 mail2 postfix/lmtp[5013]: connect to mail2.leetackle.com[174.141.0.158]: Connection refused (port 7025)
    Mar 3 17:38:35 mail2 postfix/qmgr[4976]: 3FDD02003CD: from=, size=2310, nrcpt=1 (queue active)
    Mar 3 17:38:35 mail2 postfix/lmtp[5017]: connect to mail2.leetackle.com[174.141.0.158]: Connection refused (port 7025)
    Mar 3 17:38:35 mail2 postfix/qmgr[4976]: 3627C2003E6: from=, size=1801, nrcpt=1 (queue active)
    Mar 3 17:38:35 mail2 postfix/lmtp[5027]: connect to mail2.leetackle.com[174.141.0.158]: Connection refused (port 7025)
    Mar 3 17:38:35 mail2 postfix/qmgr[4976]: 3DD26200439: from=, size=11849, nrcpt=1 (queue active)
    Mar 3 17:38:35 mail2 postfix/lmtp[5035]: connect to mail2.leetackle.com[174.141.0.158]: Connection refused (port 7025)
    Mar 3 17:38:35 mail2 postfix/qmgr[4976]: 45E66200314: from=, size=18556, nrcpt=2 (queue active)
    Mar 3 17:38:35 mail2 postfix/lmtp[5042]: connect to mail2.leetackle.com[174.141.0.158]: Connection refused (port 7025)
    Mar 3 17:38:35 mail2 postfix/qmgr[4976]: 57B862001F5: from=, size=31058, nrcpt=1 (queue active)
    Mar 3 17:38:35 mail2 postfix/qmgr[4976]: 5347B20033D: from=, size=6366291, nrcpt=1 (queue active)
    Mar 3 17:38:35 mail2 postfix/qmgr[4976]: 5D0C22003D9: from=, size=4885, nrcpt=1 (queue active)
    Mar 3 17:38:35 mail2 postfix/qmgr[4976]: 5B4302003E5: from=<1.49617.333432363431343038.b@enewsmail.rodalenews. com>, size=18409, nrcpt=1 (queue active)
    Mar 3 17:38:35 mail2 postfix/qmgr[4976]: 643782003DF: from=, size=14909, nrcpt=1 (queue active)
    Mar 3 17:38:35 mail2 postfix/qmgr[4976]: 7B76B2003E7: from=, size=2902, nrcpt=1 (queue active)
    Mar 3 17:38:35 mail2 postfix/qmgr[4976]: 74AAF2003E8: from=, size=18667, nrcpt=1 (queue active)

  2. #2
    Join Date
    Mar 2009
    Posts
    17
    Rep Power
    6

    Default forgot the rest of the log files....

    /opt/zimbra/log/mailbox.log

    This is weird...the file is 0 bytes...maybe because mailbox has yet to start successfully since I rolled over the log files manually.....


    /opt/zimbra/log/zmmailboxd.out

    CompilerOracle: exclude com/zimbra/cs/session/SessionMap.putAndPrune
    0 INFO [main] log - Logging to org.slf4j.impl.Log4jLoggerAdapter(org.mortbay.log) via org.mortbay.log.Slf4jLog
    Zimbra server reserving server socket port=110 bindaddr=66.93.49.35 ssl=false
    Fatal error: exception while binding to ports

    java.net.BindException: Cannot assign requested address
    at java.net.PlainSocketImpl.socketBind(Native Method)
    at java.net.PlainSocketImpl.bind(PlainSocketImpl.java :359)
    at java.net.ServerSocket.bind(ServerSocket.java:319)
    at com.zimbra.common.util.NetUtil.newBoundServerSocke t(NetUtil.java:99)
    at com.zimbra.common.util.NetUtil.bindServerSocket(Ne tUtil.java:122)
    at com.zimbra.common.util.NetUtil.bindTcpServerSocket (NetUtil.java:47)
    at com.zimbra.common.handlers.PrivilegedHandler.openP orts(PrivilegedHandler.java:75)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.mortbay.xml.XmlConfiguration.call(XmlConfigura tion.java:534)
    at org.mortbay.xml.XmlConfiguration.configure(XmlConf iguration.java:244)
    at org.mortbay.xml.XmlConfiguration.configure(XmlConf iguration.java:206)
    at org.mortbay.xml.XmlConfiguration.main(XmlConfigura tion.java:968)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.mortbay.start.Main.invokeMain(Main.java:183)
    at org.mortbay.start.Main.start(Main.java:497)
    at org.mortbay.start.Main.main(Main.java:115)
    CompilerOracle: exclude com/zimbra/cs/session/SessionMap.putAndPrune
    0 INFO [main] log - Logging to org.slf4j.impl.Log4jLoggerAdapter(org.mortbay.log) via org.mortbay.log.Slf4jLog
    Zimbra server reserving server socket port=110 bindaddr=66.93.49.35 ssl=false
    Fatal error: exception while binding to ports
    java.net.BindException: Cannot assign requested address
    at java.net.PlainSocketImpl.socketBind(Native Method)
    at java.net.PlainSocketImpl.bind(PlainSocketImpl.java :359)
    at java.net.ServerSocket.bind(ServerSocket.java:319)
    at com.zimbra.common.util.NetUtil.newBoundServerSocke t(NetUtil.java:99)
    at com.zimbra.common.util.NetUtil.bindServerSocket(Ne tUtil.java:122)
    at com.zimbra.common.util.NetUtil.bindTcpServerSocket (NetUtil.java:47)
    at com.zimbra.common.handlers.PrivilegedHandler.openP orts(PrivilegedHandler.java:75)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.mortbay.xml.XmlConfiguration.call(XmlConfigura tion.java:534)
    at org.mortbay.xml.XmlConfiguration.configure(XmlConf iguration.java:244)
    at org.mortbay.xml.XmlConfiguration.configure(XmlConf iguration.java:206)
    at org.mortbay.xml.XmlConfiguration.main(XmlConfigura tion.java:968)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.mortbay.start.Main.invokeMain(Main.java:183)
    at org.mortbay.start.Main.start(Main.java:497)
    at org.mortbay.start.Main.main(Main.java:115)

    Obviously, the zmmailboxd.out file indicates that the server is still trying to bind to the old IP address. Other than making sure the /etc/hosts file is correct, the A and MX records on the DNS server are correct and reinstalling, where else would the old IP address would be stored? I have tried reinstalling a couple of times.
    The zimbra.log file indicates that mail is coming in....
    The other posts had stop zimbra, check for errant processes and restarting zimbra...nothing
    When the zimbra server is down, there are no active ports(verified with netstat and several nmap scans...), so there is no other mail services running...
    I have tried to manually input the IP address in the /opt/zimbra/mailboxd/etc/jetty.xml.in, /opt/zimbra/mailboxd/etc/zimbra.web.xml.in, /opt/zimbra/mailboxd/etc/zimbraAdmin.web.xml.in files
    I have also tried starting just the zmstorectl command on its own to see if I could get mailbox up...
    At this point I am ready to post my SSH root username and password to the forum if anyone has any ideas...this is happening right during the Dubai boat show and my boss is about to send me a one way ticket to Dubai...Any hope would be greatly appreciated, thanks

  3. #3
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    If you manually rolled the log files then ensure the zimbra user can write to them. Shutdown ZCS and then check no old Zimbra processes are running
    Code:
    ps aux | grep zimbra
    Then start ZCS back up again and check your log files.

  4. #4
    Join Date
    Mar 2009
    Posts
    17
    Rep Power
    6

    Default log file

    already ran:

    sudo chown zimbra:zimbra /opt/zimbra/log/mailbox.log

    and verified this morning....
    nothing is writing to that file...the ip address issue is probably preventing mailboxd from starting....

  5. #5
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    What does the following show ?
    Code:
    su - zimbra
    zmprov -l gs mail2.leetackle.com | grep Bind

  6. #6
    Join Date
    Mar 2009
    Posts
    17
    Rep Power
    6

    Default gotcha...

    zimbraImapBindOnStartup: TRUE
    zimbraImapBindPort: 143
    zimbraImapProxyBindPort: 143
    zimbraImapSSLBindOnStartup: TRUE
    zimbraImapSSLBindPort: 993
    zimbraImapSSLProxyBindPort: 993
    zimbraLmtpBindOnStartup: FALSE
    zimbraLmtpBindPort: 7025
    zimbraMemcachedBindPort: 11211
    zimbraPop3BindAddress: 66.93.49.35
    zimbraPop3BindOnStartup: TRUE
    zimbraPop3BindPort: 110
    zimbraPop3ProxyBindPort: 110
    zimbraPop3SSLBindOnStartup: TRUE
    zimbraPop3SSLBindPort: 995
    zimbraPop3SSLProxyBindPort: 995

  7. #7
    Join Date
    Mar 2009
    Posts
    17
    Rep Power
    6

    Default how...

    do I change it with the zmprov command? Or can I just disable pop3 and see if it helps?
    Last edited by pwhite76; 03-04-2009 at 07:27 AM.

  8. #8
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Code:
    su - zimbra
    zmprov ms mymail.server.com zimbraPop3BindAddress 174.141.0.158
    zmcontrol stop; zmcontrol start

  9. #9
    Join Date
    Mar 2009
    Posts
    17
    Rep Power
    6

    Default almost there...

    all commands were run as the zimbra user:


    $ zmprov -l ms mail2.leetackle.com zimbraPop3BindAddress 174.141.0.158

    $ zmprov -l gs mail2.leetackle.com | grep Bind
    zimbraImapSSLBindPort: 993
    zimbraImapSSLProxyBindPort: 993
    zimbraLmtpBindOnStartup: FALSE
    zimbraLmtpBindPort: 7025
    zimbraMemcachedBindPort: 11211
    zimbraPop3BindAddress: 174.141.0.158
    zimbraPop3BindOnStartup: TRUE
    zimbraPop3BindPort: 110
    zimbraPop3ProxyBindPort: 110
    zimbraPop3SSLBindOnStartup: TRUE
    zimbraPop3SSLBindPort: 995
    zimbraPop3SSLProxyBindPort: 995

    $ zmcontrol stop
    Host mail2.leetackle.com
    Stopping stats...Done
    Stopping mta...Done
    Stopping spell...Done
    Stopping snmp...Done
    Stopping archiving...Done
    Stopping antivirus...Done
    Stopping antispam...Done
    Stopping imapproxy...Done
    Stopping mailbox...Done
    Stopping logger...Done
    Stopping ldap...Done

    $zmcontrol start
    Host mail2.leetackle.com
    Starting ldap...Done.
    Starting logger...Done.
    Starting mailbox...Done.
    Starting antispam...Done.
    Starting antivirus...Done.
    Starting snmp...Done.
    Starting spell...Done.
    Starting mta...Done.
    Starting stats...Done.

    $zmcontrol status
    Host mail2.leetackle.com
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Running
    mta Running
    snmp Running
    spell Running
    stats Running

    so now I can see the light until I try and login(or even access the web interface....)




    Error 404 NOT_FOUND


    HTTP ERROR: 404

    NOT_FOUND

    RequestURI=/


    Powered by jetty://




    From all the other posts that report the same error, the recommendation is to restore from a backup...problem is that I started all this debugging from my latest backup(an rsync of the /opt/zimbra directory)

    Will re-running /opt/zimbra/libexec/zmsetup.pl help at all?

    I am going to try and access my mail via imap to make sure it's still there...

    The president of the company has already indicated that if his email goes away(1000+ messages and hundreds of contacts...), I may go with it....

    Thanks again for all your help, and any additional help you can give me...

  10. #10
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Can you access the webmail interface using the IP address ? Also check /var/log/zimbra.log to see if there were any erroneous error messages on startup ?

Similar Threads

  1. zmmailboxdctl is stopped frequently..
    By tamilnandhu in forum Installation
    Replies: 13
    Last Post: 04-12-2008, 09:59 AM
  2. Can't seem to get global in BES
    By sdemeyer in forum Zimbra Connector for BlackBerry
    Replies: 12
    Last Post: 03-19-2008, 09:22 AM
  3. Replies: 4
    Last Post: 11-14-2007, 02:19 PM
  4. httpd resident in memory but not accessible
    By AlexanderH in forum Installation
    Replies: 3
    Last Post: 05-11-2007, 10:19 AM
  5. Trouble sending mail from Outlook
    By czaveri in forum Users
    Replies: 15
    Last Post: 07-24-2006, 12:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •