Results 1 to 4 of 4

Thread: [SOLVED] Installing VeriSign Secure Site Pro certificate error

Hybrid View

  1. #1
    Join Date
    Mar 2009
    Rep Power

    Default [SOLVED] Installing VeriSign Secure Site Pro certificate error

    Get: "ZIMBRA IOEXCEPTION while handling uploaded certificate "
    See attached screen shot.
    Any idea or known work-arounds? We've tried everything posted in the wiki/forum pages.

    Background Info:
    Release 5.0.15_GA_2851.RHEL5_20090310165728 CentOS5 NETWORK edition

    Running on CentOS 5. During the install I used the --override-platform (or something similar) to force it to to installed the RH5 version on CentOS 5 (which is the same thing from a binary standpoint).

    zmcontrol status:
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Running
    mta Running
    snmp Running
    spell Running
    stats Running
    Attached Images Attached Images

  2. #2
    Join Date
    Oct 2006
    Rep Power


    - check to make sure the certificate file is not corrupt
    open the file in a text editor and make sure there are garbage characters in there

  3. #3
    Join Date
    Mar 2009
    Rep Power


    okay, i was able to get the certs installed
    with the command line steps documented

    # zmcertmgr deploycrt comm /tmp/certs/commercial.crt /tmp/certs/verisign_chain.crt
    ** Verifying /tmp/certs/commercial.crt against /opt/zimbra/ssl/zimbra/commercial/commercial.key
    Certificate (/tmp/certs/commercial.crt) and private key (/opt/zimbra/ssl/zimbra/commercial/commercial.key) match.
    Valid Certificate: /tmp/certs/commercial.crt: OK
    ** Copying /tmp/certs/commercial.crt to /opt/zimbra/ssl/zimbra/commercial/commercial.crt
    ** Appending ca chain /tmp/certs/verisign_chain.crt to /opt/zimbra/ssl/zimbra/commercial/commercial.crt
    ** Saving server config key zimbraSSLCertificate...done.
    ** Saving server config key zimbraSSLPrivateKey...done.
    ** Installing mta certificate and key...done.
    ** Installing slapd certificate and key...done.
    ** Installing proxy certificate and key...done.
    ** Creating pkcs12 file /opt/zimbra/ssl/zimbra/jetty.pkcs12...done.
    ** Creating keystore file /opt/zimbra/mailboxd/etc/keystore...done.
    ** Installing CA to /opt/zimbra/conf/ca...done.

    NOTE however, the GUI installation still fails with the error noted earlier...with the same *.crt files!
    Last edited by hemma; 04-01-2009 at 04:40 PM. Reason: works with cli not with the gui

  4. #4
    Join Date
    Oct 2006
    Rep Power


    Thank you for the update

Similar Threads

  1. Installation zimbra Initializing ldap...failed. (28416)
    By farrukh.nadeem in forum Installation
    Replies: 10
    Last Post: 08-14-2009, 06:52 AM
  2. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  3. [SOLVED] Debian Etch 32 / 64: MTA not working
    By xflip in forum Installation
    Replies: 2
    Last Post: 01-18-2008, 03:58 AM
  4. 3.0 to 4.5.3 Upgrade failed (mysql error)
    By dealt in forum Installation
    Replies: 35
    Last Post: 03-19-2007, 10:30 PM
  5. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 12:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts