Results 1 to 2 of 2

Thread: [SOLVED] Problems with Zimbra 5.0.14 since CentOS 5.3 upgrade

Hybrid View

  1. #1
    Join Date
    Nov 2006
    Rep Power

    Default [SOLVED] Problems with Zimbra 5.0.14 since CentOS 5.3 upgrade

    I upgraded to CentOS 5.3 the other day, rebooted my server and Zimbra seemed happy as can be.

    Over night Zimbra stopped working. I attempted to restart it and it failed complaining ldap was still running and sure enough it was. I killed the running ldap process and then tried to start Zimbra again and this is what I get:

    [zimbra@tiny ~]$ zmcontrol start
            Starting ldap...Done.
            Starting logger...Done.
            Starting mailbox...FAILED
    Starting zmmtaconfig...failed.
    Starting mysqld...done.
    Starting mailboxd...done.
            Starting antispam...Done.
            Starting antivirus...Done.
            Starting snmp...Done.
            Starting spell...Done.
            Starting mta...FAILED
    Starting zmmtaconfig...failed.
    zmmtaconfigctl failed to start
    Starting saslauthd...done.
            Starting stats...Done.
    The only thing that stands out to me in the zimbra.log file is the following:

    Apr  2 09:14:42 tiny amavis[28365]: (28365-01) (!)_DIE: Can't locate in @INC (@INC contains: /opt/zimbra/zimbramon/lib/x86_64-linux-thread-multi /o
    pt/zimbra/zimbramon/lib/i386-linux-thread-multi /opt/zimbra/zimbramon/lib /opt/zimbra/zimbramon/lib/i386-linux-thread-multi /opt/zimbra/zimbramon/lib/i486-lin
    ux-gnu-thread-multi /opt/zimbra/zimbramon/lib/i586-linux-thread-multi /opt/zimbra/zimbramon/lib/x86_64-linux-gnu-thread-multi /opt/zimbra/zimbramon/lib/darwin
    -thread-multi-2level /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.
    8.6/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl
    5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/
    5.8.7/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6/i3...
    Apr  2 09:14:42 tiny amavis[28365]: (28365-01) (!)...86-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl
    /5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386
    -linux-thread-multi /usr/lib/perl5/5.8.8 .) at /opt/zimbra/zimbramon/lib/IO/Socket/ line 61,  line 5.\n
    and here is my Perl version:
    [zimbra@tiny ~]$ perl -v
    This is perl, v5.8.8 built for i386-linux-thread-multi
    Strangely I can login to webmail and send/receive just fine. Any ideas?

  2. #2
    Join Date
    Nov 2006
    Rep Power


    Got it fixed.

    To get rid of the Perl error you can do one of two things (I think).

    What I know worked for me was disabling IPv6 support on CentOS and rebooting.

    This might also work if you don't want to disable IPv6:
    yum install perl-Socket6.i386
    As for the rest of the problem (zmmtaconfig not working) I shut down Zimbra. Made sure there were no more Zimbra processes and then deleted '/opt/zimbra/log/'.

    Problem was solved after that. Zimbra started normally.

    ** Update **
    Guess I could have linked the Wiki page I used to disable IPv6 from's Wiki: FAQ/CentOS5 - CentOS Wiki
    Last edited by fizi; 04-04-2009 at 09:33 AM.

Similar Threads

  1. Replies: 12
    Last Post: 02-25-2008, 06:28 PM
  2. zmperditionctl start asking for password
    By k7sle in forum Administrators
    Replies: 32
    Last Post: 02-20-2008, 10:13 AM
  3. I have problems with en language in zimbra 5.01
    By yuranchik in forum Installation
    Replies: 0
    Last Post: 01-24-2008, 02:23 AM
  4. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 11:34 AM
  5. 4.5 Upgrade failure
    By brained in forum Installation
    Replies: 9
    Last Post: 03-03-2007, 02:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts