I upgraded to CentOS 5.3 the other day, rebooted my server and Zimbra seemed happy as can be.

Over night Zimbra stopped working. I attempted to restart it and it failed complaining ldap was still running and sure enough it was. I killed the running ldap process and then tried to start Zimbra again and this is what I get:

Code:
[zimbra@tiny ~]$ zmcontrol start
Host fizi.ca
        Starting ldap...Done.
        Starting logger...Done.
        Starting mailbox...FAILED
Starting zmmtaconfig...failed.
Starting mysqld...done.
Starting mailboxd...done.


        Starting antispam...Done.
        Starting antivirus...Done.
        Starting snmp...Done.
        Starting spell...Done.
        Starting mta...FAILED
Starting zmmtaconfig...failed.
zmmtaconfigctl failed to start
Starting saslauthd...done.


        Starting stats...Done.
The only thing that stands out to me in the zimbra.log file is the following:

Code:
Apr  2 09:14:42 tiny amavis[28365]: (28365-01) (!)_DIE: Can't locate Socket6.pm in @INC (@INC contains: /opt/zimbra/zimbramon/lib/x86_64-linux-thread-multi /o
pt/zimbra/zimbramon/lib/i386-linux-thread-multi /opt/zimbra/zimbramon/lib /opt/zimbra/zimbramon/lib/i386-linux-thread-multi /opt/zimbra/zimbramon/lib/i486-lin
ux-gnu-thread-multi /opt/zimbra/zimbramon/lib/i586-linux-thread-multi /opt/zimbra/zimbramon/lib/x86_64-linux-gnu-thread-multi /opt/zimbra/zimbramon/lib/darwin
-thread-multi-2level /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.
8.6/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl
5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/
5.8.7/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6/i3...
Apr  2 09:14:42 tiny amavis[28365]: (28365-01) (!)...86-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl
/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386
-linux-thread-multi /usr/lib/perl5/5.8.8 .) at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 61,  line 5.\n
and here is my Perl version:
Code:
[zimbra@tiny ~]$ perl -v

This is perl, v5.8.8 built for i386-linux-thread-multi
Strangely I can login to webmail and send/receive just fine. Any ideas?