Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Installing 5.0.6 on ubuntu 8.04. Ques about host file?

  1. #1
    Join Date
    Apr 2009
    Posts
    34
    Rep Power
    6

    Question Installing 5.0.6 on ubuntu 8.04. Ques about host file?

    Hi experts. I am getting a message about my host file that I thought I set up correctly. Can you please take a look? This is what I am getting. Thanks.

    It seems it wants me to fix the hosts file first..I am not sure exactly how to syntax that host file?

    root@ubuntu:/etc/zcs-5.0.6_GA_2314.UBUNTU8.FRANKLIN# ./install.sh

    Operations logged to /tmp/install.log.4376
    Checking for existing installation...
    zimbra-ldap...NOT FOUND
    zimbra-logger...NOT FOUND
    zimbra-mta...NOT FOUND
    zimbra-snmp...NOT FOUND
    zimbra-store...NOT FOUND
    zimbra-apache...NOT FOUND
    zimbra-spell...NOT FOUND
    zimbra-proxy...NOT FOUND
    zimbra-archiving...NOT FOUND
    zimbra-cluster...NOT FOUND
    zimbra-core...NOT FOUND


    PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE.
    ZIMBRA, INC. ("ZIMBRA") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU
    FIRST ACCEPT THE TERMS OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING
    THE SOFTWARE, OR USING THE PRODUCT, YOU ARE CONSENTING TO BE BOUND BY
    THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS
    AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE PRODUCT.

    License Terms for the Zimbra Collaboration Suite:
    http://www.zimbra.com/license/zimbra..._eula_2.1.html


    Press Return to continue


    ERROR: Installation can not proceeed. Please fix your /etc/hosts file
    to contain:



    Where is the ip address of the host,
    is the FULLY QUALIFIED host name, and
    is the (optional) hostname-only portion

    root@ubuntu:/etc/zcs-5.0.6_GA_2314.UBUNTU8.FRANKLIN#

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    It's somewhat difficult to comment as you've not provided the contents of your /etc/hosts file. Please post the output of the following:
    Code:
    cat /etc/hosts
    cat/etc/resolv/conf
    dig yourdomain.com any 
    dig yourdomain.com mx
    host `hostname`  <-- type that command exactly and us ebackticks not single quotes
    Then read the Quick Start Installation Guide then this documentation, I assume that's the version you're running?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    BTW, you should download the most recent version of ZImbra from this page and install that. The version that you're installing is not a Zimbra released product and is not supported, get the correct version installed.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    Join Date
    Apr 2009
    Posts
    34
    Rep Power
    6

    Default

    I just found that out. Sorry for the trouble. This seems like a great forum. I will try that now and report back!

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by Linuxwho? View Post
    I just found that out. Sorry for the trouble. This seems like a great forum. I will try that now and report back!
    It's no trouble but please post the output I've asked you for before you try the install again.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    Join Date
    Apr 2009
    Posts
    34
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    It's no trouble but please post the output I've asked you for before you try the install again.
    Some notes on my part:
    1. "MYdomain.com" is not really my domain, I just replaced the text of course.
    2. My servers name is really ubuntu...that may be throwing things off or is that ok? Is the entry "local host" conflicting with my servername ebtry of "ubuntu?"
    3. Should my internal domain name be the same as my external domain name? I am not sure how to even create a domain in Linux or if you need a domain controller like Microsoft? I just used what was in the host file to begin with for domain.

    Ok, Here it is:
    COMMAND cat /etc/hosts
    root@ubuntu:/home/owner# cat /etc/hosts
    127.0.0.1 localhost.localdomain.com localhost
    127.0.1.1 ubuntu
    192.168.1.110 mail.mydomain.com mail

    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    root@ubuntu:/home/owner#


    COMMAND cat/etc/resolv/conf
    root@ubuntu:/home/owner# cat/etc/resolv/conf
    bash: cat/etc/resolv/conf: No such file or directory
    root@ubuntu:/home/owner#



    COMMAND dig yourdomain.com any
    root@ubuntu:/home/owner# dig mydomain.com any

    ; <<>> DiG 9.4.2-P2 <<>> mydomain.com any
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 59355
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;mydomain.com. IN ANY

    ;; ANSWER SECTION:
    mydomain.com. 604800 IN SOA mail.mydomain.com. admin.mydomain.com. 70725 604800 86400 2419200 604800
    mydomain.com. 604800 IN NS mail.mydomain.com.
    mydomain.com. 604800 IN MX 10 mail.mydomain.com.
    mydomain.com. 604800 IN A 192.168.1.110

    ;; ADDITIONAL SECTION:
    mail.mydomain.com. 604800 IN A 192.168.1.110

    ;; Query time: 1 msec
    ;; SERVER: 192.168.1.110#53(192.168.1.110)
    ;; WHEN: Tue Apr 7 20:13:13 2009
    ;; MSG SIZE rcvd: 140

    root@ubuntu:/home/owner#

    COMMAND dig yourdomain.com mx
    root@ubuntu:/home/owner# dig mydomain.com mx

    ; <<>> DiG 9.4.2-P2 <<>> mydomain.com mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 25955
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;mydomain.com. IN MX

    ;; ANSWER SECTION:
    mydomain.com. 604800 IN MX 10 mail.mydomain.com.

    ;; AUTHORITY SECTION:
    mydomain.com. 604800 IN NS mail.mydomain.com.

    ;; ADDITIONAL SECTION:
    mail.mydomain.com. 604800 IN A 192.168.1.110

    ;; Query time: 1 msec
    ;; SERVER: 192.168.1.110#53(192.168.1.110)
    ;; WHEN: Tue Apr 7 20:14:53 2009
    ;; MSG SIZE rcvd: 82

    root@ubuntu:/home/owner#

    COMMAND host `hostname` <-- type that command exactly and us ebackticks not single quotes
    root@ubuntu:/home/owner# host `hostname`
    ubuntu has address 8.15.7.117
    ubuntu has address 63.251.179.13
    Host ubuntu not found: 3(NXDOMAIN)
    root@ubuntu:/home/owner#

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Your 'internal' can be the same or different to your real domain name but I 'd recommend you keep it the same for clarity.

    Your hosts file only needs to contain the following:

    Code:
    127.0.0.1 localhost.localdomain.com localhost
    192.168.1.110 mail.mydomain.com mail
    You would normally have an extry in your /etc/resolv.conf like this:

    Code:
    search mydomain.com 
    nameserver 192.168.1.110
    The set-up in the wiki that I've given you assumes that the Split DNS server resides on your Zimbra server - if you used another DNS server then change that IP.

    You also seem to be getting the correct response from your DNS records but the 'host `hostname`' command is returning the wrong IP - it should return the LAN IP of your Zimbra server. Make the changes I've mentioned the try the host command again.
    Last edited by phoenix; 10-13-2009 at 01:48 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    Join Date
    Apr 2009
    Posts
    34
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    Your 'internal' can be the same or different tro your real domain name but I 'd recommend you keep it the same for clarity.

    Your hosts file only needs to contain the following:

    Code:
    127.0.0.1 localhost.localdomain.com localhost
    192.168.1.110 mail.mydomain.com mail
    You would normally have an extry in your /etc/resolv.conf like this:

    Code:
    search mydomain.com 
    nameserver 192.168.1.110
    The set-up in the wiki that I've given you assumes that the Split DNS server resides on your Zimbra server - if you used another DNS server then change that IP.

    You also seem to be getting the correct response from your DNS records but the 'host `hostname`' command is returning the wrong IP - it should return the LAN IP of your Zimbra server. Make the changes I've mentioned the try the host command again.
    I made the change to the host file but my computer thinks its name is "ubuntu" so I guess it is going out on the net and getting that name. I am rebooting it.

  9. #9
    Join Date
    Apr 2009
    Posts
    34
    Rep Power
    6

    Default

    Nope..its still giving the weird address:

    root@ubuntu:/etc# host `hostname`
    ubuntu has address 63.251.179.13
    ubuntu has address 8.15.7.117
    Host ubuntu not found: 3(NXDOMAIN)
    root@ubuntu:/etc#

    How to you create a domain? Simply by entering it in the host file? Should I change "localdomain to the domain name of my email?

  10. #10
    Join Date
    Apr 2009
    Posts
    34
    Rep Power
    6

    Default

    Here is my named.conf file..should it be populated? Is my server acting as a DNS server? Dumb question but I think the answer is yes?

    "// This is the primary configuration file for the BIND DNS server named.
    //
    // Please read /usr/share/doc/bind9/README.Debian.gz for information on the
    // structure of BIND configuration files in Debian, *BEFORE* you customize
    // this configuration file.
    //
    // If you are just adding zones, please do that in /etc/bind/named.conf.local

    include "/etc/bind/named.conf.options";

    // prime the server with knowledge of the root servers
    zone "." {
    type hint;
    file "/etc/bind/db.root";
    };

    // be authoritative for the localhost forward and reverse zones, and for
    // broadcast zones as per RFC 1912

    zone "localhost" {
    type master;
    file "/etc/bind/db.local";
    };

    zone "127.in-addr.arpa" {
    type master;
    file "/etc/bind/db.127";
    };

    zone "0.in-addr.arpa" {
    type master;
    file "/etc/bind/db.0";
    };

    zone "255.in-addr.arpa" {
    type master;
    file "/etc/bind/db.255";
    };


    Here is named.conf.local


    "//
    zone "mydomain.com" {
    type master;
    file "/etc/bind/db.mydomain.com";
    };
    //

    // Consider adding the 1918 zones here, if they are not used in your
    // organization
    //include "/etc/bind/zones.rfc1918";

    Here is DB.mydomain.com:
    ;
    ; Bind data file for mydomain.com
    ;
    $TTL 604800
    @ IN SOA mail.mydomain.com. admin.mydomain.com. (
    070725 ; Serial
    604800 ; Refresh
    86400 ; Retry
    2419200 ; Expire
    604800 ) ; Negative Cache TTL
    ;
    @ IN NS mail
    IN MX 10 mail
    IN A 192.168.1.110
    mail IN A 192.168.1.110
    Last edited by Linuxwho; 04-08-2009 at 09:26 PM.

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 10:06 AM
  2. Problem installing on Ubuntu
    By snuffelt in forum Installation
    Replies: 3
    Last Post: 03-01-2007, 03:09 PM
  3. Replies: 5
    Last Post: 03-01-2007, 03:20 AM
  4. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  5. Unknown Host ?
    By msentissi in forum Administrators
    Replies: 5
    Last Post: 03-18-2006, 03:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •