Results 1 to 3 of 3

Thread: Outgoing mail issue

  1. #1
    Join Date
    Apr 2009
    Posts
    2
    Rep Power
    6

    Default Outgoing mail issue

    Hi All,
    I am a zimbra newbie, and have migrated my entire mail server over to it, its about 100 users, with about 20 domains in total,

    The issue I am having is that I when I send mail it mostly works on most domains, but on some domains it bounces the mail back to me with unable to look up host wlsh.co.za: Name or service not known which is not hosted locally on the server, but 99% of my other mail goes out fine,

    I am not using an upstream smtp as I have an uncapped solutiona and the ISP for that dont supply upstream smtp but I am pretty sure I have configured it correctly , when I do a dig of the mx record it resolves with no problem here is the dig of the domain's mx record , also I also run my own internal dns server on another server on the internal network (bind9)
    zimbra:~# dig mx wlsh.co.za

    ; <<>> DiG 9.3.4 <<>> mx wlsh.co.za
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 63280
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;wlsh.co.za. IN MX

    ;; ANSWER SECTION:
    wlsh.co.za. 73901 IN MX 5 mx1.mweb.net.

    ;; AUTHORITY SECTION:
    wlsh.co.za. 21167 IN NS ns2.mweb.co.za.
    wlsh.co.za. 21167 IN NS ns1.mweb.co.za.

    ;; Query time: 12 msec
    ;; SERVER: 10.0.200.12#53(10.0.200.12)
    ;; WHEN: Wed Apr 15 19:17:45 2009
    ;; MSG SIZE rcvd: 97


    Is there possibly a setting or something that I may have overlooked, and someone could assist me, I would be most grateful,

    Kind regards

    Brad

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Firstly welcome to the forums

    If you could post the following information it would really help us
    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain mx
    dig yourdomain any
    host `hostname` <- note backticks and not single quotes

  3. #3
    Join Date
    Apr 2009
    Posts
    2
    Rep Power
    6

    Default

    Hi , Thanks for the reply ...


    cat /etc/hosts
    127.0.0.1 localhost
    10.0.200.56 zimbra.elk.msits.co.za zimbra
    10.0.200.11 robby.msits.co.za robby
    10.0.200.1 bell.msits.co.za bell


    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts

    cat /etc/resolv.conf
    search msits.co.za
    nameserver 10.0.200.12
    nameserver 10.0.200.14

    dig msits.co.za

    ; <<>> DiG 9.3.4 <<>> msits.co.za
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 16970
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;msits.co.za. IN A

    ;; AUTHORITY SECTION:
    msits.co.za. 604800 IN SOA ns1.msits.co.za. dnsadmin.msits.co.za. 15710 604800 86400 2419200 604800

    ;; Query time: 0 msec
    ;; SERVER: 10.0.200.12#53(10.0.200.12)
    ;; WHEN: Wed Apr 15 21:18:04 2009
    ;; MSG SIZE rcvd: 78

    dig msits.co.za any

    ; <<>> DiG 9.3.4 <<>> msits.co.za any
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33206
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 7, AUTHORITY: 0, ADDITIONAL: 5

    ;; QUESTION SECTION:
    ;msits.co.za. IN ANY

    ;; ANSWER SECTION:
    msits.co.za. 604800 IN SOA ns1.msits.co.za. dnsadmin.msits.co.za. 15710 604800 86400 2419200 604800
    msits.co.za. 604800 IN NS ns4.mydyndns.org.
    msits.co.za. 604800 IN NS ns1.mydyndns.org.
    msits.co.za. 604800 IN NS ns5.mydyndns.org.
    msits.co.za. 604800 IN NS ns3.mydyndns.org.
    msits.co.za. 604800 IN NS ns2.mydyndns.org.
    msits.co.za. 604800 IN MX 10 bell.msits.co.za.

    ;; ADDITIONAL SECTION:
    ns2.mydyndns.org. 81347 IN A 204.13.249.76
    ns3.mydyndns.org. 362 IN A 208.78.69.76
    ns4.mydyndns.org. 231 IN A 91.198.22.76
    ns5.mydyndns.org. 348 IN A 203.62.195.76
    bell.msits.co.za. 604800 IN A 10.0.200.1

    ;; Query time: 1 msec
    ;; SERVER: 10.0.200.12#53(10.0.200.12)
    ;; WHEN: Wed Apr 15 21:18:32 2009
    ;; MSG SIZE rcvd: 281

    host `hostname`
    zimbra.msits.co.za has address 10.0.200.56

    Um, I think I see where the error is .... there is a difference of the local domain being msits.co.za and the zimbra server is on a subdomain of elk.zimbra.co.za , or am I jumping the gun here ?

    Many thanks

    Bradley

Similar Threads

  1. Messages not being delivered
    By buee in forum Administrators
    Replies: 53
    Last Post: 10-23-2009, 11:28 AM
  2. server dropped connection
    By ferra in forum Installation
    Replies: 20
    Last Post: 10-06-2008, 05:32 PM
  3. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 09:09 AM
  4. fatal: Queue report unavailable - mail system is down
    By zzzzsg in forum Administrators
    Replies: 16
    Last Post: 08-24-2006, 03:31 AM
  5. Seeming variety of problems on suse-9.1
    By Crexis in forum Installation
    Replies: 52
    Last Post: 03-04-2006, 12:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •