Results 1 to 7 of 7

Thread: need help in zimbra replication

  1. #1
    Join Date
    Apr 2009
    Location
    Philippines
    Posts
    15
    Rep Power
    6

    Default need help in zimbra replication

    hello guys,

    sorry for noobish questions. i'm new to this and confused.
    i'm using split dns for my zimbra server here since my server is behind a firewall.
    now, my boss wants me to do an ldap replication

    do i have to add another zone entry in BIND configuration or should i just add an MX and A record in my current zimbra domain?

    thanks for any help,
    Jantoy

  2. #2
    Join Date
    Apr 2009
    Location
    Philippines
    Posts
    15
    Rep Power
    6

    Default

    hi guys,

    i got the firs issue resolved. i just needed to add mx and a records

    my next problem is when i was installing ldap and snmp in replica server
    it won't allow me to continue if hostname and the ldap master are not the same

    in common configuration, if hostname is mail2.zimbra.asi.com and my ldap master hostname is mail.zimbra.asi.com, i can't proceed with the installation

    if i make them the same i get an error later in the installation


    may i know what's wrong with my setup?

  3. #3
    Join Date
    Apr 2009
    Location
    Philippines
    Posts
    15
    Rep Power
    6

    Default

    i'm getting this during installation of replica server
    i got not "a" option

    Code:
    Main menu
    
       1) Common Configuration:
            +Hostname:                             mail2.zimbra.asi.com
            +Ldap master host:                     mail.zimbra.asi.com
            +Ldap port:                            389
            +Ldap Admin password:                  set
            +Require secure interprocess communications: yes                        
            +TimeZone:                             (GMT+08.00) Beijing / Chongqing / Hong Kong / Urumqi
    
       2) zimbra-ldap:                             Enabled
       r) Start servers after configuration        yes
       s) Save config to file
       x) Expand menu
       q) Quit
    
    Address unconfigured (**) items or correct ldap configuration  (? - help)
    on master server

    Code:
    [zimbra@mail ~]$ host `hostname`
    mail.zimbra.asi.com has address 192.36.253.120
    [zimbra@mail ~]$
    dig zimbra.asi.com mx

    Code:
    ; <<>> DiG 9.3.3rc2 <<>> zimbra.asi.com mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 54104
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 1, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;zimbra.asi.com.                        IN      MX
    
    ;; ANSWER SECTION:
    zimbra.asi.com.         3600    IN      MX      5 mail.zimbra.asi.com.
    zimbra.asi.com.         3600    IN      MX      10 mail2.zimbra.asi.com.
    
    ;; AUTHORITY SECTION:
    zimbra.asi.com.         3600    IN      NS      192.36.253.120.zimbra.asi.com.
    
    ;; ADDITIONAL SECTION:
    mail.zimbra.asi.com.    3600    IN      A       192.36.253.120
    mail2.zimbra.asi.com.   3600    IN      A       192.36.253.201
    
    ;; Query time: 12 msec
    ;; SERVER: 192.36.253.120#53(192.36.253.120)
    ;; WHEN: Fri Apr 17 09:48:01 2009
    ;; MSG SIZE  rcvd: 136
    
    [zimbra@mail ~]$
    dig zimbra.asi.com any

    Code:
    ; <<>> DiG 9.3.3rc2 <<>> zimbra.asi.com any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 5419
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;zimbra.asi.com.                        IN      ANY
    
    ;; ANSWER SECTION:
    zimbra.asi.com.         3600    IN      SOA     zimbra.asi.com. root.zimbra.asi.com. 2 10800 3600 604800 3600
    zimbra.asi.com.         3600    IN      NS      192.36.253.120.zimbra.asi.com.
    zimbra.asi.com.         3600    IN      MX      10 mail2.zimbra.asi.com.
    zimbra.asi.com.         3600    IN      MX      5 mail.zimbra.asi.com.
    
    ;; ADDITIONAL SECTION:
    mail.zimbra.asi.com.    3600    IN      A       192.36.253.120
    mail2.zimbra.asi.com.   3600    IN      A       192.36.253.201
    
    ;; Query time: 2 msec
    ;; SERVER: 192.36.253.120#53(192.36.253.120)
    ;; WHEN: Fri Apr 17 09:49:00 2009
    ;; MSG SIZE  rcvd: 177
    
    [zimbra@mail ~]$
    /etc/hosts
    Code:
    [zimbra@mail ~]$ cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1       localhost.localdomain   localhost
    ::1     localhost6.localdomain6 localhost6
    192.36.253.201  mail2.zimbra.asi.com    mail2
    192.36.253.120  mail.zimbra.asi.com     mail
    [zimbra@mail ~]$
    /etc/resolv.conf
    Code:
    [zimbra@mail ~]$ cat /etc/resolv.conf
    ; generated by /sbin/dhclient-script
    nameserver 192.36.253.120
    [zimbra@mail ~]$
    hope this information helps

    anyone got an idea why this is happening?

  4. #4
    Join Date
    Apr 2009
    Location
    Philippines
    Posts
    15
    Rep Power
    6

    Default

    ok, i found something odd

    i can't locate zimbra.asi.com when i do nslookup from slave server

    Code:
    [root@mail2 ~]# nslookup zimbra.asi.com
    Server:         192.36.253.120
    Address:        192.36.253.120#53
    
    *** Can't find zimbra.asi.com: No answer
    ok i think i found the root problem
    my slave server cannot see the master server..

    any ideas on how to resolve this?

  5. #5
    Join Date
    Apr 2009
    Location
    Philippines
    Posts
    15
    Rep Power
    6

    Default

    found out something new, apparently i placed

    192.36.253.201 zimbra2.asi.com zimbra2

    in slave server's /etc/hosts
    changed it to

    192.36.253.201 mail2.zimbra.asi.com mail2

    will give an update on how it goes

  6. #6
    Join Date
    Apr 2009
    Location
    Philippines
    Posts
    15
    Rep Power
    6

    Default

    even in master server, nslookup zimbra.asi.com still gets nothing

    is this because i'm using split dns?

  7. #7
    Join Date
    Apr 2009
    Location
    Philippines
    Posts
    15
    Rep Power
    6

    Default

    i reinstalled the master server and slave server.. they're working fine now

    do i need to configure the servers to use the replica server? is that needed?

Similar Threads

  1. Replies: 8
    Last Post: 01-12-2012, 01:20 AM
  2. slapd message error
    By smoke in forum Administrators
    Replies: 7
    Last Post: 04-27-2008, 03:23 PM
  3. Replies: 12
    Last Post: 02-25-2008, 06:28 PM
  4. [SOLVED] Clamav problem ? What's happening ?
    By aNt1X in forum Installation
    Replies: 23
    Last Post: 02-14-2008, 04:43 AM
  5. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 06:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •