Results 1 to 4 of 4

Thread: DNS problem during installation

  1. #1
    Join Date
    Nov 2006
    Posts
    43
    Rep Power
    8

    Default DNS problem during installation

    Hi there,

    Seems like Zimbra installation is not able to properly resolve server MX record.
    DNS server is on the same host as Zimbra and host is sitting inside my LAN.

    Zimbra 5.0.14
    Centos 5.3 i386 (VMWare ESX 3.5)

    Zimbra server hostname: smb.vhs.com
    Zimbra server IP: 172.16.1.230

    this is error I got
    --
    DNS ERROR resolving smb.vhs.com
    It is suggested that the hostname be resolveable via DNS


    When querying for mx record this is what I got:
    --
    $ dig vhs.com mx

    ; <<>> DiG 9.2.4 <<>> @172.16.1.230 vhs.com mx
    ; (1 server found)
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 16247
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;vhs.com. IN MX

    ;; ANSWER SECTION:
    vhs.com. 86400 IN MX 10 smb.vhs.com.

    ;; AUTHORITY SECTION:
    vhs.com. 86400 IN NS smb.vhs.com.

    ;; ADDITIONAL SECTION:
    smb.vhs.com. 86400 IN A 172.16.1.230



    This is result of reverse query.

    $ dig -x 172.16.1.230

    ; <<>> DiG 9.2.4 <<>> @172.16.1.230 -x 172.16.1.230
    ; (1 server found)
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 45553
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;230.1.16.172.in-addr.arpa. IN PTR

    ;; ANSWER SECTION:
    230.1.16.172.in-addr.arpa. 259200 IN PTR smb.vhs.com.

    ;; AUTHORITY SECTION:
    1.16.172.in-addr.arpa. 259200 IN NS smb.vhs.com.

    ;; ADDITIONAL SECTION:
    smb.vhs.com. 86400 IN A 172.16.1.230

    ;; Query time: 4 msec
    ;; SERVER: 172.16.1.230#53(172.16.1.230)
    ;; WHEN: Thu Apr 23 12:31:50 2009
    ;; MSG SIZE rcvd: 98


    cat /etc/resolv.conf
    search vhs.com
    nameserver 172.16.1.230



    Anyone has idea why I got this error?

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Code:
    cat /etc/hosts
    host `hostname` <- note backticks and not single quotes

  3. #3
    Join Date
    Nov 2006
    Posts
    43
    Rep Power
    8

    Default

    # cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost
    172.16.1.230 smb.vhs.com smb

    [root@smb ~]# host `hostname`
    smb.vhs.com has address 172.16.1.230

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by goran View Post
    this is error I got
    --
    DNS ERROR resolving smb.vhs.com
    It is suggested that the hostname be resolveable via DNS
    At this point you should be asked if you want to change the Domain Name (did that happen?), you should reply 'yes' then continue the install.

    Is the Zimbra behind a firewall? I assume the IP is an ESX NAT address?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. DNS issues in installation
    By JustinHarlow in forum Installation
    Replies: 1
    Last Post: 12-13-2008, 12:26 PM
  2. DNS Problem on CentOS
    By nabbed in forum Installation
    Replies: 7
    Last Post: 06-18-2007, 07:42 AM
  3. SLES10 installation issue (split DNS config)
    By swacongne in forum Installation
    Replies: 2
    Last Post: 03-26-2007, 01:54 AM
  4. Installation problem on CENTOS 4.3 x86_64
    By Fabio in forum Installation
    Replies: 7
    Last Post: 09-07-2006, 08:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •