Results 1 to 6 of 6

Thread: [SOLVED] installation of existing ssl certificate new install. Certificate not expor

Hybrid View

  1. #1
    Join Date
    May 2008
    Location
    Melbourne, Australia
    Posts
    96
    Rep Power
    7

    Default [SOLVED] installation of existing ssl certificate new install. Certificate not expor

    I've just taken my new install live and everything went well except that I didn't export the certificate from the old server before wiping it.

    I have the original files, including the generated csr from the old server, original certificate file and original root ca.

    Is it possible to use the old csr and install the existing certificate I have?

    I do have a backup of the old server, but I'd really rather not re-install it if possible.

    The old server is 5.11 and new one 5.14.

    Thanks,

    Mark
    Mark Hawkins

    Medalist

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Are you not able to import it from within the Admin GUI ?

  3. #3
    Join Date
    May 2008
    Location
    Melbourne, Australia
    Posts
    96
    Rep Power
    7

    Default

    I get an error, which is probably due to the csr, which may be slightly different due to something like the alternative name or location or something.

    Code:
    Your certificate was not installed due to the error : system failure: XXXXX ERROR: Unmatching certificate (/opt/zimbra/mailboxd/webapps/zimbraAdmin/tmp/current.crt) and private key (/opt/zimbra/mailboxd/webapps/zimbraAdmin/tmp/current_comm.key) pair.
    Mark Hawkins

    Medalist

  4. #4
    Join Date
    May 2008
    Location
    Melbourne, Australia
    Posts
    96
    Rep Power
    7

    Default

    I have the original CSR file, can this be used in the new install?
    Mark Hawkins

    Medalist

  5. #5
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Have a read through Bug 23294 – commercial certs fail to install as you may be able to do it from the CLI.

  6. #6
    Join Date
    May 2008
    Location
    Melbourne, Australia
    Posts
    96
    Rep Power
    7

    Default

    I managed to get it working using these instructions
    http://wiki.zimbra.com/index.php?tit...etween_servers
    I didn't have to re-install and export, I just extracted the /opt/zimbra/ssl folder from the backup and followed the instructions to the letter and had no issues.
    Mark Hawkins

    Medalist

Similar Threads

  1. SSL Certificate installation
    By premoddev in forum Administrators
    Replies: 1
    Last Post: 10-24-2012, 09:37 AM
  2. Install a commercial SSL certificate ??
    By nick20 in forum Installation
    Replies: 6
    Last Post: 06-23-2010, 03:08 AM
  3. Fresh Zimbra installation does not work
    By Datax in forum Installation
    Replies: 4
    Last Post: 08-18-2008, 01:18 PM
  4. [SOLVED] ipsCA SSL Certificate Install Problems (Zimbra 5.0.7)
    By thunder04 in forum General Questions
    Replies: 3
    Last Post: 08-14-2008, 08:50 AM
  5. Replies: 0
    Last Post: 01-15-2008, 12:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •